An external email message is not delivered to mail-enabled public folders and you do not receive NDR messages in an Exchange Server 2010 environment

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Article ID: 2645587 - View products that this article applies to.
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Symptoms

Assume that you send an external email message that has valid recipients and invalid recipients (for example, recipients that have empty email addresses) in a Microsoft Exchange Server 2010 environment. One of the recipients is a mail-enabled public folder. In this situation, the email message is not delivered to the mail-enabled public folder, and you do not receive a non-delivery report (NDR) message.

Cause

This issue occurs because the Exchange Server 2010 server stops the message delivery process only for mail-enabled public folders and not for mailbox users when the Exchange server checks the recipient list and encounters an error.

Resolution

To resolve this issue, install the following update rollup:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2
After you apply this update, email messages now are still not delivered to public folder recipients. However, a NDR message is generated.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2645587 - Last Review: July 15, 2014 - Revision: 4.0
Applies to
  • Microsoft Exchange Server 2010 Service Pack 2, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew KB2645587

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