Article ID: 2650066 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

When you try to save an Excel file in Excel for Mac 2011, it does not save.

Can't save an Excel file in Excel 2008 for Mac?

Click here to follow Excel 2008 for Mac troubleshooting methods for this problem

Resolution

IMPORTANT: The location of certain files are different if you have Service Pack 2 (SP2) installed. To check if it is installed, open Word, and then click About Word from the Word menu. If the version number is 14.2.0 or above, you have Service Pack 2 and you should follow the Service Pack 2 steps when provided in this article.

We recommend that you follow the provided methods in this article in order. However, if you have previously tried one of the methods and it has failed, you can jump to another method quickly from this list:

Method 1: Check the Hard Disk Drive name

Make sure the hard disc drive icon has a name. The name can contain numbers as long as it starts with text characters. The name should not contain:
  • All numbers
  • Special characters such as periods (.), commas (,), semi-colons (;), quotation marks ("), and so on.

Method 2: Save the file to a different location

Warning The 255 character file name limit includes the file path location of the file as part of the limit. For example, if you save a file to the desktop all the characters that are contained in this file path will be included: HD\Users\<your user name>\Desktop.

You should first try to save the file to a different location on your local hard disc drive, such as the Desktop or Documents folder. If you cannot save the file to a local hard disc drive location, go to method 3.

If you can save the file locally but you cannot save it to an external device, contact the manufacturer of the external device or Apple.

If you can save the file locally but you cannot save it to a network share, contact the network administrator, your company's IT department, or the owner of the share.


Method 3: Empty the Office 2011 AutoRecovery folder

To empty the AutoRecovery folder, follow these steps if have Service Pack 2 installed:
  1. Quit all applications.
  2. On the File menu, click New Folder.
    A new folder is created on the desktop. The folder will be called "New Folder."

  3. On the Go menu, click Home.
  4. Open Library.
    Note The Library folder is hidden in Mac OS X Lion. To display this folder, hold down the OPTION key while you click the Go menu.

  5. Open Application Support, and then open Microsoft.
  6. Open Office 2011 AutoRecovery.
  7. On the Edit menu, click Select All.
  8. Drag all files into "New Folder" on the desktop.
    The AutoRecovery folder should be empty.

  9. Open Excel for Mac 2011 and try to save a file.
    If you can save a file, review the contents of "New Folder" to decide which files that you want to keep.

    If the problem continues to occur, go to the next method.


To empty the AutoRecovery folder, follow these steps if you do not have Service Pack 2 installed:
  1. Quit all applications.
  2. On the File menu, click New Folder.
    A new folder is created on the desktop. The folder will be called "New Folder."

  3. On the Go menu, click Documents.
  4. Open Microsoft User Data, and then open Office 2011 AutoRecovery.
  5. On the Edit menu, click Select All.
  6. Drag all files into "New Folder" on the desktop.
    The AutoRecovery folder should be empty.

  7. Open Excel for Mac 2011 and try to save a file.
    If you can save a file, review the contents of "New Folder" to decide which files that you want to keep.

    If the problem continues to occur, go to the next method.

Method 4: Remove Excel Preferences

Warning Removing preferences will delete any customizations that were made. These customizations include changes to toolbars, custom dictionaries, and keyboard shortcuts that were created.
  1. Quit all applications.
  2. On the Go menu, click Home.
  3. Open Library.
    Note The Library folder is hidden in Mac OS X Lion. To display this folder, hold down the OPTION key while you click the Go menu.

  4. Open Preferences, and then drag the following file to the desktop:
    • com.microsoft.Excel.plist

    Note If you do not locate this file, Excel is using default preferences. Go to step 6.
  5. Open Excel for Mac 2011, and try to save a file.
    If the problem continues to occur, quit Excel, and restore the file to its original location. Go to step 6.
    If the problem is resolved, drag this file to the Trash.

  6. Quit all applications.
  7. On the Go menu, click Home.
  8. Open Library.
    Note The Library folder is hidden in Mac OS X Lion. To display this folder, hold down the OPTION key while you click the Go menu.

  9. Open Preferences.
    Note If you have Service Pack 2 installed, open Application Support instead of Preferences.
  10. Open Microsoft, and then drag the following file to the desktop:
    • com.microsoft.Excel.prefs.plist

    Note If you do not locate this file, Excel is using default preferences. Go to step 12.

  11. Open Excel for Mac 2011, and try to save a file.
    If the problem continues to occur, quit Excel, and restore the file to its original location. Go to step 12.
    If the problem is resolved, drag this file to the Trash.

  12. Quit all applications.
  13. On the Go menu, click Home.
  14. Open Library.
    Note The Library folder is hidden in Mac OS X Lion. To display this folder, hold down the OPTION key while you click the Go menu.

  15. Open Preferences.
    Note If you have Service Pack 2 installed, open Application Support instead of Preferences.
  16. Open Microsoft, and then open Office 2011. Drag the following file to the desktop:
    • Microsoft Excel Toolbars

    Note If you do not locate this file, Excel is using default preferences.

  17. Open Excel for Mac 2011, and try to save a file.
    If the problem continues to occur, quit Excel, and restore the file to its original location. Go to method 5.
    If the problem is resolved, drag this file to the Trash.

Method 5: Create a new User Account

The user information may be corrupted. This can cause application startup, install, and usage problems.

To determine whether the User Account is corrupted, log on as a new user or create a new user account, and then test Excel. To create a new user account, read this Microsoft knowledge base article:

2439218 Testing your user account to troubleshoot Office for Mac applications

If the problem continues to occur go to the next method.


Method 6: Save the file in safe mode

To save the file in safe mode, follow the steps provided in this Microsoft knowledge base article:

2398596 Perform a clean startup (Safe boot) to determine whether background programs are interfering with Office for Mac

If you can save the file in safe mode, the issue is most likely related to programs running in the background.

References

If the information in this knowledge base article did not help resolve your problem, select one of the following options:

Properties

Article ID: 2650066 - Last Review: October 3, 2012 - Revision: 4.0
Applies to
  • Microsoft Excel for Mac 2011
Keywords: 
KB2650066

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com