Article ID: 2655088 - Last Review: January 11, 2012 - Revision: 2.0

FIX: Form-based SSO logon fails after you install Forefront Unified Access Gateway Service Pack 1 Update 1

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SYMPTOMS

Consider the following scenario:
  • You install Microsoft Forefront Unified Access Gateway (UAG) Service Pack 1 (SP1) Update 1 on a server. 
  • You configure Forefront UAG 2010 to use a form-based single sign on (SSO) template for a web application.
In this scenario, when users who are already logged on to the UAG portal try to access the published web application, UAG does not perform SSO, the users receive an authentication error, and the logon fails. However, the users can manually enter their credentials and then access the web application.

CAUSE

This issue occurs because the SSO form does not include valid credentials when the form is submitted to the published web application.

RESOLUTION

To resolve this issue, install the rollup package that is described in the following Microsoft Knowledge Base article:
2647899  (http://support.microsoft.com/kb/2647899/ ) Rollup 1 for Forefront Unified Access Gateway (UAG) 2010 Service Pack 1 Update 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates


APPLIES TO
  • Microsoft Forefront Unified Access Gateway 2010 Service Pack 1
Keywords: 
kbhotfixrollup kbexpertiseinter kbqfe kbbug kbfix kbsurveynew KB2655088