Lunga durata di accesso quando si stabilisce una sessione di desktop remoto a un server basato su Windows Server 2008 R2 Host sessione Desktop remoto se Ŕ attivato il reindirizzamento della stampante

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Sintomi

Si consideri il seguente scenario:
  • Si dispone di un server basato su Windows Server 2008 R2 Host sessione Desktop remoto (RD) in un ambiente di dominio Active Directory.
  • Si applica l'impostazione di criteri di gruppo reindirizzamento della stampante per sessioni di desktop remoto per connettono al server.
  • Stabilire ripetutamente sessioni di desktop remoto per il server da un computer client che dispone di pi¨ stampanti installate.
In questo scenario, il tempo di accesso aumenta ogni volta che si stabilisce una connessione desktop remoto. Inoltre, il conteggio di % tempo privilegiato aumenta nel processo Svchost. exe che ospita il servizio di modalitÓ utente Plug-and-Play (Umpnpmgr. dll) sul server. Questo comportamento si verifica ogni volta che log, disconnettersi o ristabilire una sessione di desktop remoto.

Questo comportamento pu˛ causare problemi di prestazioni, ad esempio avvio lento, tempi di accesso, blocco del sistema o errore di reindirizzare le stampanti e unitÓ mappate.

Cause

Questo problema si verifica perchÚ il servizio Redirector periferica di Servizi Desktop remoto crea una nuova porta ogni volta che viene stabilita una sessione di desktop remoto. Tuttavia, le porte inattive non vengono riciclate. Invece, le porte per le stampanti reindirizzate inattive si accumulano nella seguente chiave del Registro di sistema sul server:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{28d78fad-5a12-11D1-ae5b-0000f803a8c2}\##?#root#RDPBUS#0000#{28d78fad-5a12-11D1-ae5b-0000f803a8c2}\

Risoluzione

Informazioni sull'aggiornamento rapido

Un hotfix supportato Ŕ disponibile da Microsoft. Tuttavia, questo hotfix Ŕ destinato a correggere il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix vengano eseguiti ulteriori test. Se il problema non causa gravi difficoltÓ, si consiglia di attendere il prossimo aggiornamento software contenente tale hotfix.

Se l'aggiornamento rapido Ŕ disponibile per il download, Ŕ presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se Ŕ richiesta la risoluzione dei problemi, Ŕ necessario creare una richiesta di assistenza separata. I costi di supporto consueto verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido non Ŕ disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, Ŕ necessario eseguire Windows Server 2008 R2 o Windows Server 2008 R2 Service Pack 1 (SP1). Inoltre, Ŕ necessario disporre del servizio ruolo Host sessione Desktop remoto installato nel computer.

Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
976932Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per applicare l'hotfix descritto in questo pacchetto, non Ŕ necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo aver applicato questo hotfix, Ŕ necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e gli orari di questi file sono elencati nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari cambiano quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows Server 2008 R2
  • I file che si applicano a un prodotto specifico, un'attivitÓ cardine (RTM, SPn), e il ramo del servizio (LDR, GDR) pu˛ essere identificato esaminando i numeri di versione del file, come illustrato nella tabella riportata di seguito:
    Riduci questa tabellaEspandi questa tabella
    VersioneProdottoAttivitÓ cardineRamo del servizio
    6.1.760 0,21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente Nella sezione "ulteriori informazioni sui file per Windows Server 2008 R2". MUM e i file manifesto e i file di catalogo (CAT) di protezione associati sono estremamente importanti mantenere lo stato dei componenti aggiornati. I file del catalogo di protezione per il quale gli attributi non sono elencati, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni basate su x64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Umrdp.dll6.1.7600.21124195,58411-Gen-201206: 28x64
Umrdp.dll6.1.7601.21895214.52811-Gen-201206: 23x64

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Dopo aver installato questo hotfix, Ŕ inoltre necessario rimuovere le porte dei Server Terminal attualmente inattivo. Questo aggiornamento rapido impedisce l'accumulo inattivo porte del Server Terminal. Di conseguenza, Ŕ sufficiente rimuovere le porte una sola volta dopo l'installazione di questo aggiornamento rapido in Windows Server 2008 R2.

Per noi rimuovere automaticamente le porte attualmente inattivo Terminal Server, visitare il "Risolvere il problema per me"sezione.

Risolvere il problema per me



Per rimuovere automaticamente le porte inattivo Terminal Server corrente, scegliere il Risolvere il problema pulsante o un collegamento. Quindi fare clic su Eseguire nel Download del file finestra di dialogo casella e seguire le istruzioni del Risolvere il problema procedura guidata.


Risolvere il problema
Microsoft Fix it 50833


Note
  • Questa Ŕ possibile Fixit utilizzata anche per la pulitura inattivo Terminal Server porte su tutte le versioni di Windows Server 2003 e Windows Server 2008, Windows 7 in un VDI scenario e pu˛ essere automatizzato per l'esecuzione in base a una pianificazione. Per ulteriori informazioni, vederehttp://blogs.technet.com/b/askperf/Archive/2012/03/06/Performance-Issues-due-to-inactive-Terminal-Server-Ports.aspx.
  • Questa procedura guidata pu˛ essere solo in lingua inglese. Tuttavia, la correzione automatica funziona anche per altre versioni di lingua di Windows.
  • Se non si Ŕ sul computer che presenta il problema, salvare la correzione, soluzioni per un'unitÓ memoria flash o un CD, quindi eseguirlo sul computer che presenta il problema.
Per ulteriori informazioni sul reindirizzamento della stampante, visitare il seguente sito Web Microsoft:
Informazioni generali sul reindirizzamento della stampante
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2008 R2

File aggiuntivi per tutte le versioni basate su x64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileAmd64_3fa953577d7d1ef5281e74af83e76b68_31bf3856ad364e35_6.1.7600.21124_none_283f0e03f23d0d0a.manifest
Versione del fileNon applicabile
Dimensioni file723
Data (UTC)11-Gen-2012
Ora (UTC)11: 12
PiattaformaNon applicabile
Nome del fileAmd64_5bfeae5b817170f1bd59c2ed5ba20fcf_31bf3856ad364e35_6.1.7601.21895_none_d2977157f84c5304.manifest
Versione del fileNon applicabile
Dimensioni file723
Data (UTC)11-Gen-2012
Ora (UTC)11: 12
PiattaformaNon applicabile
Nome del fileAmd64_microsoft-windows-t...ICES-portredirector_31bf3856ad364e35_6.1.7600.21124_none_be673547d7e28cb7.manifest
Versione del fileNon applicabile
Dimensioni file20,927
Data (UTC)11-Gen-2012
Ora (UTC)07: 22
PiattaformaNon applicabile
Nome del fileAmd64_microsoft-windows-t...ICES-portredirector_31bf3856ad364e35_6.1.7601.21895_none_c0030b01d540a24f.manifest
Versione del fileNon applicabile
Dimensioni file20,927
Data (UTC)11-Gen-2012
Ora (UTC)07: 27
PiattaformaNon applicabile

ProprietÓ

Identificativo articolo: 2655998 - Ultima modifica: venerdý 11 maggio 2012 - Revisione: 6.0
Chiavi:á
kbautohotfix kbqfe kbhotfixserver kbfix kbprint kbrd kbsurveynew kbexpertiseinter kbfixme kbmsifixme kbmt KB2655998 KbMtit
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