Applies ToMicrosoft Windows XP Home Edition Microsoft Windows XP Professional Microsoft Windows XP Starter Edition Microsoft Windows XP Media Center Edition 2005 Windows Vista Business Windows Vista Enterprise Windows Vista Home Basic Windows Vista Home Premium Windows Vista Starter Windows Vista Ultimate Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

Symptoms

When you open a file in Windows, such as an .exe, .cmd, .reg, .regedit, .secfile, .com, or .bat file, a different program or file may start. Additionally, the icon for the file may not appear as expected. You may also receive additional errors from the from the program it starts.

Cause

This may be the result of malware, such as XP Antivirus 2012, XP internet Security 2012, or a variant of the Win32/FakeRean virus.

Resolution

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix it button. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Microsoft Fix it 50895 Notes

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.

Let me fix it myself

If you believe you've been infected with malware that's preventing .exe files from opening normally, follow the steps below:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows XP

  1. Click the Start button and then click Run.

  2. In the Search box, type explorer and then click OK.

  3. Navigate to the Windows directory (e.g. a typical path may be C:\Windows) and locate regedit.exe.

  4. Run Regedit

    1. Windows XP: Right-click on regedit.exe and select Run as. Uncheck "Protect my computer and data from unauthorized program activity" and click OK.

    2. On Windows 7 or Vista: Right-click on regedit.exe and select Run as administrator. Click Yes to accept the UAC prompt.

  5. Using Regedit, locate and then click on the following registry key:HKeyCurrentUser\Software\Classes

  6. On the left panel, right-click on the following registry subkey:'.exe'

  7. Select Delete and then click OK.

  8. On the left panel, right-click on the following registry subkey:.com'

  9. Select Delete and then click OK.

  10. On the left panel, right-click on the following registry subkey:'.bat'

  11. Select Delete and then click OK.

  12. On the left panel, right-click on the following registry subkey:'.cmd'

  13. Select Delete and then click OK.

  14. On the left panel, right-click on the following registry subkey:'.reg'

  15. Select Delete and then click OK.

  16. On the left panel, right-click on the following registry subkey:'.regedit'

  17. Select Delete and then click OK.

  18. On the left panel, right-click on the following registry subkey:'secfile'

  19. Select Delete and then click OK.

  20. Close Registry Editor.

Run your antivirus software to remove the virus:

If you have anitvirus software on your computer, update the signatures and run a virus scan to remove the malware. If you don't have an anti-virus program, Microsoft does produce a free malware removal tool, Microsoft Safety Scanner, that can clean viruses from your computer.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.

  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

More Information

For more information about the Win32/FakeRean virus and it's variants, visit: http://www.microsoft.com/security/portal/Threat/Encyclopedia/Entry.aspx?Name=Rogue%3aWin32%2fFakeReanFor more information about the Microsoft Safety Scanner, visit: http://www.microsoft.com/security/scanner/en-us/default.aspx

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