Error message when you open an RTF email message that has inline attachments in an Exchange Server 2010 environment

Article ID: 2665806 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You import a personal folder (.pst) file into a mailbox by using the New-MailboxImportRequest cmdlet in a Microsoft Exchange Server 2010 environment.
  • The .pst file contains a Rich Text Format (RTF) email message that has some inline attachments.
  • You open the RTF email message.
In this scenario, the inline attachments are not displayed, and you receive the following error message:

Could not open one or more attachments.

CAUSE

This issue occurs because the inline attachments in the RTF email message are formatted as embedded OLE objects. In this situation, the Mailbox Replication Service (MRS) handles the inline attachments incorrectly when it imports the .pst file. Therefore, the inline attachments are not displayed when you open the RTF email message.


RESOLUTION

To resolve this issue, install the following update rollup:
2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2

WORKAROUND

To work around this issue, import the .pst file directly from Microsoft Outlook.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about move requests, visit the following Microsoft website:
General information about move requests
For more information about the embedded OLE object, visit the following Microsoft website:
General information about the embedded OLE object

Properties

Article ID: 2665806 - Last Review: April 16, 2012 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 2, when used with:
    • Microsoft Exchange Server 2010 Standard
    • Microsoft Exchange Server 2010 Enterprise
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew KB2665806

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