XL: Somma o formattazione di un intervallo di ore, minuti o secondi

Traduzione articoli Traduzione articoli
Identificativo articolo: 266691 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In Excel per formattare automaticamente espressioni di tempo che sommate superano 24 ore, 60 minuti o 60 secondi, è possibile utilizzare i seguenti formati di numeri personalizzati e la funzione SOMMA:
  • Ore = [h]:mm:ss
  • Minuti = [m]:ss
  • Secondi = [ss]

Informazioni

In Microsoft Excel è già disponibile il formato personalizzato delle ore, mentre è necessario creare i formati personalizzati di minuti e secondi per ciascuna cartella di lavoro in cui si desidera utilizzarli.

Per visualizzare correttamente i totali di ore superiori a 24 e i totali di minuti e secondi superiori a 60, utilizzare i metodi descritti di seguito.

Esempio di ore

Per formattare i totali di ore che superano le 24 ore, attenersi alla procedura seguente:
  1. Creare un nuovo foglio di lavoro e digitarvi i seguenti valori. Assicurarsi di utilizzare i due punti (:) come separatore dei numeri.
         A1:      12:35:58
         A2:      12:24:30
         A3:      11:18:23
    					
  2. Nella cella A4 digitare la formula riportata di seguito. Il risultato verrà formattato automaticamente in maniera corretta ogni volta che verranno aggiunte delle ore.
         A4:      =SOMMA(A1:A3)     
    					
Verrà visualizzato il totale 36:18:51.

Esempi di minuti e secondi

Per formattare i totali di minuti e secondi superiori a 60, attenersi alla procedura seguente:
  1. Creare un nuovo foglio di lavoro e digitarvi i seguenti valori. Assicurarsi di utilizzare gli zeri iniziali (00) e i due punti (:) come separatore dei numeri.
         A1:      00:42:58
         A2:      00:19:30
         A3:      00:37:23
    					
  2. Nella cella A4 digitare la seguente formula:
         A4:      =SOMMA(A1:A3)     
    						
    Verrà visualizzato il totale 1:39:51. Per visualizzare questo totale espresso in minuti e secondi oppure solo in secondi, utilizzare la procedura descritta di seguito per creare e applicare il formato appropriato:
    1. Fare clic con il pulsante destro del mouse sulla cella A4, quindi scegliere Formato celle.
    2. Scegliere la scheda Numero.
    3. Nell'elenco Categoria fare clic su Personalizzato.
    4. Nella casella Tipo modificare i codici dei formati dei numeri per creare il formato desiderato.
      • Per il formato dei minuti digitare [m]:ss
      • Per il formato dei secondi digitare [ss]
    5. Selezionare il formato che si desidera applicare, quindi scegliere OK.
    Una volta applicato il formato dei minuti, verrà visualizzato il totale 99:51.

    Una volta applicato il formato dei secondi, verrà visualizzato il totale 5981.
NOTA: quando si modifica un formato predefinito, in Excel viene creato un nuovo formato che tuttavia non viene sostituito a quello esistente.

Applicazione di formati ad altre celle

Una volta creati i formati personalizzati di minuti e secondi, attenersi alla procedura descritta di seguito per applicarli alle celle aggiuntive della cartella di lavoro:
  1. Fare clic con il pulsante destro del mouse sulle celle in cui visualizzare il formato creato, quindi scegliere Formato celle.
  2. Nella finestra di dialogo fare clic sulla scheda Numero, quindi fare clic su Personalizzato.
  3. Nell'elenco dei formati personalizzati fare clic per selezionare quello appropriato, quindi scegliere OK.

Proprietà

Identificativo articolo: 266691 - Ultima modifica: lunedì 18 febbraio 2008 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
Chiavi: 
kbhowto KB266691
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com