Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Проблемы

Рассмотрим следующий сценарий.

  • У вас есть стороннее приложение, которое задает неправильный порядок для списка управления доступом папки "Календарь" в почтовом ящике.

  • Почтовый ящик, содержащий папку "Календарь", можно переместить на Microsoft Exchange Server 2010. Операция перемещения успешно завершена.

  • Вы пытаетесь изменить разрешение на доступ к папке "Календарь", используя приложение веб-службы Exchange (EWS) или приложение MAPI, например Microsoft Outlook.

В этом случае изменить разрешения доступа для папки "Календарь" невозможно.

Причина

Эта проблема возникает из-за ошибки, когда Магазин Exchange проверяет канонические списки управления доступом. Поэтому приложению MAPI или EWS не удается получить таблицу списка управления доступом из папки "Календарь".

Решение

Чтобы устранить эту проблему, установите следующий скат обновлений:

2685289 Описание обновления 3 для Exchange Server 2010 Пакет обновления 2 После установки обновления можно включить проверку канонических ALS, настроив ключ
реестра. Чтобы мы могли включить для вас проверку канонических ALS, перейдите в раздел "Исправить дляменя" Если вы хотите самостоятельно включить проверку канонических ALS, перейдите в раздел "Самостоятельное решение проблемы".

Помощь в решении проблемы



Чтобы автоматически включить проверку канонических ALS, нажмите кнопку "Исправить" или ссылку. Затем в диалоговом окне "Загрузка файла" нажмите кнопку "Выполнить" и следуйте шагам мастера fix it.




Примечания

  • Установите обновление, описанное в статье базы знаний Майкрософт 2685289, перед запуском этого решения Fix it.

  • Возможно, мастер доступен только на английском языке. При этом автоматическое исправление подходит для любых языковых версий Windows.

  • Решения по устранению проблем можно скачать на любой компьютер, а затем сохранить их на устройство флэш-памяти или компакт-диск и запустить на нужном компьютере.


Затем перейдите в раздел"Проблема была исправлена?"



Самостоятельное решение проблемы

Чтобы включить проверку канонических ALS путем настройки ключа реестра, выполните следующие действия:

  1. Запустите редактор реестра. Для этого нажмите кнопку "Начните",в поле "Начните поиск" введите "regedit" и нажмите ввод.

  2. Найдите и щелкните следующий подкомай реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. В меню "Правка" найдите пункт"Новое" и выберите пункт DWORD (32-битное) значение.

  4. Введите CheckCanonicalACLDuringMove и нажмите ввод.

  5. В меню "Правка" выберите пункт "Изменить".

  6. В поле "Значение" введите "1" и нажмите кнопку "ОК".

  7. Закройте редактор реестра.

После включения функции канонического списка управления доступом переместить папки, в которых список элементов управления доступом не является каноническим, невозможно. Кроме того, при попытке переместить папку вы получаете следующее сообщение об ошибке:

Ошибка: MapiExceptionInvalidParameter: не удается настроить свойства объекта. (hr=0x80070057, ec=-2147024809)
Контекст
диагностики: 55847 EMSMDBPOOL. EcPoolSessionDoRpc called [length=267]
Lid: 43559 EMSMDBPOOL. EcPoolSessionDoRpc возвращает [ec=0x0][length=232][latency=0]
Rop: 23226 --- ROP Parse Start ---
Rop: 27962 ROP: ropSetProps
[10] ROP: 17082, ошибка ROP: 0x80070057
Конор: 30561с3:
21921 StoreEc: 0x80070057
ROP: 27962 ROP: ropExtendedError [250]
Конус: 1494 ---- Удаленный контекст Beg ----
Rop: 26426 ROP: ropSetProps [10]
10] Крышка: 21 StoreEc: 0x8004010F proptag: 0x668F0040 и
крышка: 25000
Прикобь: 24936,
крышка: 24952—
47113,
Крышка: 7915 StoreEc: 0x80070057- и
5263 StoreEc: 0x80070057 собь:
19768,
Крышка: 4559 МагазинEc: 0x80070057 Сбока: 1750 ---- Удаленный контекст: конец удаленного контекста ----(-а), крышка


26849: 21817, сбой ROP:
0x80070057 собять: 25761,
1940 StoreEc: 0x80070057 собять:
25297,
Крышка: 21201 StoreEc: 0x80070057


Проблема устранена?

  • Проверьте, устранена ли проблема. Если устранена, пропустите дальнейшие инструкции, приведенные в этом разделе. Если нет, обратитесь в службу технической поддержки.

  • Мы ценим ваши замечания. Чтобы оставить отзыв или сообщить о проблемах с этим решением, оставьте комментарий в блоге«Fix it for me»или отправьте нам сообщение электронной почты.

Дополнительная информация

Дополнительные сведения о списках управления доступом можно найти на следующем веб-сайте Майкрософт:

Общие сведения о списках управления доступомДополнительные сведения о записях управления доступом можно найти на следующем веб-сайте Майкрософт:

Общие сведения о записях управления доступомДополнительные сведения о том, как использовать Visual Basic и ADsSecurity.dll для упорядочения acEs в ACL, перейдите на следующий веб-сайт Майкрософт:

Использование Visual Basic и ADsSecurity.dll для упорядочения acEs в ACL

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×