Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.
영어
죄송합니다. 이 문서는 귀하의 언어로 사용할 수 없습니다.

Symptoms

Consider the following scenario:

  • You install Microsoft Exchange Server 2010 Service Pack 1 (SP1) or a later version.

  • You deploy a Client Access server (CAS) array that uses load balancing.

  • You run the New-MailboxExportRequest cmdlet or the New-MailboxImportRequest cmdlet.

In this scenario, the request may time out and not finish as expected. Additionally, you may receive the following error message:

The call to 'net.tcp://SERVERNAME/Microsoft.Exchange.MailboxReplicationService SERVERNAME (14.1.218.11 caps:07)' timed out. Error details: This request operation sent to net.tcp://SERVERNAME/Microsoft.Exchange.MailboxReplicationService did not receive a reply within the configured timeout (00:01:00). The time allotted to this operation may have been a portion of a longer timeout. This may be because the service is still processing the operation or because the service was unable to send a reply message. Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.
+ CategoryInfo : NotSpecified: (0:Int32) [New-MailboxExportRequest], TimeoutErrorTransientException
+ FullyQualifiedErrorId : 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest

Cause

This issue can occur if the load balancing device is configured incorrectly. For example, this issue can occur if the load balancer does not let the Exchange Server where the request was created connect to the Virtual IP (VIP) for the CAS array.

Resolution

To resolve this issue, verify that the following conditions are true:

  • The Exchange Server can connect to the load balancer as a client.

  • The Exchange Server can connect to the VIP for the CAS array.


Workaround

To work around this issue, use one of the following methods.

Method 1

Configure the RPCClientAccessServer value in the mailbox database to point to a specific CAS server.

Note This setting is read dynamically.

Method 2

Create an entry in the Hosts file on the CAS servers that resolves the CAS array name to "localhost."

More Information

When a mailbox Import or Export request is created, the process is as follows.

Note The steps for an Import or Export request resemble a Move request.

  1. The request is created on the Exchange Server on which the Windows PowerShell session is connected.

  2. As part of the request validation, the Exchange Server connects to the MAPI on the Middle Tier endpoint. Then, the Exchange Server tries to log on to the mailbox that you want to import or export.

  3. If validation is successful, a folder-associated items (FAI) message is created and added to a queue in the System mailbox of the database.

    Note The issue that is described in the "Symptoms" section typically occurs after this step. In this issue, the request is not created as expected, and the FAI message is not created.

  4. All instances of the Mail Replication Service (MRS) check the System mailbox periodically. If an MRS server is not specified in the cmdlet, an MRS server is randomly selected.

  5. MRS finishes the Import or Export request and then changes the request status to "Completed."

  6. An administrator clears the Import or Export request.

    Note This step is optional

References

For more information about Import and Export requests in Exchange Server 2010, visit the following TechNet website:

http://technet.microsoft.com/en-us/library/ee633455.aspx
For more information about Move requests in Exchange Server 2010, visit the following TechNet website:

http://technet.microsoft.com/en-us/library/dd298174.aspx

For more information about how to configure the RPCClientAccessServer value in a mailbox database, visit the following TechNet website:

http://technet.microsoft.com/en-us/library/ee332317.aspx

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

이 정보가 유용한가요?

사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×