Applies ToExchange Server 2010 Enterprise Exchange Server 2010 Standard

Symptoms

Consider the following scenario:

  • You access a mailbox in an Exchange Server 2010 environment by using an Exchange ActiveSync device to connect to a Microsoft Exchange Server 2010 Client Access server.

  • You make some changes that change the user-agent information about the device. For example, you update the operating system version on the device.

  • The administrator runs the Get-ActiveSyncDeviceStatistics cmdlet to retrieve the device statistics.

In this scenario, the cmdlet returns an out of date version of the user-agent information instead of the latest user-agent information.

Cause

This issue occurs because Exchange ActiveSync does not recognize the changes of the user-agent string. Therefore, Active Directory Domain Services (AD DS) is not updated with the latest user-agent information.

Resolution

To resolve this issue, install the following cumulative update:

2661854 Description of Update Rollup 2 for Exchange Server 2010 Service Pack 2

More Information

For more information about the Get-ActiveSyncDeviceStatistics cmdlet, visit the following Microsoft website:

General information about the Get-ActiveSyncDeviceStatistics cmdletFor more information about user-agent strings, visit the following Microsoft website:

General information about user-agent stringsFor more information about Exchange ActiveSync, visit the following Microsoft website:

General information about Exchange ActiveSync The Troubleshoot ActiveSync with Exchange Server guided walkthrough helps troubleshoot the following issues:

  • Unable to create a profile on the device

  • Unable to connect to the server

  • Mail issues

  • Calendaring issues

  • Delays on device/CAS performance

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.