Multiple recovery items are added to the versions subfolder of the Recoverable Items folder in an Exchange Server 2010 environment

Article ID: 2700544 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You enable single-item recovery for a mailbox or place a mailbox on litigation hold in a Microsoft Exchange Server 2010 environment.
  • You log on to the mailbox by using Microsoft Outlook.
  • You open or create a message item that contains some attachments and then open one or more of the attachments.
  • You leave the message item and the attachments open for several minutes.


In this scenario, multiple recovery items are added to the Versions subfolder of the Recoverable Items folder. The expected behavior is that only one recovery item is added to the Versions subfolder.

Notes
  • Even if no changes or manual saves are performed, new recovery items appear in the Versions subfolder of the Recoverable Items folder every few minutes.
  • By default, all changes to a calendar item (such as a meeting request, an appointment, or a task item) are recorded in the mailbox of a user to keep older versions of meeting items.
  • When this issue occurs, the Recoverable Items folder for the mailbox can reach the Recoverable Items quota faster than expected, and then no more items can be stored in the folder.


CAUSE

This issue occurs because the Exchange Information Store service creates unnecessary copies and calendar logs for an item that contains attachments.


RESOLUTION

To resolve this issue, install the update rollup that is described in the following article in the Microsoft Knowledge Base:
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

WORKAROUND

To work around this issue, use one or more of the following methods:

Method 1

Deploy a Group Policy Object (GPO) that disables the Autosave feature in Outlook for the mailboxes that have this problem.

Method 2

Run the following cmdlet to disable single-item recovery on the mailboxes that have this problem:
Set-Mailbox -Identity Mailbox -SingleItemRecoveryEnabled:$false

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the changes to Recoverable Items versioning in Exchange 2010, go to the following Microsoft website:
Changes to Recoverable Items versioning in Exchange
For more information about the Recoverable Items folder, go to the following Microsoft website:
Understanding Recoverable Items
For more information about the Get-MailboxFolderStatistics cmdlet, go to the following Microsoft website:
General information about the Get-MailboxFolderStatistics cmdlet
For more information about how to enable single-item recovery on a mailbox, go to the following Microsoft website:
Enable Single Item Recovery for a Mailbox
For more information about how to put a mailbox on litigation hold, go to the following Microsoft website:
Place a Mailbox on Litigation Hold
For more information about the Set-Mailbox cmdlet, go to the following Microsoft website:
General information about the Set-Mailbox cmdlet

Properties

Article ID: 2700544 - Last Review: June 8, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 2, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbfix kbexpertiseinter kbqfe KB2700544

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