A subject that contains colons is truncated in a mixed Exchange Server 2003 and Exchange Server 2010 environment

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Article ID: 2724188 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You have a mixed Microsoft Exchange Server 2003 and Microsoft Exchange Server 2010 environment.
  • You have Full Access permissions to mailbox A on an Exchange Server 2003 server.
  • You also have Full Access permissions to mailbox B on an Exchange Server 2010 server.
  • You have an email message that contains multiple colons in the subject line. For example, the subject of an email message is "A:B:C:D."
  • You copy or move the email message from mailbox A to a folder in mailbox B by using Microsoft Outlook in online mode.
  • You copy the email message from the folder to another folder in mailbox B.
In this scenario, the subject line of the email message in the target folder is truncated. For example, the subject is truncated to "A:C:D."

Cause

This issue occurs because the Exchange server incorrectly renormalizes the normalized subject line if the PR_SUBJECT_PREFIX property of the email message is set.

Resolution

To resolve this issue, install the following update rollup:
2706690 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about the PR_SUBJECT_PREFIX property, go to the following Microsoft website:
General information about the PR_SUBJECT_PREFIX property

Properties

Article ID: 2724188 - Last Review: August 14, 2012 - Revision: 2.0
Applies to
  • Microsoft Exchange Server 2010 Service Pack 2, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2724188

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