SynchronizeTime task does not start at the time that you scheduled on a computer that is running Windows 7 or Windows Server 2008 R2

Article translations Article translations
Article ID: 2725604 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

Assume that you change the time zone settings on a computer that is running Windows 7 or Windows Server 2008 R2. In this situation, the SynchronizeTime task on the computer does not start at the time that Windows scheduled.

For example, assume that you set the time zone to (UTC+09:00) Osaka, Sapporo, Tokyo on the computer, and then you schedule a SynchronizeTime task to run every Sunday at 01:00. In this situation, the history of the SynchronizeTime task displays the run time of the task as every Monday at 01:00.

Note To access the SynchronizeTime task, click Microsoft in the Task Scheduler, click Windows, and then click Time Synchronization.

Cause

This issue occurs because Windows uses Coordinated Universal Time (UTC) instead of local time to calculate the necessary wait time between each instance of the task. Therefore, the wait time that is used between each instance of the task is incorrect.

Resolution

Hotfix information

Important This hotfix has been re-released to address an issue in which the digital signature on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ubpm.dll6.1.7600.21263170,49610-Jul-201218:17x86
Ubpm.dll6.1.7601.22048170,49610-Jul-201216:57x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ubpm.dll6.1.7600.21263214,01610-Jul-201218:09x64
Ubpm.dll6.1.7601.22048214,01610-Jul-201217:55x64
Ubpm.dll6.1.7600.21263170,49610-Jul-201218:17x86
Ubpm.dll6.1.7601.22048170,49610-Jul-201216:57x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ubpm.dll6.1.7600.21263485,88810-Jul-201216:50IA-64
Ubpm.dll6.1.7601.22048485,88810-Jul-201216:47IA-64
Ubpm.dll6.1.7600.21263170,49610-Jul-201218:17x86
Ubpm.dll6.1.7601.22048170,49610-Jul-201216:57x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the Task Scheduler, go to the following Microsoft website:
General information about the Task Scheduler

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot Applicable
File size2,773
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameX86_49185244a2e8c1c5c4ffc5d38487b8a4_31bf3856ad364e35_6.1.7601.22048_none_f78732c81a3f5e99.manifest
File versionNot Applicable
File size719
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameX86_57518752f443c2b055ec72a10ff23c55_31bf3856ad364e35_6.1.7600.21263_none_83ff19cf228e1d62.manifest
File versionNot Applicable
File size719
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7600.21263_none_66c388996bcb157a.manifest
File versionNot Applicable
File size4,955
Date (UTC)11-Jul-2012
Time (UTC)04:56
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7601.22048_none_68c486e968dcc837.manifest
File versionNot Applicable
File size4,955
Date (UTC)10-Jul-2012
Time (UTC)17:24
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_26a18c697a607cf1bab1393e93a32758_31bf3856ad364e35_6.1.7600.21263_none_dd6f4bdc6b990942.manifest
File versionNot Applicable
File size723
Date (UTC)17-Sep-2012
Time (UTC)09:49
PlatformNot Applicable
File nameAmd64_29691bc1fe54822a758efa27089c4a0f_31bf3856ad364e35_6.1.7601.22048_none_1a2ff9d5b119b68a.manifest
File versionNot Applicable
File size1,086
Date (UTC)17-Sep-2012
Time (UTC)09:49
PlatformNot Applicable
File nameAmd64_dcdf69fcf3dc0784c68995ecfa0dd7ca_31bf3856ad364e35_6.1.7600.21263_none_be259fa1fefc622d.manifest
File versionNot Applicable
File size1,086
Date (UTC)17-Sep-2012
Time (UTC)09:49
PlatformNot Applicable
File nameAmd64_e2bb23541b136d1cb9df7741a920bb0c_31bf3856ad364e35_6.1.7601.22048_none_484b6a1c0e80a445.manifest
File versionNot Applicable
File size723
Date (UTC)17-Sep-2012
Time (UTC)09:49
PlatformNot Applicable
File nameAmd64_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7600.21263_none_c2e2241d242886b0.manifest
File versionNot Applicable
File size4,959
Date (UTC)10-Jul-2012
Time (UTC)19:34
PlatformNot Applicable
File nameAmd64_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7601.22048_none_c4e3226d213a396d.manifest
File versionNot Applicable
File size4,959
Date (UTC)10-Jul-2012
Time (UTC)18:22
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,215
Date (UTC)17-Sep-2012
Time (UTC)09:49
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7600.21263_none_66c388996bcb157a.manifest
File versionNot Applicable
File size4,955
Date (UTC)11-Jul-2012
Time (UTC)04:56
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7601.22048_none_68c486e968dcc837.manifest
File versionNot Applicable
File size4,955
Date (UTC)10-Jul-2012
Time (UTC)17:24
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_b14d947afc01ba0890290dfdec802b25_31bf3856ad364e35_6.1.7601.22048_none_77017dc367cc9022.manifest
File versionNot Applicable
File size1,084
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameIa64_ce360b25c49b2b7cffd2d9d159bf9e5b_31bf3856ad364e35_6.1.7600.21263_none_10044346ee720ddc.manifest
File versionNot Applicable
File size1,084
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameIa64_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7600.21263_none_66c52c8f6bc91e76.manifest
File versionNot Applicable
File size4,957
Date (UTC)10-Jul-2012
Time (UTC)19:33
PlatformNot Applicable
File nameIa64_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7601.22048_none_68c62adf68dad133.manifest
File versionNot Applicable
File size4,957
Date (UTC)10-Jul-2012
Time (UTC)18:20
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,947
Date (UTC)17-Sep-2012
Time (UTC)09:48
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7600.21263_none_66c388996bcb157a.manifest
File versionNot Applicable
File size4,955
Date (UTC)11-Jul-2012
Time (UTC)04:56
PlatformNot Applicable
File nameX86_microsoft-windows-u..roundprocessmanager_31bf3856ad364e35_6.1.7601.22048_none_68c486e968dcc837.manifest
File versionNot Applicable
File size4,955
Date (UTC)10-Jul-2012
Time (UTC)17:24
PlatformNot Applicable

Properties

Article ID: 2725604 - Last Review: October 10, 2012 - Revision: 2.0
Applies to
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertisebeginner kbsurveynew KB2725604

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com