Applies ToWindows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptoms

Assume that you connect a computer that is running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1 to a network that uses IEEE 802.1X authentication. Additionally, assume that you set up the connection by using a device that supports the 802.1X authentication protocol (for example, an 802.1X-capable switch). When you start the computer, 802.1X authentication fails intermittently.Note To check whether the authentication fails, run the netsh lan show interface command.

Cause

This issue occurs because a Read process starts before the network adapter is initialized.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 0.16xxx

    Windows 7 and Windows Server 2008 R2

    RTM

    GDR

    6.1.760 1.17xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    GDR

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Dot3api.dll

6.1.7601.17514

91,136

20-Nov-2010

12:18

x86

Dot3dlg.dll

6.1.7600.16385

47,104

14-Jul-2009

01:15

x86

Dot3msm.dll

6.1.7601.22074

115,200

30-Jul-2012

17:40

x86

Dot3svc.dll

6.1.7601.22074

215,552

30-Jul-2012

17:40

x86

Report.system.netdiagframework.xml

Not applicable

29,356

10-Jun-2009

21:20

Not applicable

Report.system.wired.xml

Not applicable

19,290

10-Jun-2009

21:20

Not applicable

Rules.system.netdiagframework.xml

Not applicable

57,286

10-Jun-2009

21:20

Not applicable

Rules.system.wired.xml

Not applicable

40,902

10-Jun-2009

21:20

Not applicable

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Dot3api.dll

6.1.7601.17514

84,992

20-Nov-2010

13:26

x64

Dot3dlg.dll

6.1.7600.16385

57,856

14-Jul-2009

01:40

x64

Dot3msm.dll

6.1.7601.22074

103,936

30-Jul-2012

18:38

x64

Dot3svc.dll

6.1.7601.22074

254,464

30-Jul-2012

18:38

x64

Report.system.netdiagframework.xml

Not applicable

29,356

10-Jun-2009

20:37

Not applicable

Report.system.wired.xml

Not applicable

19,290

10-Jun-2009

20:37

Not applicable

Rules.system.netdiagframework.xml

Not applicable

57,286

10-Jun-2009

20:37

Not applicable

Rules.system.wired.xml

Not applicable

40,902

10-Jun-2009

20:37

Not applicable

Dot3api.dll

6.1.7601.17514

91,136

20-Nov-2010

12:18

x86

Dot3dlg.dll

6.1.7600.16385

47,104

14-Jul-2009

01:15

x86

Dot3msm.dll

6.1.7601.22074

115,200

30-Jul-2012

17:40

x86

Workaround

To work around this issue, restart the Wired AutoConfig service. Note The service name of the Wired AutoConfig service is dot3svc.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updatesFor more information about wired networking with 802.1X authentication, go to the following Microsoft website:

General information about wired networking with 802.1X authenticationFor more information about 802.1X authenticated wired access, go to the following Microsoft website:

General information about 802.1X authenticated wired accessFor more information about 802.1X authenticated wired access deployment, go to the following Microsoft website:

General information about 802.1X authenticated wired access deployment

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_7aefca0db44362a71ec481f5c824f6ea_31bf3856ad364e35_6.1.7601.22074_none_26a3d91cc5f084cd.manifest

File version

Not applicable

File size

695

Date (UTC)

31-Jul-2012

Time (UTC)

07:01

Platform

Not applicable

File name

X86_microsoft-windows-dot3svc_31bf3856ad364e35_6.1.7601.22074_none_6dbc13caeb14d72c.manifest

File version

Not applicable

File size

89,640

Date (UTC)

31-Jul-2012

Time (UTC)

16:40

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_7c9dc13c979f733227ffb011e2333c6c_31bf3856ad364e35_6.1.7601.22074_none_0ebda206edd1d8e3.manifest

File version

Not applicable

File size

699

Date (UTC)

31-Jul-2012

Time (UTC)

07:01

Platform

Not applicable

File name

Amd64_924bbb314f869d8987e55793a6f0f7ae_31bf3856ad364e35_6.1.7601.22074_none_fd632fce5c975099.manifest

File version

Not applicable

File size

1,040

Date (UTC)

31-Jul-2012

Time (UTC)

07:01

Platform

Not applicable

File name

Amd64_microsoft-windows-dot3svc_31bf3856ad364e35_6.1.7601.22074_none_c9daaf4ea3724862.manifest

File version

Not applicable

File size

89,644

Date (UTC)

31-Jul-2012

Time (UTC)

16:35

Platform

Not applicable

File name

Wow64_microsoft-windows-dot3svc_31bf3856ad364e35_6.1.7601.22074_none_d42f59a0d7d30a5d.manifest

File version

Not applicable

File size

83,073

Date (UTC)

31-Jul-2012

Time (UTC)

16:35

Platform

Not applicable

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