"Daný kľúč nebol prítomný v slovníku" chyba pri pokuse spustiť Get-ADObjects cmdlet na počítači so systémom Windows 7 alebo Windows Server 2008 R2

Preklady článku Preklady článku
ID článku: 2741618 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

Priznaky

Predpokladajme, že používate Active Directory cmdlet na interrogate objektov služby Active Directory na počítači so systémom Windows Server 2008 R2 alebo na počítač so systémom Windows 7, ktorý má funkciu Remote Server Administration Tools nainštalovaný. Pri pokuse spustiť Get-ADObjects cmdlet, zobrazí sa chybové hlásenie podobné nasledujúcemu:
Daný kľúč nebol prítomný v slovníku.

Pricina

Tento problém sa vyskytuje, pretože cmdlet dotaz vráti atribútu, ktorý nie je uvedené v súhrnnej schémy. Keď Windows PowerShell cmdlet formáty atribútov pre výsledok dotazu cmdlet, cmdlet načíta zoznam zaujímavých atribúty zo služby Active Directory na sledovanie formátovania operácie. Potom cmdlet porovnáva tento zoznam proti zoznamu atribútov, načítané súhrnnej schémy. Keď cmdlet dotaz vráti atribútu, ktorý nie je uvedené v súhrnnej schémy, vyskytne sa problém, ktorý je popísaný v časti „príznaky".

Riesenie

Informácie o rýchlej oprave

Podporovaná rýchla oprava je k dispozícii od spoločnosti Microsoft. Táto rýchla oprava je však určená iba problém, ktorý je popísaný v tomto článku. Táto rýchla oprava sa vzťahujú len na systémy, ktoré sa vyskytuje problém popísaný v tomto článku. Možno, že táto rýchla oprava bude ďalej testovaná. Preto, ak ste neobťažuje problém, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá obsahuje túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na prevzatie, je tu oddiel "Prevzatie dostupnej rýchlej opravy" na začiatku tohto článku databázy Knowledge Base. Ak sa táto sekcia nezobrazuje, obráťte sa na Microsoft zákaznícky servis a podpora získať rýchlu opravu.

Poznámka Ak sa vyskytnú ďalšie problémy alebo ak sa riešenie problémov vyžaduje, budete musieť vytvoriť samostatnú servisnú požiadavku. Obvyklé podporu náklady budú vzťahovať na dodatočnú podporu otázky a otázky, ktoré nie sú oprávnené na túto rýchlu opravu špecifické. Úplný zoznam telefónnych čísel, Microsoft zákaznícky servis a podpora alebo vytvorte samostatnú servisnú požiadavku, navštívte nasledujúce webovú lokalitu spoločnosti Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Poznámka "Prevzatie dostupnej rýchlej opravy" forme sa zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nevidíte svoj jazyk, je, pretože rýchla oprava nie je k dispozícii pre daný jazyk.

Predpoklady

Ak chcete použiť túto rýchlu opravu, musíte používať systém Windows 7 Service Pack 1 (SP1) alebo systém Windows Server 2008 R2 SP1.

Ďalšie informácie o možnostiach získania Windows 7 alebo Windows Server 2008 R2 service pack nájdete po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
976932Informácie o Service Pack 1 pre systém Windows 7 a Windows Server 2008 R2

Informácie databázy Registry

Ak chcete použiť túto rýchlu opravu, nemáte robiť žiadne zmeny v databáze Registry.

Ruský štandardný čas

Po použití tejto rýchlej opravy je potrebné reštartovať počítač.

Informácie o nahradení pre rýchlu opravu

Táto rýchla oprava nenahrádza vydanú rýchlu opravu.

Informácie o súbore

Globálna verzia tejto rýchlej opravy sa nainštaluje súbory, ktoré majú atribúty, ktoré sú uvedené v nasledovných tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené v koordinovaný svetový čas (UTC). Dátumy a časy jednotlivých súborov na lokálnom počítači zobrazia váš miestny čas spolu s vašej aktuálnej bias letný čas (letný čas). Navyše, dátumy a časy sa môže zmeniť, ak môžete vykonať určité operácie so súbormi.
Windows 7 a Windows Server 2008 R2 súbor informácií poznámky
Dôležité Windows 7 rýchlych a rýchlych opráv systému Windows Server 2008 R2 sú zahrnuté v tie isté balíčky. Však rýchle opravy na stránke rýchla oprava žiadosti sú uvedené v oboch operačných systémoch. Ak chcete požiadať balíka rýchlej opravy, ktorá sa vzťahuje na jednej alebo oboch operačných systémov, je rýchla, ktorý je uvedený v časti "Windows 7 a Windows Server 2008 R2" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch určiť skutočný operačný systém, ktorý každý rýchlu opravu, na ktorý sa vzťahuje.
  • Súbory, ktoré sa vzťahujú na konkrétny výrobok, SR_Level (RTM, SPn), služby pobočky (LDR, NDR) možno identifikovať preskúmaním čísla verzií súborov, ako je uvedené v nasledujúcej tabuľke:
    Zbaliť túto tabuľkuRozbaliť túto tabuľku
    VerziaVýrobkuMíľnikomSlužby pobočky
    6.1.760 1.22xxxWindows 7 a Windows Server 2008 R2SP1LDR
  • ZJAVNE súbory (.manifest) a MAMA súbory (.mum), ktoré sú nainštalované pre každý prostredie sú uvedené samostatne v sekcii "ďalší súbor informácií pre Windows 7 a Windows Server 2008 R2". MAMA a ZJAVNE a súvisiace bezpečnostné katalógu (typu .cat) súbory, sú veľmi dôležité pre udržanie stav aktualizované. Katalógový súbor zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané s digitálnym podpisom spoločnosti Microsoft.
Pre všetky podporované x 86-bitové verzie Windows 7
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruVerzia súboruVeľkosť súboruDátumČasPlatforma
Microsoft.ActiveDirectory.Management.dll6.1.7601.22079774,14406-Aug-201217: 12x 86
Pre všetky podporované x 64-bitových verziách systému Windows 7 a Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruVerzia súboruVeľkosť súboruDátumČasPlatforma
Microsoft.ActiveDirectory.Management.dll6.1.7601.22079774,14406-Aug-201218: 11x 86

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti „vzťahuje sa na".

dalsie informacie

Ďalšie informácie o terminológii softvérových aktualizácii - kliknutím na nasledujúce číslo článku zobrazíte článok z databázy Microsoft Knowledge Base:
824684Popis štandardnej terminológie použitej na popis aktualizácií softvéru Microsoft

Ďalších informácií o súbore

Ďalší súbor informácií pre Windows 7 a Windows Server 2008 R2

Ďalšie súbory pre všetky podporované x 86-bitové verzie Windows 7
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruX86_a72e15df5fd0ce2c991e6e8f403daead_31bf3856ad364e35_6.1.7601.22079_none_8aa6ed2c8a8746ce.Manifest
Verzia súboruNeplatí
Veľkosť súboru706
Dátum (UTC)07-Aug-2012
Čas (UTC)09: 46
PlatformaNeplatí
Názov súboruX86_microsoft.ActiveDirectory.management_31bf3856ad364e35_6.1.7601.22079_none_1aeb5954edaf626a.Manifest
Verzia súboruNeplatí
Veľkosť súboru2,809
Dátum (UTC)06-Aug-2012
Čas (UTC)17: 33
PlatformaNeplatí
Ďalšie súbory pre všetky podporované x 64-bitových verziách systému Windows 7 a Windows Server 2008 R2
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruAmd64_6d4f87cd9f3324175b411631038a43a5_31bf3856ad364e35_6.1.7601.22079_none_215c5e0ff5ba5791.Manifest
Verzia súboruNeplatí
Veľkosť súboru710
Dátum (UTC)07-Aug-2012
Čas (UTC)09: 46
PlatformaNeplatí
Názov súboruAmd64_a72e15df5fd0ce2c991e6e8f403daead_31bf3856ad364e35_6.1.7601.22079_none_e6c588b042e4b804.Manifest
Verzia súboruNeplatí
Veľkosť súboru708
Dátum (UTC)07-Aug-2012
Čas (UTC)09: 46
PlatformaNeplatí
Názov súboruAmd64_microsoft.ActiveDirectory.management_31bf3856ad364e35_6.1.7601.22079_none_7709f4d8a60cd3a0.Manifest
Verzia súboruNeplatí
Veľkosť súboru2,813
Dátum (UTC)06-Aug-2012
Čas (UTC)18: 46
PlatformaNeplatí

Vlastnosti

ID článku: 2741618 - Posledná kontrola: 12. septembra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Kľúčové slová: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2741618 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2741618

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com