FIX: Doména používateľ nemôže pristúpiť TFS 2010 server po migrovať používateľov a ich históriu SID do inej domény

Preklady článku Preklady článku
ID článku: 2741905 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

Príznaky

Uvažujme o nasledujúcom prípade:
  • Môžete pridať používateľa do domény (doména 1).
  • Pridajte server Microsoft Visual Studio Team Foundation Server (TFS) 2010 do inej domény (doména 2).

    Poznámka: Doména 2 dôveruje doméne 1.
  • Pridáte používateľa na TFS server. Užívateľ môže teraz prístup k serveru TFS.
  • Migrovaním používateľa a ich bezpečnostný identifikátor (SID) histórie z domény 1 do domény 2.
V takomto prípade užívateľ môže používať už ich poverenia pre doménu 1 prístup k serveru TFS.

Poznámka:Toto nastane do 24 hodín migrácie.

Príčina

Tento problém sa vyskytuje z dôvodu problém synchronizácie počas synchronizácie denné úlohy na serveri TFS. Ak sa tento problém vyskytne, TFS server značiek 1 používateľským kontom domény ako neplatný.

Riešenie

Informácie o rýchlej oprave

Podporovaná rýchla oprava je teraz k dispozícii od spoločnosti Microsoft. Však zamýšľa iba problém, ktoré popisuje tento článok. Použite ju iba v počítačoch s týmto konkrétnym problémom.

Ak chcete vyriešiť tento problém, obráťte sa na službu podpory zákazníkov spoločnosti Microsoft získať rýchlu opravu. Úplný zoznam telefónnych čísiel služby podpory zákazníkov spoločnosti Microsoft a informácie o poplatkoch za podporu, navštívte nasledujúce webovú lokalitu spoločnosti Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Poznámka: V osobitných prípadoch, poplatky, ktoré sú telefonickú podporu hovory môže byť zrušená ak podpory určuje, že konkrétna aktualizácia vyrieši váš problém. Obvyklé podporu náklady budú vzťahovať na dodatočnú podporu otázky a otázky, ktoré nespĺňajú kritériá pre konkrétnu aktualizáciu predmetné.

Predpoklady

Ak chcete použiť túto rýchlu opravu, musíte mať Visual Studio Team Foundation Server 2010 Service Pack 1 nainštalovaný v počítači.

Požiadavka na reštart

Možno budete musieť reštartovať počítač po inštalácii tejto rýchlej opravy, ak sú zasiahnuté súbory používané počas inštalácie. Odporúčame, aby ste zatvorili všetky súvisiace s Microsoft Visual Studio 2010 komponenty pred inštaláciou tejto rýchlej opravy.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a časy jednotlivých súborov sú uvedené v univerzálny koordinovaný čas (UTC). Keď zobrazíte informácie o súbore, sa konvertuje na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite Časové pásmo kartu v Dátum a čas položka v ovládacom paneli.

Pre všetky podporované verzie Visual Studio Team Foundation Server 2010
Zbaliť túto tabuľkuRozbaliť túto tabuľku
Názov súboruVerzia súboruVeľkosť súboruDátumČasPlatforma
Microsoft.teamfoundation.admin.dll10.0.40219.43025,618,01626-Oct-20129: 11x86
Microsoft.teamfoundation.Build.server.dll10.0.40219.430445,54426-Oct-20129: 11x86
Microsoft.teamfoundation.Build.server.plugins.dll10.0.40219.43046,72026-Oct-20129: 11x86
Microsoft.teamfoundation.framework.server.dll10.0.40219.4301,103,47226-Oct-20129: 11x86
Microsoft.teamfoundation.server.deploy.tfcollection.dll10.0.40219.430562,31226-Oct-20129: 11x86
Microsoft.teamfoundation.server.dll10.0.40219.430221,79226-Oct-20129: 11x86
Microsoft.teamfoundation.Servicing.dll10.0.40219.43066,66426-Oct-20129: 11x86
Microsoft.teamfoundation.testmanagement.Adapter.dll10.0.40219.43093,82426-Oct-20129: 11x86
Microsoft.teamfoundation.versioncontrol.server.dll10.0.40219.430618,11226-Oct-20129: 11x86
Microsoft.teamfoundation.versioncontrol.server.plugins.dll10.0.40219.43026,76826-Oct-20129: 11x86
Microsoft.teamfoundation.versioncontrol.server.proxy.dll10.0.40219.43090,24826-Oct-20129: 11x86
Microsoft.teamfoundation.Warehouse.dll10.0.40219.4303,526,76026-Oct-20129: 11x86
Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll10.0.40219.430589,99226-Oct-20129: 11x86
Microsoft.teamfoundation.workitemtracking.server.dataservices.dll10.0.40219.430143,52026-Oct-20129: 11x86

Ako problém obísť

Obísť tento problém, nahraďte identity domény 1 domény 2 identitu v rámci TFS servera a potom prístup TFS server prostredníctvom poverenia pre doménu 2. Chcete urobiť, do príkazového riadka zadajte nasledovný príkaz:
TFSConfig identity/Change /fromdomain:domain1 /todomain:domain2 /account:AccountName /toaccount:AccountName
Poznámka: Ak identitu domény 1 mal len prístup k serveru TFS prostredníctvom členstva v skupine Windows, TFS správca môže mať udeliť prístup k totožnosti domény 2.

Stav

Spoločnosť Microsoft potvrdila, že ide o problém produktov spoločnosti Microsoft uvedených v časti "Vzťahuje sa na".

Ďalšie informácie

Ďalšie informácie o príkaze identít , nájdete nasledujúce webovú lokalitu MSDN:
Všeobecné informácie o príkazu identít

Vlastnosti

ID článku: 2741905 - Posledná kontrola: 27. novembra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Visual Studio Team Foundation Server 2010 Service Pack 1, pri použití s produktom:
    • Microsoft Visual Studio Team Foundation Server 2010
Kľúčové slová: 
kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2741905 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2741905

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com