Excel: Cómo solucionar problemas de bloqueos y no responde con Excel

Seleccione idioma Seleccione idioma
Id. de artículo: 2758592 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al abrir o utilizar Microsoft Excel, Excel estropea, se bloquea, se paraliza, o deja de funcionar. Además, puede recibir uno de los mensajes de error siguientes:

Excel no responde.

Excel ha dejado de funcionar.
Un problema hizo que el programa deje de funcionar correctamente. Windows cerrará el programa y notificar si hay una solución.



Causa

Problemas con Excel bloquea o cuelga a la que pueden deberse a varias cosas. La siguiente es una lista de las posibles soluciones.

Solución

Utilice los métodos siguientes en el orden en que aparecen. Si se trata de uno de estos métodos y no soluciona el problema, vaya al método siguiente.

Método 1: Comprobar o instalar las actualizaciones más recientes

Deberá configurar Windows Update para descargar e instalar las actualizaciones recomendadas automáticamente. Instalar las actualizaciones importantes, recomendadas y opcionales con frecuencia puede corregir problemas por el reemplazo de archivos no actualizados y repara vulnerabilidades. Para instalar las actualizaciones más recientes de Office, haga clic en el vínculo específico para su versión de Windows y siga los pasos de este artículo.


Actualizaciones del sistema operativo

Instalar las actualizaciones de Windows en Windows 7

Instalar las actualizaciones de Windows en Windows Vista

Instalar actualizaciones de Windows en Windows XP

Actualizaciones de Office

Para obtener más información acerca de las actualizaciones de Office, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
953878Actualizaciones acumulativas están disponibles en el equipo de Microsoft Office para solucionar los problemas detectados
Si el problema no se resuelve después de instalar las actualizaciones más recientes de Windows y Office, vaya al método 2.

Método 2: Inicie Excel en modo a prueba de errores

El modo seguro permite usar con seguridad de Excel sin que se produzcan ciertos programas de inicio. Excel puede abrir en modo a prueba de errores manteniendo pulsado Ctrl mientras inicia el programa o mediante el "/ safe" (es decir, excel.exe /safe) opción al iniciar el programa desde la línea de comandos. Al ejecutar Excel en modo a prueba de errores, omite la funcionalidad y opciones como ubicación de inicio alternativa, las barras de herramientas modificados, la carpeta xlstart y complementos de Excel (sin embargo, se excluyen los complementos COM).

Si el problema se resuelve después de ejecutar Excel en modo a prueba de errores, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
280504 Cómo solucionar problemas de inicio en Excel

Si el problema no se resuelve después de iniciar Excel en modo a prueba de errores, vaya al método 3.

Método 3: Investigue posibles problemas con los componentes

Muchos desarrolladores crean complementos para Excel. Estos complementos se dividen en dos tipos:
  • Complementos (complementos que se guardan como archivos .xla, .xlam o .xll) de Excel. Estos complementos se cargan en la interfaz de usuario de Excel.
  • Complementos COM. Normalmente, estos complementos tienen instalarse e incluir los archivos DLL y claves del registro.

Deshabilitar los complementos es una buena prueba porque le permite limitar la elección de los cuales complemento está causando el bloqueo.

Nota: Modo a prueba de errores de Excel deshabilite los complementos.

Para obtener más información sobre los complementos de Excel, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
280504 Cómo solucionar problemas de inicio en Excel

Si el problema no se resuelve después de quitar o deshabilitar los complementos, vaya al método 4.

Método 4: Compruebe si el software antivirus está actualizado o que está en conflicto con Excel

Si el software antivirus no está actualizado, Excel podría no funcionar correctamente.

Cómo comprobar si el software antivirus está actualizado

Para mantener el ritmo con nuevos virus que se crean, los proveedores de software de antivirus proporcionan periódicamente las actualizaciones que se pueden descargar desde Internet. Descargar las actualizaciones más recientes, visite el sitio Web del proveedor de su software antivirus. Para obtener una lista de proveedores de software antivirus, visite el siguiente sitio Web de Microsoft:
Proveedores de software de seguridad de consumidor

Cómo comprobar si el software antivirus está en conflicto con Excel

Si su software antivirus incluye integración con Excel, puede experimentar problemas de rendimiento. En este caso, puede deshabilitar todos integración de Excel en el software antivirus mediante la creación de excepciones para los archivos de Excel.

Importante
cambiar la configuración del antivirus puede hacer que su equipo vulnerable a los ataques virales, fraudulentos o malintencionados. No se recomienda que intente cambiar la configuración del antivirus. Utilice esta solución bajo su propia responsabilidad. Deberá ponerse en contacto con su proveedor de software antivirus para determinar cómo configurar el software para excluir cualquier integración con Excel.
Si actualizar el software antivirus y lo que lo excluye de la integración con Excel no resolvió su problema, vaya al método 5.


Método 5: Asegúrese de que Excel no está siendo utilizado por otro proceso

Con frecuencia, se está Excel iniciado por un tercero o llama a través de un proceso de automatización. Esto puede hacer que Excel no funcione como se esperaba. Si va a automatizar Excel de esta manera, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
257757 Consideraciones para la automatización de servidor de Office

Intente reproducir el bloqueo sólo con Excel. No utilice cualquier automatización. Si puede reproducir el problema mediante automatización, póngase en contacto con la compañía que admite la aplicación de automatización.

Si el problema no se resuelve después de quitar la automatización, vaya al método 6.

Método 6: Compruebe si el archivo se genera por un tercero.

A veces se generan archivos de Excel en una aplicación de terceros. En este caso, los archivos pueden generarse de forma incorrecta, y algunas características no funcionen correctamente al abrir los archivos de Excel. Si esto ocurre, puede probar las funciones de nuevos archivos fuera de la aplicación de terceros. Si las características funcionen correctamente, debe asegurarse de que el tercero es consciente del problema.

Si el problema no se resuelve después de haberlo probado fuera de la aplicación de otros fabricantes, vaya al método 7.

Método 7: Prueba mediante el uso de un nuevo perfil de red o local

En ocasiones, Windows no puede leer su perfil de usuario correctamente. Para determinar si un perfil de usuario dañado está causando el problema, intente iniciar sesión como un usuario nuevo. O bien, haga clic en uno de los vínculos siguientes, dependiendo de la versión de Windows y, a continuación, siga los pasos descritos en el artículo:

Windows 7: Reparar un perfil de usuario dañado

Windows Vista: Reparar un perfil de usuario dañado

Windows XP: Cómo crear y configurar cuentas de usuario en Windows XP

Si el problema no se resuelve después de volver a crear el perfil, vaya al método 8.

Método 8: Realizar un inicio selectivo para determinar si un programa, proceso o servicio entra en conflicto con Excel


Al iniciar Windows como de costumbre, varias aplicaciones y servicios de inicio automáticamente y, a continuación, ejecutar en segundo plano. Estas aplicaciones y servicios pueden interferir con otro software en el PC. Realizar un inicio selectivo (también conocido como un "inicio limpio") puede ayudarle a identificar los problemas con aplicaciones en conflicto. Para realizar un inicio selectivo, haga clic en uno de los vínculos siguientes, dependiendo de la versión de Windows y, a continuación, siga los pasos descritos en el artículo:

Windows 7: Ejecutar un inicio selectivo utilizando configuración del sistema

Windows Vista: Ejecutar un inicio selectivo utilizando configuración del sistema

Windows XP: Cómo configurar Windows XP para iniciar en un estado de "inicio limpio"

Inicio selectivo se utiliza para identificar el proceso ofensivo, servicio o aplicación que está en conflicto con Excel.

Si el problema no se resuelve después de realizar un inicio selectivo, vaya al método 9.

Método 9: Reparar o volver a instalar el programa de Office

Puede ser capaz de resolver sus problemas con Excel reparando los programas de Office. Para ello, siga estos pasos:
  1. Salga de los programas de Office que se están ejecutando.
  2. Abra el Panel de Control y, a continuación, abra el elemento Agregar o quitar programas (si está ejecutando Windows XP) o el elemento programas y características (si está ejecutando Windows Vista o Windows 7).
  3. En la lista de programas instalados, haga clic en Microsoft Office 2010y, a continuación, haga clic en Reparar.

NotaSi utiliza hacer clic y ejecutar de Office, visite el siguiente sitio Web de Microsoft Office y, a continuación, siga los pasos para reparar Office Click-to-Run:

Actualizar, reparar o desinstalar productos hacer clic y ejecutar de Office

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
290301Cómo desinstalar o quitar conjuntos de programas de Microsoft Office 2010
Si el problema no se resuelve después de reparar los programas de Office, vaya a la sección "Solución avanzada de problemas".


Solución de problemas avanzada

Si los métodos que se han mencionado anteriormente no resolvió su problema, el problema podría ser archivo específico o contextual. En la siguiente sección se describe cómo solucionar un problema adicional que puede hacer que Excel se bloquee o se bloquee.

Investigue el contenido y los datos de archivo de Excel

Archivos de Excel pueden existir en el equipo durante mucho tiempo. Que se han actualizado desde la versión a versión y viajan con frecuencia de un usuario a otro usuario. Con frecuencia, un usuario hereda de un archivo de Excel, pero no sabe qué se incluye en el archivo. Por lo tanto, asegúrese de que realice un inventario de los archivos de Excel y quitar los archivos que ya no son necesarios. Para obtener más información acerca de las áreas de problemas posibles en un archivo de excel, vaya al sitio Web de Microsoft siguiente:

Excel: Cómo solucionar problemas de bloqueos y no responde en los archivos de Excel
Lista de problemas de rendimiento en los libros de Excel 10

Factores ambientales

Factores del entorno son tan importantes como el contenido de los archivos y complementos al solucionar problemas de bloqueos. Puede ayudarnos a determinar la causa del problema de las siguientes acciones:
  • Siga los pasos de solución de problemas básicos.
  • Pruebe los archivos en el entorno de forma más limpio posible. Por ejemplo, probar los archivos en un equipo local. O bien, utilizar un controlador de impresora del escritor de documentos XPS de Microsoft.
Las secciones siguientes describen algunas áreas que vale la pena investigar.

Permisos
Cuando se guarda un archivo de Excel, debe tener los siguientes permisos a la carpeta en la que desea guardar el archivo:

? Permisos de lectura
? Permisos de escritura
? Modificar permisos
Eliminación de permisos

NotaSi no tiene todos estos permisos, no se puede completar el proceso de guardado de Excel y Excel se puede bloquear o producir errores. Para obtener más información acerca de por qué Excel necesita estos permisos, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
814068 Descripción de la forma en que Excel guarda los archivos

Nota
si Excel deja de responder o se bloquea cuando se guarda un archivo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
271513 Cómo solucionar errores al guardar archivos de Excel

¿Dónde se almacena el archivo
Mover el archivo localmente le ayudará a determinar si hay algún problema con el archivo o donde se guarda el archivo. Pueden surgir varios problemas al guardar un archivo de Excel en una red o en un servidor web. Es una buena idea guardar el archivo localmente. Esto debe hacerse en las siguientes situaciones:

? Redirige la carpeta "Mis documentos" para la ubicación del servidor

? Los archivos sin conexión

? Abrir archivos desde Webfolder o SharePoint

? Escritorio remoto/Citrix

? Dispositivos de red

? Entorno virtualizado.Para obtener más información acerca del software de Microsoft que se está ejecutando un entorno virtualizado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
897615 Directiva de soporte técnico para software de Microsoft que se ejecuta en software de virtualización de hardware que no sean de Microsoft

Memoria
Archivos de Excel pueden crecer bastante al comenzar a agregar gran cantidad de formas y formato. Asegúrese de que el sistema tiene suficiente memoria RAM para ejecutar la aplicación. Para los requisitos del sistema de los conjuntos de aplicaciones de Microsoft Office, visite los siguientes sitios Web de Microsoft:

Requisitos del sistema para Office de 2013

Requisitos del sistema para Office 2010

Requisitos del sistema para Excel 2007

Office2010 presenta las versiones nativas de 64 bits de productos de Office para poder aprovechar esta mayor capacidad. Por ejemplo, esta capacidad adicional sólo es necesarios para los usuarios de Microsoft Excel que requieren las hojas de cálculo de Excel para tener acceso a más de 2 gigabytes (GB) de memoria direccionable. Para leer más acerca de Excel y las ediciones de 64 bits de Office, vaya a los siguientes sitios Web de Microsoft:

ediciones de 64 bits de Office de 2013

Descripción de Office de 64 bits

Impresoras y controladores de vídeo
Cuando se inicia Excel, examina la impresora predeterminada y los controladores de vídeo que se mostrarán a los libros de Excel. Excel hace mucho uso de la impresora. Por lo tanto, se ejecutará incluso más lentamente cuando se guardan los archivos de Excel en vista previa de salto de página. Probar el archivo con diferentes impresoras como el controlador de impresora del escritor de documentos XPS de Microsoft o el controlador de vídeo VGA, determinará si el problema es con un controlador de vídeo o una impresora específica.

Hay un problema conocido con ciertos controladores de impresora de HP. Debe quitar estos controladores de impresora en el equipo. Para ver una lista de estos controladores de impresora, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2555016Excel 2010 puede bloquearse cuando se utiliza en impresoras HP

Más información

Si sigue teniendo problemas de bloqueos o interrupciones en Excel después de trabajar a través de los métodos de resolución que se mencionan a continuación, póngase en contacto con Microsoft Support para obtener más información.

Propiedades

Id. de artículo: 2758592 - Última revisión: lunes, 03 de marzo de 2014 - Versión: 15.0
La información de este artículo se refiere a:
  • Microsoft Office Excel 2007
  • Microsoft Excel 2010
  • Microsoft Excel 2013
Palabras clave: 
kbmt KB2758592 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2758592

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com