FIX: Configured time-out value for adapter binding properties does not work when a WCF workflow application uses an adapter to connect an LOB Server instance

Article ID: 2761439
Expand all | Collapse all

On This Page

This article applies to the following product:
  • BizTalk Adapter Pack 2010

Symptoms

Consider the following scenario:
  • There is a Windows Communication Foundation (WCF) workflow application that uses an adapter from Microsoft BizTalk Adapter Pack to connect to an instance of Line of Business (LOB) Server.
  • You configure the adapter binding properties to define a time-out value (for example, you configure a SendTimeout, ReceiveTimeout, or TransactionTimeout binding property).
In this scenario, the actual time-out value is the default value (60 seconds), regardless of what you defined in the binding properties.

Resolution

Cumulative update package information

For BizTalk Adapter Pack 2010

The hotfix that resolves this issue is included in cumulative update package 3 for BizTalk Adapter Pack 2010.

For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2617150 Cumulative update package 3 for BizTalk Adapter Pack 2010


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

Properties

Article ID: 2761439 - Last Review: July 12, 2013 - Revision: 1.0
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced kbbtsadapters KB2761439

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com