Form elements are missing or the wrong form is loaded in the Microsoft Dynamics CRM December 2012 Service Update

Article ID: 2781494 - View products that this article applies to.
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Symptoms

When Read Optimized forms are enabled, users may notice that the process and tab control are absent from the Lead, Opportunity, and Case forms. In addition, the Account and Contact forms may not show the tab control.

When Read Optimized forms are disabled, users may notice that the old form definition is loaded by default instead of the new form definition.


Cause

Both of these issues can happen after users utilize "Switch To Classic", and then interact with the form selector in the left navigation area of the classic form. When users switch to a different form, the last loaded form becomes the default form for any new instances of the entity type.

When Read Optimized forms are enabled, this setting causes the old form definition to appear more similar to that of the new form definition, which creates the impression that the process and tab control have been removed. 

When Read Optimized forms are disabled, the system will render the previous form definition in the classic form style found in Microsoft Dynamics CRM 2011.

Resolution

To switch to the default form experience when Read Optimized forms are enabled, follow these steps:

1. Open an entity record where the issue reproduces.

2. Click the Ellipses and select Switch to Classic.

3. In the left navigation area, in the form selector, change the form definition from "Information" to "<entity name>", where entity name is the name of the entity where the user is experiencing the issue. 

4. After the form refreshes, close and re-open the record.

To switch the default form experience when Read Optimized forms are disabled, follow these steps:

1. In the left navigation area, in the form selector, change the form definition from "Information" to "<entity name>", where entity name is the name of the entity where the user is experiencing the issue.

2. After the form refreshes, close and re-open the record.

More information

Note: This article applies to Microsoft Dynamics CRM Online customers who have applied the December 2012 Service Update. Microsoft Dynamics CRM Online organizations created after the December 2012 Service Update is released will have this update applied automatically.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2781494 - Last Review: January 4, 2013 - Revision: 3.1
Applies to
  • Microsoft Dynamics CRM 2011
Keywords: 
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