Clients cannot connect to IPv4-only resources when you use DirectAccess and external load balancing in Windows Server 2012

Article translations Article translations
Article ID: 2782560 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

Consider the following scenario:
  • You deploy DirectAccess on a computer that is running Windows Server 2012 in a network environment. The environment contains some intranet resources that only have IPv4 addresses.
  • You enable external load balancing in the environment.
  • A DirectAccess client connects from the Internet to internal resources that only have IPv4 addresses.
In this scenario, DNS64 does not resolve the computer names of the internal resources. Therefore, clients cannot connect to the internal resources.

Cause

This issue occurs because the firewall does not enumerate loopback addresses and treats them as unknown addresses.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 updates are included in the same packages.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Firewallapi.dll6.2.9200.16455757,76010-Nov-201204:21x64
Icfupgd.dll6.2.9200.16455105,98410-Nov-201204:21x64
Mpsdrv.sys6.2.9200.1645574,75210-Nov-201203:55x64
Mpssvc.dll6.2.9200.16455901,63210-Nov-201204:21x64
Wfapigp.dll6.2.9200.1645524,57610-Nov-201204:22x64
Firewallapi.dll6.2.9200.20559757,76010-Nov-201204:22x64
Icfupgd.dll6.2.9200.20559105,98410-Nov-201204:22x64
Mpsdrv.sys6.2.9200.2055974,75210-Nov-201203:55x64
Mpssvc.dll6.2.9200.20559901,63210-Nov-201204:22x64
Wfapigp.dll6.2.9200.2055924,57610-Nov-201204:23x64
Collapse this imageExpand this image
assets folding end collapsed

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameAmd64_2a0b7fae30e458b3d4233f63f481d7e6_31bf3856ad364e35_6.2.9200.16455_none_e8f6456a0f1f813b.manifest
File versionNot applicable
File size1,032
Date (UTC)12-Nov-2012
Time (UTC)05:15
PlatformNot applicable
File nameAmd64_32f03dc36439c9a564a59b8f663ce8da_31bf3856ad364e35_6.2.9200.16455_none_03c93573373be170.manifest
File versionNot applicable
File size695
Date (UTC)12-Nov-2012
Time (UTC)05:15
PlatformNot applicable
File nameAmd64_67c567b0c15356d0fe7478a9ad41867b_31bf3856ad364e35_6.2.9200.20559_none_0e394a16033e9e7e.manifest
File versionNot applicable
File size695
Date (UTC)12-Nov-2012
Time (UTC)05:15
PlatformNot applicable
File nameAmd64_8a8b52a0bc2937ac28f67d4f2c7f9ece_31bf3856ad364e35_6.2.9200.20559_none_81bc8219965cd241.manifest
File versionNot applicable
File size1,032
Date (UTC)12-Nov-2012
Time (UTC)05:15
PlatformNot applicable
File nameAmd64_networking-mpssvc-svc_31bf3856ad364e35_6.2.9200.16455_none_f2ff54d15187b63b.manifest
File versionNot applicable
File size234,052
Date (UTC)10-Nov-2012
Time (UTC)06:40
PlatformNot applicable
File nameAmd64_networking-mpssvc-svc_31bf3856ad364e35_6.2.9200.20559_none_f38cf2c46aa1bb61.manifest
File versionNot applicable
File size234,052
Date (UTC)10-Nov-2012
Time (UTC)06:30
PlatformNot applicable
File nameWow64_networking-mpssvc-svc_31bf3856ad364e35_6.2.9200.16455_none_fd53ff2385e87836.manifest
File versionNot applicable
File size74,570
Date (UTC)10-Nov-2012
Time (UTC)05:21
PlatformNot applicable
File nameWow64_networking-mpssvc-svc_31bf3856ad364e35_6.2.9200.20559_none_fde19d169f027d5c.manifest
File versionNot applicable
File size74,570
Date (UTC)10-Nov-2012
Time (UTC)04:58
PlatformNot applicable
Collapse this imageExpand this image
assets folding end collapsed

Properties

Article ID: 2782560 - Last Review: December 18, 2012 - Revision: 3.0
Applies to
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2782560

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com