Applies ToWindows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Home Basic Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptoms

Consider the following scenario:

  • You start an application on a computer that is running Windows 7 or Windows Server 2008 R2.

  • The application is developed by using the Windows Filtering Platform (WFP) API.

  • The WFP-based application tries to register a new callout routine in a callout table.

In this scenario, the computer crashes. Additionally, you receive a Stop error message that resembles following:

Stop 0x00000050 (Parameter1, Parameter2, Parameter3, Parameter4)

Notes

  • This Stop error describes a PAGE_FAULT_IN_NONPAGED_AREA issue.

  • The parameters in this Stop error message vary, depending on the configuration of the computer.

  • Not all "Stop 0x00000050" errors are caused by this issue.

Cause

This issue occurs because of a race condition that occurs when the callout table is full and space is allocated for a newly registered callout routine.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 7

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notesImportant Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 0.21xxx

    Windows 7 and Windows Server 2008 R2

    RTM

    LDR

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Netio.sys

6.1.7600.21385

239,960

29-Nov-2012

04:52

x86

Netio.sys

6.1.7601.22176

240,472

29-Nov-2012

05:41

x86

Fwpkclnt.sys

6.1.7601.22176

187,736

29-Nov-2012

05:41

x86

Tcpip.sys

6.1.7601.22176

1,307,992

29-Nov-2012

05:41

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Netio.sys

6.1.7600.21385

374,616

29-Nov-2012

05:44

x64

Netio.sys

6.1.7601.22176

376,680

29-Nov-2012

06:08

x64

Fwpkclnt.sys

6.1.7601.22176

288,088

29-Nov-2012

06:08

x64

Tcpip.sys

6.1.7601.22176

1,901,928

29-Nov-2012

06:08

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Netio.sys

6.1.7600.21385

710,488

29-Nov-2012

04:44

IA-64

Netio.sys

6.1.7601.22176

711,000

29-Nov-2012

04:55

IA-64

Fwpkclnt.sys

6.1.7601.22176

482,136

29-Nov-2012

04:55

IA-64

Tcpip.sys

6.1.7601.22176

3,822,440

29-Nov-2012

04:55

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.