Help and Support
 

powered byLive Search

Error message when you try to play an .avi file by using Windows Media Player

Article ID:279242
Last Review:December 18, 2007
Revision:6.0
This article was previously published under Q279242
On This Page

SYMPTOMS

When you use Windows Media Player and you try to play an .avi file, you may receive any of the following error messages:
Invalid File Format Error=8004022F
Cannot play back the file. The format is not supported. Error=80040265
Cannot play back the video stream: no suitable decompressor could be found. Error=80040255
No combination of filters could be found to render the stream. Error=80040218
The source filter for this file could not be loaded. Error=80040241
Windows Media Player cannot open filename. You may need to reboot to complete installation of a downloaded component. Please verify that the path and filename are correct and try again. Error=80004005
One or more codecs required to open this content could not be found. Error=C00D10D1
The following error messages typically display the Four Character Code (FourCC) identification in the error message:
Video not available, cannot find 'VIDS:xxxx' decompressor.
Unable to download an appropriate decompressor Error=80040200

Back to the top

CAUSE

This behavior can occur if the .avi was created by using a codec that was not installed on the host computer, and the codec is not available on an update site. This behavior can also occur because the file encoding for the .avi file is unsupported.

Back to the top

RESOLUTION

Method 1

Windows XP users

1.Click Start, point to Run, type mplay32.exe, and then press ENTER.
2.Click Open on the File menu, locate the .avi file that you want to play, and then drag the file to Windows Media Player.
3.When you receive the error message that specifies the FourCC identification, be aware that FourCC identification. For example, if you are using a VCR2 codec from ATI, "vids:vcr2" is the FourCC identification.
Note The FourCC identification that you receive may be in the vidc.iv50 format. If the FourCC identification displays "vidc" in the identification, the file contains video. The last four characters in the FourCC vidc identification specify the codec that you must have to play the file.

You must obtain the codec that you must have to play the .avi file from the appropriate manufacturer. Be aware that not all manufacturers provide their codecs for you to download.For information about how to contact the manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416 (http://support.microsoft.com/kb/65416/) Hardware and software vendor contact information, A-K

60781 (http://support.microsoft.com/kb/60781/) Hardware and software vendor contact information, L-P

60782 (http://support.microsoft.com/kb/60782/) Hardware and software vendor contact information, Q-Z
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Back to the top

Method 2

Windows Vista users

1.Double-click the .avi file that you want Windows Media Player to play.

You receive an error that resembles the following:
Windows Media Player encountered an error. Click the icon for more information
2.Click Error Details to receive the following message:
A codec is required to play this file
3.Click Web Help to display information about the missing codec and the corresponding link if the codec is available to download.

Windows XP users who have Windows Media Player 9, Windows Media Player 10, or Windows Media Player 11

1.Double-click the .avi file that you want Windows Media Player to play.
2.Under Now Playing, right-click the exclamation mark in front of the file name, and then select Error Details.
3.Click Web Help to display information about the missing codec and the corresponding link if the codec is available to download.
Note If you still have problems with Windows Media Player, you might want to ask someone for help or contact support. For information about how to contact support, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Back to the top

MORE INFORMATION

Be aware that .avi files can contain several different audio or video formats. To play an .avi file, you must use the .avi file player and the relevant codec file to decompress the .avi file. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
138261 (http://support.microsoft.com/kb/138261/) Error message: video not available, cannot find decompressor
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
230687 (http://support.microsoft.com/kb/230687/) Err msg: Unable to download an appropriate decompressor
Microsoft does not support playing .avi files that were created by using the MPEG4 version 3 codec.

To make sure that you have the latest information to troubleshoot issues with Microsoft Windows Media Player 11 for Windows Vista, Windows Media Player 11 for Windows XP, Windows Media Player 10, and earlier versions of Windows Media Player, we recommend that you visit one of the following Microsoft Web sites.

Back to the top

Windows Media Player 11 for Windows Vista

For information about how to troubleshoot Windows Media Player 11 for Windows Vista issues, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windowsmedia/player/windowsvista/troubleshooting.aspx (http://www.microsoft.com/windows/windowsmedia/player/windowsvista/troubleshooting.aspx)

Back to the top

Windows Media Player 11 for Windows XP

For information about how to troubleshoot Windows Media Player 11 for Windows XP issues, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windowsmedia/player/11/troubleshooting.aspx (http://www.microsoft.com/windows/windowsmedia/player/11/troubleshooting.aspx)

Back to the top

Windows Media Player 10

For information about how to troubleshoot Windows Media Player 10 issues, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windowsmedia/player/10/troubleshooting.aspx (http://www.microsoft.com/windows/windowsmedia/player/10/troubleshooting.aspx)

Back to the top

Earlier versions of Windows Media Player

For information about how to troubleshoot issues with earlier versions of Windows Media Player, visit the following Microsoft Web site:
http://www.microsoft.com/windows/windowsmedia/player/previousversions.aspx (http://www.microsoft.com/windows/windowsmedia/player/previousversions.aspx)
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
316992 (http://support.microsoft.com/kb/316992/) Windows Media Player multimedia file formats
138261 (http://support.microsoft.com/kb/138261/) Error Message: Video Not Available, Cannot Find Decompressor
230687 (http://support.microsoft.com/kb/230687/) Err msg: Unable to download an appropriate decompressor
814629 (http://support.microsoft.com/kb/814629/) Windows Media Player stops responding or generates an error message while playing an AVI file when you switch between a windowed and full-screen command prompt
278947 (http://support.microsoft.com/kb/278947/) Error message "Unable to download an appropriate decompressor." playing an .avi file
291818 (http://support.microsoft.com/kb/291818/) How to download codecs automatically in Windows Media Player for Windows XP
842186 (http://support.microsoft.com/kb/842186/) You receive an "Unable to download appropriate decompressor" error message in Windows Media Player
If these Microsoft Knowledge Base articles do not help you resolve the problem, or if you experience symptoms that differ from those that this article describes, please search the Microsoft Knowledge Base for more information. To search the Microsoft Knowledge Base, visit the following Microsoft Web site:
http://support.microsoft.com (http://support.microsoft.com/)
Then, type the text of the error message that you receive, or type a description of the problem in the Search Support (KB) field.

Back to the top


APPLIES TO
Microsoft Windows Media Player 8.01
Microsoft Windows Media Player 7.1
Microsoft Windows Media Player 6.4
Microsoft Windows Media Player 7.0
Microsoft Windows Media Player 11
Microsoft Windows Media Player 10

Back to the top

Keywords: 
kbfile kbprb kbresolve KB279242

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.