Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

PROBLEM

An Office 365 administrator can't access the Exchange Control Panel of a Microsoft Exchange Online user. When the administrator clicks Manage My Organization in the Exchange Control Panel, and then clicks Another User, he or she receives the following error message:

Sorry! Access Denied – You do not have permission to open this page. If you are a new user or were recently assigned credentials, please wait 15 minutes and try again

CAUSE

This issue occurs if the Office 365 administrator account is assigned to the "empty" role assignment policy. In this situation, the administrator doesn't have the necessary role-based access control (RBAC) permissions to access Exchange Control Panel through Outlook Web App.

SOLUTION

To resolve this issue, follow these steps:

  1. Connect to Exchange Online by using remote PowerShell. For more information about how to do this, go to the following Microsoft website:

    Connect to Exchange Online Using Remote PowerShell

  2. Retrieve another role assignment policy. To do this, run the following command:

    $a= Get-RoleAssignmentPolicy -Organization contoso.com | where{$_.IsDefault -ne $true} Note If the organization contains no additional role assignment policies, you must create a role assignment policy before you run this command. For more information about how to do this in Exchange Online, go to the following Microsoft website:

    Create a new role assignment policy

  3. Assign the role assignment policy to a global administrator. To do this, run the following command:

    Set-Mailbox joe@contoso.com -RoleAssignmentPolicy $a.Identity

  4. Make sure that the role was assigned correctly. To do this, run the following command:

    Get-Mailbox joe@contoso.com -RoleAssignmentPolicy

Still need help? Go to Microsoft Community.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×