Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You have a Remote Desktop Session Host (RD Session Host) server that is running Windows Server 2012.

  • The RD Session Host server has more than 50 Remote Desktop Services (RDS) clients connected, and that causes the RD Session Host server to be under a heavy load.

  • The RD Session Host server receives a Remote Desktop Protocol (RDP) session from a Windows 7 Service Pack 1 (SP1)-based RDS client that has RDP 8.0 installed.  

    Note For more information about how to install and enable RDP 8.0 on a computer that is running Windows 7 SP1, click the following article number to view the article in the Microsoft Knowledge Base:

    2592687 Description of the Remote Desktop Protocol 8.0 update for Windows 7 SP1 and Windows Server 2008 R2 SP1

In this scenario, the graphics update for all the connected clients freezes for at least 100 milliseconds. Additionally, this issue recurs when the RD Session Host server receives new RDP sessions from any other clients.

Cause

This issue occurs because a User Datagram Protocol (UDP) connection object is not created immediately after an Acknowledgement (ACK) packet is received. This behavior provides an opportunity for all the other connections that have a pending data to be sent. Additionally, when multiple connections are established at the same time, if the higher layers of some connections are not ready, a 100-millisecond delay occurs to let the higher layer be registered with the RDP-UDP layer.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.20 xxx

    Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Rdpcorets.dll

6.2.9200.20587

3,245,056

20-Dec-2012

21:34

x64

Rdpudd.dll

6.2.9200.16384

235,520

26-Jul-2012

02:30

x64

Rdpvideominiport.sys

6.2.9200.16384

27,888

26-Jul-2012

03:17

x64

Rfxvmt.dll

6.2.9200.16384

36,352

26-Jul-2012

03:07

x64




Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×