W3wp.exe process consumes excessive CPU and memory resources on an Exchange Client Access server after you apply Update Rollup 5 version 2, Update Rollup 6 or Update Rollup 7 for Exchange Server 2010 SP2

Article translations Article translations
Article ID: 2800133 - View products that this article applies to.
Expand all | Collapse all

Symptoms

Assume that you apply Update Rollup 5 version 2, Update Rollup 6 or Update Rollup 7 for Microsoft Exchange Server 2010 Service Pack 2 (SP2). When a delegate of a user declines a meeting request, the W3wp.exe process for the MSExchangeSyncAppPool and MSExchangeServicesAppPool application pools consumes excessive CPU and memory resources on an Exchange Server 2010 Client Access server.

Note You can use the Performance Monitor to monitor CPU and memory resources. The % Processor Time counter monitors CPU usage. The Allocated Bytes/sec counter monitors memory resources and displays the rate at which W3wp.exe allocates memory. The % Time in GC counter monitors memory resources and the time that W3wp.exe spends processing garbage collections. To add these counters in the Performance Monitor, follow these steps:
  • Select the % Processor Time counter under the Processor object, and then select All instances.
  • Select the Allocated Bytes/sec counter under the .NET CLR Memory object, and then select w3wp.
  • Select the % Time in GC counter under the .NET CLR Memory object, and then select w3wp.

Cause

This issue is caused by a corrupted PR_SCHDINFO_APPT_TOMBSTONE property in the user's free/busy data in the Exchange Information store. The corrupted property then causes memory pressure on the server and triggers W3wp.exe to process garbage collections.

Resolution

To resolve this issue, install Exchange Server 2010 Service Pack 3 (SP3) on the Exchange Server 2010 servers. For more information about Exchange Server 2010 SP3, click the following article number to view the article in the Microsoft Knowledge Base:
2808208 Description of Exchange Server 2010 Service Pack 3

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about Update Rollup 5 version 2 for Exchange Server 2010 SP2, click the following article number to view the article in the Microsoft Knowledge Base:
2785908 Description of Update Rollup 5 version 2 for Exchange Server 2010 Service Pack 2

For more information about Update Rollup 6 for Exchange Server 2010 SP2, click the following article number to view the article in the Microsoft Knowledge Base:
2746164 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 2
For more information about Update Rollup 7 for Exchange Server 2010 SP2, visit the following Microsoft website:

http://www.microsoft.com/en-us/download/details.aspx?id=39863

For more information about the PR_SCHDINFO_APPT_TOMBSTONE property, visit the following Microsoft website:
General information about the PR_SCHDINFO_APPT_TOMBSTONE property
For more information about performance monitor counters, visit the following Microsoft website:
General information about performance monitor counters

Properties

Article ID: 2800133 - Last Review: August 24, 2013 - Revision: 6.0
Applies to
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2800133

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com