Errore "0x8000500C" quando si utilizza ADSI per leggere dati da un server di OpenLDAP da 8 Windows o Windows Server 2012

Traduzione articoli Traduzione articoli
Identificativo articolo: 2802148 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si supponga di utilizzare uno script per accedere ai dati della cache dello schema di Active Directory Service Interfaces (ADSI) da un computer che esegue Windows 8 o Windows Server 2012. ╚ possibile eseguire lo script per eseguire query Lightweight Directory Access Protocol (LDAP) su un server OpenLDAP. In questo caso, le query hanno esito positivo e i dati vengono restituiti al client. Tuttavia, viene visualizzato un messaggio di errore analogo al seguente:
0x8000500C, il tipo di dati di directory non pu˛ essere convertito da un tipo di dati DS nativo.

Cause

Questo problema si verifica perchÚ lo schema ADSI di memorizzazione nella cache processo richiede un attributo non Ŕ supportato dal server OpenLDAP. Nelle versioni precedenti di Windows, un tentativo di recuperare l'attributo utilizzando il processo di memorizzazione nella cache viene ignorato da Windows. Tuttavia, Windows 8 e Windows Server 2012 ottimizzare il processo di download dello schema per rendere obbligatorio il recupero dell'attributo.

Risoluzione

Il processo di download dello schema che non Ŕ pi¨ necessaria la presenza dell'attributo viene apportata una modifica.

Informazioni sull'hotfix

Un hotfix supportato Ŕ disponibile da Microsoft. Tuttavia, questo hotfix Ŕ destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, esiste una sezione "DisponibilitÓ del Download dell'Hotfix" nella parte superiore di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota. Se si verificano ulteriori problemi o se occorrono attivitÓ di risoluzione, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota. Il modulo "DisponibilitÓ del Download dell'Hotfix" Visualizza le lingue per cui Ŕ disponibile l'hotfix. Se non Ŕ disponibile la lingua, Ŕ perchÚ non Ŕ disponibile alcun hotfix per tale lingua.

Prerequisiti

Per applicare questo hotfix, Ŕ necessario eseguire Windows 8 o Windows Server 2012.

Informazioni sul Registro di sistema

Per applicare questo hotfix, Ŕ necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo avere applicato questo hotfix, Ŕ necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

Riduci l'immagineEspandi l'immagine
assets folding start collapsed
La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file sono elencate nell'ora UTC (Coordinated Universal Time). Le date e ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e i tempi cambiano quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows 8 e Windows Server 2012
Importante. Aggiornamenti rapidi di Windows 8 e aggiornamenti rapidi di Windows Server 2012 sono inclusi nel pacchetto stesso. Tuttavia, solo "Windows 8" Ŕ elencato nella pagina richiesta Hotfix. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella sezione "Windows 8" nella pagina. Fare riferimento sempre alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo al quale si applica ogni hotfix.
  • I file che si applicano a un prodotto specifico, un'attivitÓ cardine (RTM, SPn), e il ramo del servizio (LDR, GDR) pu˛ essere identificato esaminando i numeri di versione del file come indicato nella tabella seguente:
    Riduci questa tabellaEspandi questa tabella
    VersioneProdottoAttivitÓ cardineRamo del servizio
    6.2.920 xxx 0,20Windows 8 e Windows Server 2012RTMLDR
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nel "ulteriori informazioni sui file per Windows 8 e Windows Server 2012". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato sono estremamente importanti mantenere lo stato dei componenti aggiornati. I file di catalogo di sicurezza, per i quali non sono elencati gli attributi, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni basate su x86 di Windows 8
Riduci l'immagineEspandi l'immagine
assets folding start collapsed
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Adsldpc. dll6.2.9200.20615218.62423-Gen-201323:29x86
Riduci l'immagineEspandi l'immagine
assets folding end collapsed
Per tutte le versioni x64 di Windows 8 e Windows Server 2012
Riduci l'immagineEspandi l'immagine
assets folding start collapsed
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Adsldpc. dll6.2.9200.20615238,59223-Gen-201323:22x64
Riduci l'immagineEspandi l'immagine
assets folding end collapsed

Riduci l'immagineEspandi l'immagine
assets folding end collapsed

Status

Microsoft ha confermato che questo Ŕ un problema nei prodotti Microsoft elencati nella sezione "Si applica a".

I prodotti di terze parti descritti in questo articolo sono forniti da societÓ indipendenti da Microsoft. Microsoft non rilascia alcuna garanzia implicita o esplicita, sulle prestazioni o sull'affidabilitÓ di questi prodotti.

Informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Riduci l'immagineEspandi l'immagine
assets folding start collapsed

Ulteriori informazioni sui file per Windows 8 e Windows Server 2012

File aggiuntivi per tutte le versioni x86 supportate di Windows 8
Riduci l'immagineEspandi l'immagine
assets folding start collapsed
Riduci questa tabellaEspandi questa tabella
Nome del fileX86_microsoft-windows-a...terfaccia-ldapc-layer_31bf3856ad364e35_6.2.9200.20615_none_5cb3d06f50c80e15.manifest
Versione del fileNon applicabile
Dimensione del file6,203
Data (UTC)24-Gen-2013
Ora (UTC)00:03
PiattaformaNon applicabile
Riduci l'immagineEspandi l'immagine
assets folding end collapsed
File aggiuntivi per tutte supportate versioni basate su x64 di Windows 8 e Windows Server 2012
Riduci l'immagineEspandi l'immagine
assets folding start collapsed
Riduci questa tabellaEspandi questa tabella
Nome del fileAmd64_microsoft-windows-a...terfaccia-ldapc-layer_31bf3856ad364e35_6.2.9200.20615_none_b8d26bf309257f4b.manifest
Versione del fileNon applicabile
Dimensione del file6,207
Data (UTC)24-Gen-2013
Ora (UTC)02:06
PiattaformaNon applicabile
Riduci l'immagineEspandi l'immagine
assets folding end collapsed

Riduci l'immagineEspandi l'immagine
assets folding end collapsed

ProprietÓ

Identificativo articolo: 2802148 - Ultima modifica: mercoledý 13 marzo 2013 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Windows 8
  • Windows 8 Enterprise
  • Windows 8 Pro
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
Chiavi:á
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbmt KB2802148 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2802148
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com