Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You access a mailbox by using a Microsoft Exchange ActiveSync device in a Microsoft Exchange Server 2010 environment.

  • You have some Short Message Service (SMS) messages that have empty To or From fields on the device.

  • You try to synchronize the device with the mailbox.

In this scenario, the synchronization fails and the following error is logged in the Application log on the Client Access server:

Cause

This issue occurs because Exchange ActiveSync does not correctly handle the empty To and From fields of the SMS messages during the synchronization operation. Therefore, an ArgumentNullException exception is thrown and the synchronization operation fails.

Resolution

To resolve this issue, install the following update rollup:

2803727 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 3

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about Exchange ActiveSync, go to the following Microsoft website:

General information about Exchange ActiveSync

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×