Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Utilizzare un'applicazione per aprire i file eseguibili in rete da un computer client che esegue Windows 7 o Windows Server 2008 R2.

  • Questa applicazione apre anche altri file che consentono il blocco opportunistico (oplock) attraverso la rete.

  • Un altro processo tenta di accedere a un file condiviso che l'applicazione è già aperto in rete.

  • Il server richiede che il client interrompe l'oplock.

In questo scenario, il computer client non separa l'oplock. Di conseguenza, il file condiviso rimane aperto sul server e altri client non possono utilizzare tale file.

Causa

Questo problema si verifica perché il gestore della memoria del computer client contiene oggetti eseguibili e non viene chiuso. Tuttavia, il server considera gli oggetti eseguibili da chiudere e riutilizza l'ID del nuovo file di un altro. Ciò causa un conflitto di ID di file. Pertanto, quando viene emessa la richiesta di interruzione oplock, il client elabora il precedente oggetto eseguibile anziché il nuovo file.

Risoluzione

Informazioni sull'hotfix

La correzione di questo problema è inclusa nell'aggiornamento 2732673. Per risolvere il problema, installare l'aggiornamento 2732673 dal seguente articolo della Microsoft Knowledge Base:

2732673 messaggio di errore "Scrittura ritardata non riuscita" quando il file pst sono memorizzato su un server di rete che esegue Windows Server 2008 R2

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows 7 Service Pack 1 (SP1) o Windows Server 2008 R2 SP1.

Per ulteriori informazioni su come ottenere un service pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

976932 informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per applicare questo hotfix, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×