Artigo: 283807 - Última revisão: quarta-feira, 28 de Setembro de 2011 - Revisão: 9.0

Não são apresentadas imagens em Web sites no Internet Explorer

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Sumário

Este artigo descreve como resolver o problema em que as imagens (gráficos ou imagens) não são apresentadas em Web sites no Internet Explorer. Este artigo contém os passos de resolução de problemas para utilizadores principiantes, intermédios e avançados.

Sintomas

Ao abrir uma página Web, poderá não ser apresentada uma ou mais imagens. Em vez disso, é apresentado um X vermelho ou algum tipo de marcador de posição.

Causa

Este comportamento pode ocorrer caso se verifique uma das seguintes condições:
  • A página Web inclui um tipo de imagem não suportado pelo Internet Explorer.
  • A caixa de verificação Mostrar Imagens não está seleccionada no separador Avançadas da caixa de diálogo Opções da Internet no Internet Explorer ou o acessório Web Toggle Images.exe foi utilizado para desactivar as imagens no Internet Explorer.
  • A imagem é apresentada com base num script, controlo ActiveX, cookie, programa Java ou informações de referência para HTTP e o computador ou a rede está configurado(a) para bloquear uma ou mais destas funcionalidades. Por exemplo, poderá ter o Internet Explorer, Norton Internet Security (NIS) ou Norton Personal Firewall (NPF) 2002 da Symantec Corporation configurado para bloquear uma ou mais destas funcionalidades.
  • O Internet Explorer não consegue determinar o conjunto de caracteres (também denominado página de códigos ou codificação) utilizado pela página Web ou poderá faltar ou estar danificado um ficheiro ou uma chave de registo necessária para apresentar a página Web com o conjunto de caracteres adequado. Por predefinição, o Internet Explorer utiliza o conjunto de caracteres especificado no tipo de conteúdo HTTP devolvido pelo servidor, no conjunto de caracteres especificado pelo meta-elemento no documento da página Web, ou na preferência de codificação expressa pelo utilizador se não for devolvido um tipo de conteúdo HTTP pelo servidor e não for especificado um meta-elemento no documento da página Web.

Resolução

Para resolver este problema, siga os métodos descritos nesta secção pela ordem em que são apresentados até o problema ser resolvido.

Será mais fácil seguir os passos descritos se imprimir primeiro este artigo.

Estes métodos destinam-se a utilizadores principiantes a intermédios. Após cada método, actualize o Internet Explorer para verificar se o problema foi resolvido. Se o problema não for resolvido, experimente o método seguinte.

Método 1: Verificar se as imagens estão disponíveis noutro Web site

Por vezes, a hiperligação para uma imagem num Web site está danificada, sendo este o motivo pela qual uma imagem não é apresentada. Visite outro Web site para determinar se aí as imagens estão a ser apresentadas correctamente. Se estiverem a ser apresentadas correctamente, não existe nada de errado no Internet Explorer. Em vez disso, o Web site que está a visitar poderá estar danificado.

Se conseguir ver as imagens noutro Web site, o procedimento está concluído. Se as imagens não forem visíveis ou se não conseguir determinar se o Web que está a visitar está danificado, experimente limpar os ficheiros temporários da Internet através do método 2.

Nota: se utilizar o Internet Explorer 8, experimente a Vista de Compatibilidade. Para tal, inicie o Internet Explorer 8, clique em Definições da Vista de Compatibilidade no menu Ferramentas e adicione o Web site que pretende ver utilizando a Vista de Compatibilidade.

Método 2: Limpar ficheiros temporários da Internet

Ao limpar os ficheiros temporários da Internet cria mais espaço no disco rígido. Se o disco rígido estiver quase cheio, isto poderá afectar a capacidade de visualização de imagens num Web site.

Para limpar os ficheiros temporários da Internet, siga estes passos:

Internet Explorer 8
  1. Inicie o Internet Explorer 8.
  2. No menu Ferramentas, clique em Opções da Internet.
  3. No separador Geral, clique em Eliminar em Histórico de Navegação.
  4. Na caixa de diálogo Eliminar Histórico de Navegação, clique para desmarcar todas as caixas de verificação, excepto a caixa de verificação Ficheiros Temporários da Internet e clique em Eliminar.
  5. Clique em OK para fechar a caixa de diálogo Opções da Internet.
Internet Explorer 7
  1. Inicie o Internet Explorer 7.
  2. No menu Ferramentas clique em Eliminar Histórico de Navegação.
  3. Na caixa de diálogo Eliminar Histórico de Navegação, clique em Eliminar Ficheiros.
  4. Clique em OK para fechar a caixa de diálogo Opções da Internet.
Internet Explorer 6 e versões anteriores
  1. No menu Ferramentas, clique em Opções da Internet.
  2. No separador Geral, clique em Eliminar Ficheiros em Ficheiros temporários da Internet.
  3. Clique para seleccionar a caixa de verificação Eliminar todo o conteúdo offline e clique em OK.
  4. Clique em OK para fechar a caixa de diálogo Opções da Internet.
Verifique se consegue agora ver as imagens. Se, mesmo assim, não conseguir ver imagens, experimente o método 3.

Método 3: Verifique se a opção Mostrar Imagens não foi desactivada

Se a opção Mostrar Imagens no Internet Explorer estiver desactivada, não conseguirá ver imagens. Para determinar se a opção Mostrar Imagens está desactivada, siga estes passos:
  1. No menu Ferramentas, clique em Opções da Internet.
  2. Clique no separador Avançadas e certifique-se de que a caixa de verificação Mostrar Imagens está seleccionada em Multimédia.
  3. Clique em OK.
Determine se consegue agora ver as imagens. Se, mesmo assim, não conseguir ver imagens, experimente o método 4.

Método 4: Activar processamento de scripts, controlos ActiveX, cookies e programas Java

Active o processamento de scripts, controlos ActiveX, cookies e programas Java para assegurar que o seu computador está configurado para permitir que as páginas Web sejam executadas da forma para a qual foram concebidas.

Para tal, siga estes passos:
  1. No menu Ferramentas, clique em Opções da Internet.
  2. Clique no separador Segurança e clique em Nível Predefinido (se disponível) para a zona que contém a página Web (por exemplo, zona Internet).
  3. Se estiver a utilizar o Internet Explorer 6, clique no separador Privacidade e clique em Predefinição (se disponível).
Verifique se consegue agora ver as imagens. Se, mesmo assim, não conseguir ver imagens, terá de recorrer à resolução de problemas avançada. Se não estiver à vontade com a resolução de problemas avançada, talvez seja melhor consultar a secção "Passos Seguintes" para obter outros recursos que poderá utilizar para obter ajuda.

Resolução de Problemas Avançada

Método 1: Verifique se o tipo de imagem é suportado pelo Internet Explorer

O Internet Explorer apresenta imagens com as extensões .art, .wmf, .emf, .png, .mov, .xbm, .avi, .mpg, .gif, .jpg, .mpeg e .bmp.

Clique com o botão direito do rato no X vermelho ou no marcador de posição da imagem e clique em Propriedades. Verifique se o tipo da imagem é suportado pelo Internet Explorer examinando os valores de Tipo ou Endereço (URL) da caixa de diálogo Propriedades. Por exemplo, um ficheiro GIF (Graphics Interchange Format) lista Imagem GIF para o valor Tipo. O valor Endereço (URL) termina em .gif.

Se o tipo de imagem não for suportado pelo Internet Explorer, terminou o procedimento. Se o tipo de imagem for suportado, avance para o método 2.

Método 2: Certifique-se de que o acessório Web Toggle Images.exe não está presente e a desactivar imagens

O programa Toggle Images.exe pode ser definido para desactivar imagens. Certifique-se de que está definido para mostrar imagens.

Se tiver o acessório Web Toggle Images.exe instalado, clique na hiperligação Toggle Images.exe na barra Hiperligações no Internet Explorer para activar as imagens.

Nota: se a barra Hiperligações não estiver visível, clique com o botão direito do rato numa área em branco da barra de ferramentas e verifique se existe uma marca de verificação junto de Hiperligações. Se a hiperligação Toggle Images.exe não estiver visível na barra Hiperligações, clique na seta com dois parênteses angulares no extremo direito da barra Hiperligações.

Se este método resolveu o problema, o procedimento está concluído. Se, mesmo assim, não conseguir ver imagens, avance para o método 3.

Método 3: Certifique-se de que um programa de segurança da Internet, de firewall ou de bloqueio de cookies de terceiros não está a causar o problema

Se estiver a utilizar um programa de segurança da Internet, de firewall ou de bloqueio de cookies de terceiros, contacte o fabricante do programa para obter informações sobre como activar o processamento de scripts, controlos ActiveX, cookies, programas Java, anúncios e informações de referência HTTP. Por exemplo, se tiver o Norton Internet Security (NIS) ou o Norton Personal Firewall (NPF) instalado, visite os seguintes Web sites da Symantec Corporation para obter mais informações sobre as várias definições destes produtos que poderão provocar este comportamento que este artigo descreve:
http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam)
http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam)
Se aceder à Internet através de uma rede local (LAN), contacte o administrador da rede local para verificar se o processamento de scripts, controlos ActiveX, cookies, programas Java, anúncios e informações de referência HTTP não estão bloqueados por uma firewall ou por outras funcionalidades de segurança na rede.

Se este método resolveu o problema, o procedimento está concluído. Se, mesmo assim, não conseguir ver imagens, avance para o método 4.

Método 4: Activar a opção de codificação Selecção automática

No Internet Explorer 7 ou no Internet Explorer 8, no menu Página, aponte para Codificação. Se não for apresentada uma marca de verificação junto de Selecção Automática, clique em Selecção Automática.

No Internet Explorer 6, no menu Ver, aponte para Codificação. Se não for apresentada uma marca de verificação junto de Selecção Automática, clique em Selecção Automática.

Se este método resolveu o problema, o procedimento está concluído. Se, mesmo assim, não conseguir ver imagens, avance para o método 5.

Método 5: Certifique-se de que a opção de codificação está definida para o idioma correcto

No Internet Explorer 7 ou no Internet Explorer 8, no menu Página, aponte para Codificação e clique no idioma adequado para a página Web que está a tentar visualizar. Por exemplo, se a página Web estiver em inglês (Estados Unidos), clique em Europa Ocidental (ISO) ou em Europa Ocidental (Windows).

No Internet Explorer 6, no menu Ver, aponte para Codificação e clique no idioma adequado à página Web que está a tentar visualizar. Por exemplo, se a página Web estiver em inglês (Estados Unidos), clique em Europa Ocidental (ISO) ou em Europa Ocidental (Windows).

Se o idioma pretendido não estiver disponível no menu Ver no Internet Explorer 6 ou no menu Página no Internet Explorer 7 ou Internet Explorer 8, siga estes passos para o adicionar:
  1. No menu Ferramentas, clique em Opções da Internet.
  2. No separador Geral, clique em Idiomas e clique em Adicionar.
  3. Clique no idioma adequado e clique em OK.
A Microsoft fornece informações sobre contactos de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes.

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede qualquer garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

Se este método resolveu o problema, o procedimento está concluído. Se, mesmo asim, não conseguir ver imagens, avance para a secção "Passos Seguintes".

PASSOS SEGUINTES

Se estes métodos não tiverem funcionado, pode utilizar o Web site de Suporte Técnico da Microsoft para encontrar outras soluções para o problema. Alguns dos serviços fornecidos nos Web sites do Suporte Técnico da Microsoft incluem os seguintes:
  • Base de Dados de Conhecimento pesquisável (http://support.microsoft.com/search/?adv=1) : Pesquise informações de suporte técnico e ferramentas de ajuda automática para produtos Microsoft.
  • Centros de Soluções (http://support.microsoft.com/select/?target=hub) : Visualize as perguntas mais frequentes e os destaques do suporte de produtos específicos.
  • Newsgroups de Suporte Técnico da Microsoft (http://www.microsoft.com/communities/newsgroups/default.mspx) : Contacte os seus parceiros, colegas e profissionais mais experientes da Microsoft (MVP).
  • Outras Opções de Suporte (http://support.microsoft.com/default.aspx?pr=csshome) : Utilize a Web para colocar uma questão, contactar o Suporte Técnico da Microsoft ou enviar comentários.
Se continuar a ter problemas depois de utilizar estes Web sites da Microsoft ou se não conseguir encontrar uma solução para o problema no Web site de Suporte Técnico da Microsoft, clique na seguinte hiperligação para contactar o Suporte.
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

A informação contida neste artigo aplica-se a:
  • Windows Internet Explorer 8
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional Edition
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
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