Makale numarası: 283807 - Son Gözden Geçirme: 28 Eylül 2011 Çarşamba - Gözden geçirme: 8.0

Internet Explorer'da Web sitelerindeki resimler görüntülenmiyor

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.

Bu Sayfada

Hepsini aç | Hepsini kapa

Özet

Bu makalede, Internet Explorer'da Web sitelerindeki resimlerin (grafiklerin veya görüntülerin) görüntülenmemesine neden olan bir sorunun nasıl giderileceği açıklanır. Bu makale deneyimsiz, orta düzeyde ve deneyimli bilgisayar kullanıcıları için sorun giderme adımları içermektedir.

Belirtiler

Bir Web sayfasını açtığınızda bir veya daha fazla resim görüntülenmeyebiliyor. Bunun yerine, kırmızı bir X veya başka türde bir yer tutucu görüyorsunuz.

Neden

Bu davranış aşağıdaki durumlardan biri doğruysa oluşabilir:
  • Web sayfası, Internet Explorer'ın desteklemediği bir resim türünü içermektedir.
  • Internet Explorer'daki Internet Seçenekleri iletişim kutusunun Gelişmiş sekmesinde Resimleri Göster onay kutusu seçili değildir veya resimleri devre dışı bırakmak üzere Toggle Images.exe Web donatısı kullanılmıştır.
  • Resim bir komut dizisine, ActiveX denetimine, tanımlama bilgisine, Java programına veya HTTP başvuru bilgilerine dayalı olarak görüntülenir ve bilgisayarınız veya ağınız bu özelliklerden birini veya birden fazlasını engelleyecek biçimde yapılandırılmıştır. Örneğin, Internet Explorer veya Symantec Corporation tarafından geliştirilen Norton Internet Security (NIS) ya da Norton Personal Firewall (NPF) 2002 bu özelliklerden birini veya daha fazlasını engelleyecek biçimde yapılandırılmış olabilir.
  • Internet Explorer, Web sayfasının kullandığı karakter kümesini (kod sayfası veya kodlama olarak da bilinir) belirleyememektedir veya Web sayfasını uygun karakter kümesiyle görüntülemek için gereken bir dosya ya da kayıt defteri anahtarı eksik veya bozuk olabilir. Internet Explorer varsayılan olarak, sunucunun döndürdüğü HTTP içerik türünde belirtilen karakter kümesini, Web sayfası belgesindeki meta öğesinin belirttiği karakter kümesini veya sunucu tarafından HTTP içerik türü döndürülmezse ve Web sayfası belgesinde meta öğesi belirtilmemişse Kodlama tercihinizi kullanır.

Çözüm

Bu sorunu düzeltmek için, bu bölümde açıklanan yöntemleri sorun giderilinceye kadar sunuldukları sırada uygulayın.

Bu makaleyi yazdırarak adımları izlemeniz daha kolay olabilir.

Bu yöntemler deneyimsiz ve orta düzeyde deneyimli bilgisayar kullanıcıları için tasarlanmıştır. Her yöntemin ardından sorunun giderilmiş olup olmadığını denetlemek üzere Internet Explorer'ı yenileyin. Sorun giderilmemişse sonraki yöntemi deneyin.

Yöntem 1: Başka bir Web sitesinde resimlerin görüntülenip görüntülenmediğine bakın

Bazı durumlarda bir Web sitesindeki resmin bağlantısı bozuk olduğu için resim görüntülenmemektedir. Başka bir Web sitesini ziyaret edip resimlerin düzgün görüntülenip görüntülenmediğini belirleyin. Doğru görüntüleniyorlarsa, Internet Explorer ile ilgili bir sorun yoktur. Bunun yerine, ziyaret etmekte olduğunuz Web sitesi bu soruna yol açıyor olabilir.

Başka bir Web sitesindeki resimleri görüntüleyebiliyorsanız işiniz tamamlanmış demektir. Hiçbir resmi görüntüleyemiyorsanız veya ziyaret ettiğiniz Web sitesinde sorun bulunup bulunmadığını belirleyemiyorsanız, yöntem 2'yi kullanarak geçici Internet dosyalarını temizlemeyi deneyin.

Not Internet Explorer 8 kullanıyorsanız, Uyumluluk Görünümü'nü deneyin. Bunu yapmak için, Internet Explorer 8'i başlatıp Araçlar menüsünde Uyumluluk Görünümü Ayarları'nı tıklatın ve sonra da Uyumluluk Görünümü'nü kullanarak görüntülemek istediğiniz Web sitesini ekleyin.

Yöntem 2: Geçici Internet dosyalarını temizleyin

Geçici Internet dosyalarını temizlemek, sabit diskinizde daha fazla kullanılabilir alan açar. Sabit diskiniz dolmak üzereyse, bu durum Web sitesindeki resimleri görüntüleme becerinizi etkileyebilir.

Geçici Internet dosyalarını temizlemek için aşağıdaki adımları uygulayın:

Internet Explorer 8
  1. Internet Explorer 8'i başlatın.
  2. Araçlar menüsünden Internet Seçenekleri'ni tıklatın.
  3. Genel sekmesinde, Gözatma Geçmişi altında Sil'i tıklatın.
  4. Gözatma Geçmişini Sil iletişim kutusunda, Geçici Internet Dosyaları onay kutusu dışındaki tüm onay kutularını tıklatıp temizleyin ve sonra da Sil'i tıklatın.
  5. Tamam'ı tıklatarak Internet Seçenekleri iletişim kutusunu kapatın.
Internet Explorer 7
  1. Internet Explorer 7'yi başlatın.
  2. Araçlar menüsünde Gözatma Geçmişini Sil'i tıklatın.
  3. Gözatma Geçmişini Sil iletişim kutusunda Dosyaları Sil'i tıklatın.
  4. Tamam'ı tıklatarak Internet Seçenekleri iletişim kutusunu kapatın.
Internet Explorer 6 ve önceki sürümleri
  1. Araçlar menüsünden Internet Seçenekleri'ni tıklatın.
  2. Genel sekmesinde, Temporary Internet Files altından Dosyaları Sil'ı tıklatın.
  3. Tüm çevrimdışı içeriği sil onay kutusunu tıklatıp seçin ve Tamam'ı tıklatın.
  4. Tamam'ı tıklatarak Internet Seçenekleri iletişim kutusunu kapatın.
Resimleri artık görüntüleyip görüntüleyemediğinizi denetleyin. Resimleri yine de görüntüleyemiyorsanız yöntem 3'ü deneyin.

Yöntem 3: Resimleri Göster seçeneğinin devre dışı bırakılmamış olduğunu doğrulayın

Internet Explorer'daki Resimleri Göster seçeneği devre dışı bırakılmışsa resimleri görüntüleyemezsiniz. Resimleri Göster seçeneğinin devre dışı bırakılmış olup olmadığını belirlemek için şu adımları izleyin:
  1. Araçlar menüsünden Internet Seçenekleri'ni tıklatın.
  2. Gelişmiş sekmesini tıklatın ve sonra da Multimedya altında Resimleri Göster onay kutusunun seçili olduğunu doğrulayın.
  3. Tamam'ı tıklatın.
Resimleri artık görüntüleyip görüntüleyemediğinizi belirleyin. Resimleri yine de görüntüleyemiyorsanız yöntem 4'ü deneyin.

Yöntem 4: Komut dizileri, ActiveX denetimleri, tanımlama bilgileri ve Java programlarını etkinleştirin

Komut dizileri, ActiveX denetimleri, tanımlama bilgileri ve Java programlarını etkinleştirerek, bilgisayarınızın Web sayfalarını tasarlandıkları şekilde çalıştıracak şekilde ayarlanmış olduğundan emin olun.

Bunu yapmak için aşağıdaki adımları izleyin:
  1. Araçlar menüsünden Internet Seçenekleri'ni tıklatın.
  2. Güvenlik sekmesini tıklatın ve sonra da Web sayfasını içeren bölge (örneğin, Internet bölgesi) için varsa Varsayılan Düzey'i tıklatın.
  3. Internet Explorer 6 kullanıyorsanız, Gizlilik sekmesini ve sonra da (varsa) Varsayılan'ı tıklatın.
Resimleri artık görüntüleyip görüntüleyemediğinizi denetleyin. Resimleri yine de görüntüleyemiyorsanız, bazı gelişmiş sorun giderme adımlarını uygulamanız gerekir. Gelişmiş sorun giderme adımları konusunda deneyimli değilseniz, yardım için kullanabileceğiniz diğer kaynakları öğrenmek üzere "Sonraki Adımları" bölümüne bakabilirsiniz.

Gelişmiş sorun giderme

Yöntem 1: Resim türünün Internet Explorer tarafından desteklendiğini doğrulayın

Internet Explorer .art, .wmf, .emf, .png, .mov, .xbm, .avi, .mpg, .gif, .jpg, .mpeg ve .bmp uzantılı resimleri görüntüler.

Kırmızı X'i veya resmin yer tutucusunu sağ tıklatın ve sonra da Özellikler'i tıklatın. Özellikler iletişim kutusundaki Tür veya Adres (URL) değerlerini inceleyerek, resim türünün Internet Explorer tarafından desteklendiğini doğrulayın. Örneğin, Graphics Interchange Format (GIF) dosyası için Tür değeri olarak GIF Resmi görüntülenir. Adres (URL) değeri .gif ile biter.

Resim türü Internet Explorer tarafından desteklenmiyorsa, işiniz tamamlanmış demektir. Resim türü destekleniyorsa, yöntem 2'ye geçin.

Yöntem 2: Toggle Images.exe Web donatısının bulunmadığından ve resimleri devre dışı bırakmadığından emin olun

Toggle Images.exe programı resimleri devre dışı bırakacak şekilde ayarlanmış olabilir. Resimleri gösterecek şekilde ayarlanmış olduğundan emin olun.

Toggle Images.exe Web donatısı yüklüyse, resimleri açmak için Internet Explorer'daki Bağlantılar Çubuğu'nda Toggle Images.exe bağlantısını tıklatın.

Not Bağlantılar çubuğu görünür değilse, araç çubuğunda boş bir alanı sağ tıklatın ve Bağlantılar'ın yanında bir onay işareti olduğunu doğrulayın. Bağlantılar çubuğunda Toggle Images.exe bağlantısı görünür değilse, Bağlantılar çubuğunun en sağındaki iki köşeli parantez içeren oku tıklatın.

Bu yöntem sorunu giderdiyse, işiniz tamamlanmış demektir. Resimleri yine de görüntüleyemiyorsanız yöntem 3'e geçin.

Yöntem 3: Sorunun üçüncü taraflara ait Internet güvenliği, güvenlik duvarı veya tanımlama bilgisi engelleme programı nedeniyle oluşmadığından emin olun

Üçüncü taraf Internet güvenliği, güvenlik duvarı veya tanımlama bilgisi engelleme programı kullanıyorsanız, programın üreticisine başvurarak komut dizileri, ActiveX denetimleri, tanımlama bilgileri, Java programları, reklamlar ve HTTP başvuru bilgilerinin nasıl etkinleştirileceği konusunda bilgi edinin. Örneğin, Norton Internet Security (NIS) veya Norton Personal Firewall (NPF) yüklüyse, bu ürünlerde bu makalede açıklanan davranışa neden olabilecek çeşitli ayarlar hakkında ek bilgi için aşağıdaki Symantec Corporation Web sitelerini ziyaret edin:
http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam)
http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam)
Internet'e bir yerel alan ağı (LAN) üzerinden erişiyorsanız, LAN yöneticinize başvurarak komut dizileri, ActiveX denetimleri, tanımlama bilgileri, Java programları, reklamlar ve HTTP başvuru bilgilerinin ağdaki bir güvenlik duvarı veya diğer güvenlik özellikleri tarafından engellenmediğini doğrulayın.

Bu yöntem sorunu giderdiyse, işiniz tamamlanmış demektir. Resimleri yine de görüntüleyemiyorsanız yöntem 4'e geçin.

Yöntem 4: Otomatik Seç kodlama seçeneğini etkinleştirin

Internet Explorer 7 veya Internet Explorer 8'de, Sayfa menüsünde Kodlama'nın üzerine gelin. Otomatik Seç'in yanında bir onay işareti görünmüyorsa, Otomatik Seç'i tıklatın.

Internet Explorer 6'da, Görünüm menüsünde Kodlama'nın üzerine gelin. Otomatik Seç'in yanında bir onay işareti görünmüyorsa, Otomatik Seç'i tıklatın.

Bu yöntem sorunu giderdiyse, işiniz tamamlanmış demektir. Resimleri yine de görüntüleyemiyorsanız yöntem 5'e geçin.

Yöntem 5: Kodlama seçeneğinin doğru dil olarak ayarlandığından emin olun

Internet Explorer 7 veya Internet Explorer 8'de, Sayfa menüsünde Kodlama'nın üzerine gelin ve görüntülemeye çalıştığınız Web sayfası için uygun dili tıklatın. Örneğin, Web sayfası İngilizce (ABD) dilindeyse, Batı Avrupa (ISO) veya Batı Avrupa (Windows) seçeneğini tıklatın.

Internet Explorer 6'da, Görünüm menüsünde Kodlama'nın üzerine gelin ve görüntülemeye çalıştığınız Web sayfası için uygun dili tıklatın. Örneğin, Web sayfası İngilizce (ABD) dilindeyse, Batı Avrupa (ISO) veya Batı Avrupa (Windows) seçeneğini tıklatın.

Gerekli dil Internet Explorer 6'daki Görünüm menüsünde veya Internet Explorer 7 ya da Internet Explorer 8'deki Sayfa menüsünde yoksa, aşağıdaki adımları izleyerek dili ekleyin:
  1. Araçlar menüsünden Internet Seçenekleri'ni tıklatın.
  2. Genel sekmesinde, Diller'i ve sonra Ekle'yi tıklatın.
  3. Uygun dili tıklatın ve sonra da Tamam'ı tıklatın.
Microsoft, teknik destek bulmanıza yardımcı olmak üzere üçüncü taraf iletişim bilgilerini sağlamaktadır. Bu iletişim bilgileri önceden haber verilmeksizin değiştirilebilir. Microsoft bu üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez.

Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft bu ürünlerin performansı veya güvenilirliği ile ilgili örtük veya başka türlü hiçbir garanti vermez.

Bu yöntem sorunu giderdiyse, işiniz tamamlanmış demektir. Resimleri yine de görüntüleyemiyorsanız, "Sonraki Adımlar" bölümüne geçin.

SONRAKİ ADIMLAR

Bu yöntemler işe yaramadıysa, Microsoft Müşteri Destek Hizmetleri Web sitesini kullanarak sorununuza yönelik başka çözümler bulabilirsiniz. Microsoft Müşteri Destek Hizmetleri Web sitesinin sağladığı bazı hizmetler şunlardır:
  • Aranabilir Bilgi Bankası (http://support.microsoft.com/search/?adv=1) : Microsoft ürünleri hakkında teknik destek bilgileri ve kendi kendinize yardım araçlarını arayın.
  • Çözüm Merkezleri (http://support.microsoft.com/select/?target=hub) : Ürüne özgü sık sorulan soruları ve önemli destek konularını görüntüleyin.
  • Microsoft Müşteri Destek Haber Grupları (http://www.microsoft.com/communities/newsgroups/default.mspx) : Ortaklarınıza, meslektaşlarınıza ve Microsoft'un En Değerli Uzmanları'na (MVP) danışın.
  • Diğer Destek Seçenekleri (http://support.microsoft.com/default.aspx?pr=csshome) : Web'i kullanarak bir soru sorun, Microsoft Müşteri Destek Hizmetleri'ne başvurun veya görüş bildirin.
Bu Microsoft Web sitelerini kullandıktan sonra sorunları yaşamaya devam ederseniz veya Microsoft Destek Hizmetleri Web sitesinde sorununuza yönelik bir çözüm bulamazsanız, Destek Hizmetleri'ne başvurmak üzere aşağıdaki bağlantıyı tıklatın.
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

Bu makaledeki bilginin uygulandığı durum:
  • Windows Internet Explorer 8
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Microsoft Internet Explorer 6.0, Ne zaman ne ile kullanilir:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional Edition
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
Anahtar Kelimeler: 
kbtshoot kbresolve kbdisplay kbenv kbprb KB283807