Applies ToDynamics GP 2013

Symptoms

When you navigate the home page or area pages in Microsoft Dynamics GP 2013, you may receive the following error:

Value cannot be null.

Parameter name: titleValue

Cause

Microsoft has identified this as an outstanding issue with Microsoft Dynamics GP 2013. This issue is fixed with Service Pack 1.

Resolution

Download and install Service Pack 1 for Microsoft Dynamics GP 2013.Customershttps://mbs.microsoft.com/customersource/downloads/servicepacks/MDGP2013_PatchReleasesPartnershttps://mbs.microsoft.com/partnersource/downloads/servicepack/MDGP2013_PatchReleasesIf you are currently only Microsoft Dynamics GP 2013 and cannot install ServiceĀ  Pack 1 immediately, refer to the steps below for a workaround.1. Have all users exit Microsoft Dynamics GP 2013.2. Make a SQL backup of the system database. If you have upgraded from a previous release, the system database is DYNAMICS.3. If you have already experienced the error above, run the following script in the SQL Server Management Studio to remove the invalid records from the SY07140 table in the system database. Run the script below against the system database.

Delete SY07140 where CMDDICTID = 1

4. Run the script below to create a trigger on the SY07140 table to remove the invalid records automatically moving forward.

/*Microsoft Dynamics GP 2013 Trigger - CR10167*/if exists (select * from sysobjects where id = object_id('dbo.SY07140InsertTrigger') and sysstat & 0xf = 8)drop trigger dbo.SY07140InsertTriggerGOcreate trigger dbo.SY07140InsertTriggeron SY07140for insertasbeginDelete SY07140 where CMDDICTID = 1end

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.