WD2002: Jak utworzyć spis treści przez zaznaczenie tekstu

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 285059 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL285059
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

Jedną z najbardziej typowych cech dokumentów profesjonalnych jest spis treści. Program Microsoft Word 2002 sprawia, że tworzenie spisu treści jest prostsze, umożliwiając jego tworzenie bez użycia stylów przez zaznaczenie pojedynczego słowa lub grupy słów w obrębie tekstu i dodanie informacji do spisu treści.

Spis treści może być generowany z użyciem funkcji początkowego uwypuklenia, pozwalającej na zastosowanie stylów nagłówka do dowolnego tekstu wiodącego (pierwsze słowo lub słowa w akapicie lub zdaniu). Używając funkcji początkowego uwypuklenia, można tworzyć akapity, w których pierwsza część akapitu jest formatowana z użyciem stylu nagłówka i jest wyświetlana w spisie treści, natomiast reszta akapitu jest normalnym tekstem i nie jest wyświetlana w spisie treści.

W tym artykule jest objaśnione, jak używać tej nowej funkcji do tworzenia spisu treści.

Więcej informacji

Program Word 2002 pozwala tworzyć spis treści w oparciu o część tekstu w akapicie, bez dołączania całego akapitu. Aby dołączyć tekst do spisu treści, można go zaznaczyć, używając funkcji początkowego uwypuklenia wraz ze stylami nagłówka.

Krok 1: Wstawianie spisu treści

  1. Uruchom program Word, a następnie otwórz dokument.
  2. Kliknij pusty akapit w miejscu, w którym chcesz wstawić spis treści.
  3. W menu Wstaw wskaż polecenie Odwołanie, a następnie kliknij polecenie Indeks i spisy.
  4. Kliknij kartę Spis treści, a następnie kliknij opcję Pokaż pasek narzędzi Konspekt.
  5. W oknie dialogowym Indeks i spisy zaznacz opcje, które chcesz zastosować do spisu treści, a następnie kliknij przycisk OK.
  6. Kliknij przycisk OK po pojawieniu się następującego komunikatu:
    Aby dodać lub usunąć elementy spisu treści:

    1. Zaznacz tekst w dokumencie.
    2. Na pasku narzędzi kliknij poziom konspektu w celu wyświetlenia tekstu w spisie treści.
    UWAGA: Jeśli tekst zawarty w dokumencie nie zostanie zaznaczony do dołączenia do spisu treści, w dokumencie zamiast spisu treści pojawi się następujący komunikat:
    Błąd! Nie znaleziono żadnych pozycji spisu treści.

Krok 2: Zaznaczanie tekstu w celu jego dołączenia do spisu treści

Kolejnym krokiem jest użycie funkcji początkowego uwypuklenia ze stylami nagłówka do zaznaczenia tekstu, który ma być dołączony do spisu treści. Aby zaznaczyć tekst, który ma być dołączony do spisu treści, należy wykorzystać co najmniej jedną z następujących metod:

Metoda 1: Użycie funkcji początkowego uwypuklenia ze stylami nagłówka

  1. Zaznacz w dokumencie dowolny tekst wiodący, który chcesz dołączyć do spisu treści. Na przykład, w akapicie może być tekst wiodący wprowadzający do pozostałego tekstu tego akapit. W następującym akapicie chcąc dołączyć słowa wiodące „Wdowa i sierota” do spisu treści, wystarczy zaznaczyć te słowa, a następnie kontynuować wykonywanie kolejnych kroków.
    Wdowa i sierota: Wdowa to ostatni wiersz akapitu drukowany jako jedyny u góry strony. Sierota to pierwszy wiersz akapitu drukowany jako jedyny u dołu strony.
  2. Na przykład, w akapicie może być tekst wiodący wprowadzający do pozostałego tekstu tego akapit. W następującym akapicie chcąc dołączyć słowa wiodące „Wdowa i sierota” do spisu treści, wystarczy zaznaczyć te słowa, a następnie kontynuować wykonywanie kolejnych kroków. Kliknij strzałkę listy rozwijanej w polu Styl na pasku narzędzi Formatowanie, a następnie zaznacz żądany nagłówek.
  3. Na przykład, w akapicie może być tekst wiodący wprowadzający do pozostałego tekstu tego akapit. W następującym akapicie chcąc dołączyć słowa wiodące „Wdowa i sierota” do spisu treści, wystarczy zaznaczyć te słowa, a następnie kontynuować wykonywanie kolejnych kroków. Aby uaktualnić spis treści, kliknij przycisk Aktualizuj spis treści na pasku narzędzi Konspekt.
  4. Na przykład, w akapicie może być tekst wiodący wprowadzający do pozostałego tekstu tego akapit. W następującym akapicie chcąc dołączyć słowa wiodące „Wdowa i sierota” do spisu treści, wystarczy zaznaczyć te słowa, a następnie kontynuować wykonywanie kolejnych kroków. W oknie dialogowym Aktualizacja spisu treści kliknij opcję Aktualizuj cały spis, a następnie kliknij przycisk OK.
Należy zauważyć, że po kliknięciu przycisku Pokaż/Ukryj na standardowym pasku narzędzi w akapicie brakuje znaków specjalnych do oznaczenia zastosowanego początkowego uwypuklenia. Jednak tekst formatowany jako poziom nagłówka pojawi się w spisie treści dokumentu. Ponieważ nie występują ukryte znaczniki akapitu lub inne elementy, cały proces nie wymaga specjalnego przygotowania. Program Word do wykonania tej operacji używa nowej funkcji podstawowej — połączonych stylów znaków.

Styl nagłówka stosowany do wiodącej części dokumentu jest wyświetlany jako styl nagłówka, ale właściwie jest to połączony styl znaków. W programie Word 2002 po zastosowaniu stylu akapitu do podzbioru akapitów można zaobserwować następujące zachowanie:
  • Ukryty styl znaków jest tworzony w oparciu o te same właściwości znaków, co stosowany styl akapitu.

    i
  • Styl znaków jest stosowany dla zaznaczenia.
UWAGA: Ukryty styl znaków utworzony za pomocą połączonych stylów znaków jest wyświetlany na liście rozwijanej Styl, jeśli dokument jest otwarty i przeglądany we wcześniejszych wersjach programu Word. Jeśli dokument jest zapisywany we wcześniejszej wersji programu Word, tracona jest funkcja separatora stylu.

Aby obejrzeć ukryty styl znaków, wykonaj następujące kroki:
  1. W menu Format kliknij polecenie Wyświetl formatowanie.

    Pojawi się okienko zadań Wyświetlanie formatowania.
  2. Zaznacz tekst w dokumencie i zwróć uwagę, że w okienku zadań Wyświetlanie formatowania wyświetlane są szczegóły dotyczące formatowania.
  3. Zaznacz tekst, do którego zastosowano styl znaków i zauważ, że tekst pojawi się w okienku zadań Wyświetlanie formatowania jako styl znaków. Styl połączony wyświetlany będzie w okienku zadań Wyświetlanie formatowania jako Znak nagłówka. Aktualny styl znaków pozostanie ukryty w okienku zadań Style i formatowanie lub na liście rozwijanej Styl paska narzędzi Formatowanie.
W połączonym stylu znaków może być używany dowolny styl akapitu. Tworzony styl akapitu może wyglądać dokładnie tak jak styl akapitu tekstu, a następnie może być stosowany do części akapitu. W ten sposób tekst użyty do budowy spisu treści może być zgodny z tekstem akapitu, przy założeniu, że opcje spisu treści są modyfikowane w celu uwzględnienia stylu dla tekstu wiodącego.

Metoda 2: Używanie separatorów stylu wraz ze stylami nagłówka

Separator stylu jest nową funkcją programu Word 2002. Znaczniki separatorów stylu umożliwiają:
  • Zastosowanie stylów nagłówka do pojedynczego słowa lub frazy w obrębie akapitu i wyświetlenie tylko tego słowa lub frazy w spisie treści.
  • Zastosowanie dwóch stylów w jednym akapicie i wyświetlenie tego akapitu wiodącego w spisie treści.
  • Zastosowanie poziomów konspektu do tekstu wiodącego i wyświetlenie tylko tego tekstu w spisie treści.
  • Zastosowanie poziomów konspektu do pojedynczego słowa lub frazy w obrębie akapitu i wyświetlenie tylko tego słowa lub frazy w spisie treści.
Separator stylu to ukryty znacznik akapitu, który oddziela style zastosowane w dokumencie. Aby znacznik separatora stylu był widoczny, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenie Opcje.
  2. Na karcie Widok w obszarze Znaczniki formatowania kliknij opcję Wszystkie.
Aby można było skorzystać z funkcji separatora stylu, do używanego paska narzędzi należy dodać przycisk Separator stylu:
  1. W menu Narzędzia kliknij polecenie Dostosuj.
  2. Kliknij kartę Polecenia, a następnie na liście Kategorie kliknij pozycję Wszystkie polecenia.
  3. Na liście Polecenia zlokalizuj pozycję InsertStyleSeparator, a następnie przeciągnij ją na pasek narzędzi Formatowanie. Kliknij przycisk Zamknij.
Wstaw separator stylu przed zastosowaniem do tekstu stylu nagłówka. Aby to zrobić, użyj jednej z następujących metod.

Korzystanie z separatorów stylu, aby dodać do spisu treści pojedyncze słowo lub frazę w obrębie akapitu.

  1. Podczas wpisywania po dotarciu do słowa lub frazy akapitu, które chcesz dołączyć do spisu treści, kliknij przycisk Separator stylu. Po kliknięciu przycisku Separator stylu punkt wstawiania zostanie przeniesiony na prawo od separatora, umożliwiając kontynuowanie wpisywania.
  2. Wpisz słowo lub frazę, które chcesz dołączyć do spisu treści, a następnie ponownie kliknij przycisk Separator stylu.
  3. Zaznacz słowo lub frazę, które chcesz dołączyć do spisu treści, na pasku narzędzi Formatowanie kliknij strzałkę listy rozwijanej w polu Styl, a następnie zaznacz żądany nagłówek.
Słowo lub fraza pomiędzy dwoma separatorami stylu pojawi się w spisie treści.

Wstawianie separatora stylu pomiędzy dwa istniejące akapity

Separatora stylu można użyć pomiędzy dwoma istniejącymi akapitami, powodując, że pierwszy akapit stanie się tekstem wiodącym i będzie wyświetlany w spisie treści, natomiast drugi akapit stanie się pozostałą częścią tekstu i nie będzie wyświetlany w spisie treści. Aby to zrobić, wykonaj następujące kroki:
  1. Utwórz dwa akapity tekstu, umieszczając w pierwszym akapicie tekst, który ma być wyświetlany w spisie treści, a w drugim akapicie pozostałą część tekstu.
  2. Umieść punkt wstawiania w pierwszym akapicie, a następnie kliknij przycisk Separator stylu.

    Konwersja znacznika akapitu na końcu pierwszego akapitu na separator stylu spowoduje, że dwa akapity będą wyświetlane jako pojedynczy akapit. Istnieje teraz jeden złożony akapit, który, pomimo tego że pokazywany jest w widoku Konspekt jako dwa oddzielne akapity, drukowany jest jako pojedynczy akapit.
  3. Zaznacz tekst na lewo od separatora, na pasku narzędzi Formatowanie kliknij strzałkę listy rozwijanej w polu Styl, a następnie zaznacz żądany nagłówek.
W spisie treści wyświetlana jest tylko część wiodąca (pierwszy akapit) sformatowana za pomocą stylu nagłówka.

UWAGA: Separator stylu to specjalna postać ukrytego znacznika akapitu, dlatego dokumenty utworzone w programie Word 2002 i zawierające separatory stylu wyglądają tak samo w programach Word 2000 i Microsoft Word 97, chyba że w obszarze Znaczniki formatowania zostanie kliknięta opcja Wszystkie. Jeśli opcja Wszystkie w obszarze Znaczniki formatowania zostanie kliknięta we wcześniejszych wersjach programu Word, ukryty znacznik akapitu separatora stylu będzie wyświetlany jako zwykły znacznik akapitu, a dokument zostanie ponownie podzielony na strony.

We wcześniejszych wersjach programu Word, podczas przeglądania dokumentów zawierających separatory stylu i utworzonych w programie Word 2002, nie należy klikać opcji Wszystkie w obszarze Znaczniki formatowania.

Metoda 3: Usuwanie nagłówka ze spisu treści

Chcąc usunąć nagłówek ze spisu treści, do zaznaczonego tekstu należy zastosować nowy styl akapitu:
  1. Zaznacz tekst, na pasku narzędzi Formatowanie kliknij strzałkę listy rozwijanej w polu Styl, a następnie zaznacz żądany nagłówek. (Aby usunąć styl nagłówka, kliknij przycisk Normalny.)
  2. Aby dokonać aktualizacji spisu treści, na pasku narzędzi Tworzenie konspektu kliknij przycisk Aktualizuj spis treści.
  3. W oknie dialogowym Aktualizacja spisu treści kliknij przycisk Aktualizuj cały spis, a następnie kliknij przycisk OK.
UWAGA: Stosując żądany styl akapitu do całego akapitu, nie należy usuwać stylu. Należy zaznaczyć dokładnie tekst, który wyświetlany jest w spisie treści, a następnie zastosować nowy styl.

Materiały referencyjne

Aby uzyskać więcej informacji dotyczących tworzenia spisu treści, kliknij polecenie Microsoft Word 2002 — Pomoc w menu Pomoc, w Asystencie pakietu Office lub Kreatorze odpowiedzi wpisz tekst tworzenie spisu treści, a następnie kliknij przycisk Wyszukaj, aby wyświetlić temat.
Aby uzyskać dodatkowe informacje o tworzeniu spisu treści bez dokonywania zmian w formatowaniu tekstu, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
285050 WD2002: How to Use Outline Levels to Create a Table of Contents

Właściwości

Numer ID artykułu: 285059 - Ostatnia weryfikacja: 8 kwietnia 2003 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kberrmsg kbhowto kbinfo kbdta KB285059

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com