Printing fails when you use a shared printer in Windows 7

Article ID: 2864755 - View products that this article applies to.
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Symptoms

Assume that you have a printer being shared on a printer server that is running Windows Server 2008 R2. When you try to print a file from a Windows 7 client to the shared printer, printing fails.

Cause

This issue occurs because the DependentFiles registry key for the driver that is used by the printer is blank in the registry. The DependentFiles registry key is under the following registry sub-key: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\<architecture>\Drivers\Version-3\<drivername>

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 SP1 or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

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The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
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    VersionProductMilestoneService branch
    6.1.760 1.17xxxWindows 7 and Windows Server 2008 R2SP1GDR
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
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File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.22560776,70407-Jan-201408:37x86
Winprint.dll6.1.7601.1751430,20820-Nov-201012:21x86
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For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
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File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.22560965,63207-Jan-201409:03x64
Winprint.dll6.1.7601.1751439,42420-Nov-201013:27x64
Localspl.dll6.1.7601.22560776,70407-Jan-201408:37x86
Winprint.dll6.1.7601.1751430,20820-Nov-201012:21x86
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For all supported IA64-based versions of Windows Server 2008 R2
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File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.225602,079,74407-Jan-201408:18IA-64
Winprint.dll6.1.7601.1751490,62420-Nov-201010:28IA-64
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Workaround

To work around this issue, use one of the following workarounds:
  • You can repair, remove and then reconnect the network printer.
  • You can apply the hotfix 2896881. For more information about the hotfix 2896881, click the following article number to view the article in the Microsoft Knowledge Base:
    2896881 Long logon time when you use the AddPrinterConnection VBScript command to map printers for users during logon process in Windows Server 2008 R2 SP1
    Note If you are still seeing the issue after applying hotfix 2896881, add the following values to the following registry subkey on the clients that exhibit the behavior:
    Registry subkey: 
    HKLM\System\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers

    Registry values: 
    LoadTrustedDrivers (REG_DWORD) - This should be set to 1.
    TrustedDriverPath (REG_SZ) - This is the file path that will be searched for the driver. Set this value to a NULL string ("").

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
When the issue occurs, you can see event 372 is logged in the PrintService Admin log. To do this, follow these steps:
  1. Open Event Viewer and then expand Applications and Services Logs.
  2. Expand the Microsoft folder.
  3. Expand the Windows folder.
  4. Expand the PrintService folder and then click Admin.

Additional file information

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Additional file information for Windows 7 and Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
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File propertyValue
File nameX86_97fc27c4e86bbb0a3c6cb761d91b1a2d_31bf3856ad364e35_6.1.7601.22560_none_360d1493fe43246f.manifest
File versionNot applicable
File size718
Date (UTC)07-Jan-2014
Time (UTC)13:50
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22560_none_32723b400a3a1483.manifest
File versionNot applicable
File size4,844
Date (UTC)07-Jan-2014
Time (UTC)13:54
SHA-1 hashNot applicable
MD5 hashNot applicable
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Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
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File propertyValue
File nameAmd64_97fc27c4e86bbb0a3c6cb761d91b1a2d_31bf3856ad364e35_6.1.7601.22560_none_922bb017b6a095a5.manifest
File versionNot applicable
File size720
Date (UTC)07-Jan-2014
Time (UTC)13:50
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameAmd64_f59b59f215bbb43b11c6a4fe7e499a62_31bf3856ad364e35_6.1.7601.22560_none_f4decd322b093e56.manifest
File versionNot applicable
File size722
Date (UTC)07-Jan-2014
Time (UTC)13:50
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22560_none_8e90d6c3c29785b9.manifest
File versionNot applicable
File size4,845
Date (UTC)07-Jan-2014
Time (UTC)13:57
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22560_none_32723b400a3a1483.manifest
File versionNot applicable
File size4,844
Date (UTC)07-Jan-2014
Time (UTC)13:57
SHA-1 hashNot applicable
MD5 hashNot applicable
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Additional files for all supported IA64-based versions of Windows Server 2008 R2
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File propertyValue
File nameIa64_7864614eb7c6456684986c9c3332c9fe_31bf3856ad364e35_6.1.7601.22560_none_4d6afba9e8a13dcf.manifest
File versionNot applicable
File size720
Date (UTC)07-Jan-2014
Time (UTC)13:50
SHA-1 hashNot applicable
MD5 hashNot applicable
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22560_none_3273df360a381d7f.manifest
File versionNot applicable
File size4,844
Date (UTC)07-Jan-2014
Time (UTC)13:51
SHA-1 hashNot applicable
MD5 hashNot applicable
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Properties

Article ID: 2864755 - Last Review: July 4, 2014 - Revision: 7.0
Applies to
  • Windows 7 Service Pack 1, when used with:
    • Windows 7 Enterprise
    • Windows 7 Professional
    • Windows 7 Ultimate
    • Windows 7 Home Premium
    • Windows 7 Starter
  • Windows Server 2008 R2 Service Pack 1, when used with:
    • Windows Server 2008 R2 Datacenter
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 for Itanium-Based Systems
    • Windows Server 2008 R2 Foundation
    • Windows Server 2008 R2 Standard
    • Windows Web Server 2008 R2
Keywords: 
kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2864755

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