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Symptoms

Consider the following scenario:

  • You have a domain controller that runs Windows Server 2008 R2.

  • You perform an authoritative restore action on the KRBTGT account.

  • You log on to a Windows 8.1 client, a Windows 8 client with the Kerberos.dll file from update 2883201 or a later update, or a Windows 7 client with update 2845626 or a later update.

  • You try to reset or change the domain password.

In this scenario, the password cannot be reset or changed. Additionally, you receive the following error message:

The security Database on the server does not have a computer account for this workstation trust relationship

Cause

This issue occurs because the Windows Server 2008 R2 domain controller handles a specific flag incorrectly. The flag is introduced on the client-side to resolve an issue in which the kerberos.dll file is not updating a user's credential cache if the user logs in by using their user principal name (UPN).

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this update, you must be running Windows Server 2008 R2.

Registry information

To apply this update, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this update.

Update replacement information

This update does not replace a previously released update.

The global version of this update installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760
    1.18xxx

    Windows Server 2008 R2

    SP1

    GDR

    6.1.760
    1.22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, very important issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Kdcsvc.dll

6.1.7601.18321

430,080

15-Nov-2013

08:40

x64

Kdcsvc.mof

Not applicable

5,300

05-Nov-2010

02:14

Not applicable

Kdcsvc.dll

6.1.7601.22515

434,688

14-Nov-2013

09:06

x64

Kdcsvc.mof

Not applicable

5,300

05-Nov-2010

02:14

Not applicable


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

To determine whether you have a restored KRBTGT account in your domain, you can run the following command from a domain administrator-elevated command prompt:

repadmin /showobjmeta  <My_DC> "CN=krbtgt,CN=Users,DC=contoso,DC=com" >krbtgt.txt

Because the default restore increments all attributes by 100000 in the output krbtgt.txt file, you may notice the Ver (version) value of the pwdLastSet attribute is 100002 or larger. For example, the output is as follows:Loc.USN Originating DSA Org.USN Org.Time/Date Ver Attribute
======= =============== ========= ============= === =========

8064 Default-First-Site-Name\CONTOSO-DC1 12327 2014-06-23 18:27:03 100002 pwdLastSet

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

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