As barras de ferramentas e a barra de menus estão em falta ou as definições personalizadas não são mantidas quando o Word é iniciado

Traduções de Artigos Traduções de Artigos
Artigo: 291484 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT291484
Este artigo consolida os seguintes artigos previamente disponíveis: 242368

Importante: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986 Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando o Microsoft Word é iniciado, poderá encontrar um dos seguintes sintomas:
  • As barras de ferramentas estão em falta.
  • A barra de menus está em falta.
  • As definições personalizadas não são mantidas.

Como contornar

Para restaurar as barras de ferramentas, menus ou definições personalizadas utilize um dos métodos que se seguem, conforme apropriado.

Desactivar o modo de ecrã inteiro

O modo de ecrã inteiro apresenta a maior parte possível do documento no ecrã. Neste modo, o Word remove elementos do ecrã, tais como a barra de menus, as barras de ferramentas e as barras de deslocamento. Para restaurar as barras de ferramentas e os menus, desactive o modo de ecrã inteiro.
  • Se existir um documento aberto, efectue um dos seguintes procedimentos:
    • Prima ALT+V para apresentar o menu Ver e, em seguida, prima I para desactivar o modo de ecrã inteiro.
    • Se a barra de ferramentas Ecrã inteiro estiver visível, clique em Fechar o modo de ecrã inteiro.
  • Se não existir um documento aberto, siga estes passos:
    1. Prima CTRL+O para iniciar um documento novo.
    2. Prima ALT+V para apresentar o menu Ver e, em seguida, prima I para desactivar o modo de ecrã inteiro.
Termine e reinicie o Word. Se o Word for iniciado correctamente, significa que o problema foi resolvido. O problema era causado pelo facto de o Word ter sido fechado com o modo de ecrã inteiro activo e de ter retido essa definição.

Para obter mais informações sobre o modo de ecrã inteiro, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
290947 Menus and toolbars disappear and "Repeat Value:8" is displayed on Status bar

Activar as barras de ferramentas predefinidas

No menu Ver, aponte para Barras de ferramentas. Verifique se existe alguma barra de ferramentas seleccionada. Se nenhuma das barras de ferramentas estiver seleccionada, seleccione as pretendidas. Para o fazer, clique no nome da barra de ferramentas. Repita este procedimento para cada barra de ferramentas que pretende que seja apresentada. As barras de ferramentas seleccionadas por predefinição são as barras de ferramentas Padrão e Formatação, bem como o Painel de tarefas.

Nota: se não conseguir ver a barra de menus, prima ALT+V para visualizar o menu Ver e prima B para visualizar o menu Barra de ferramentas.

Termine e reinicie o Word. Se o Word for iniciado correctamente, significa que o problema foi resolvido. O problema era causado pelo facto de as barras de ferramentas predefinidas e de a barra de menus terem sido desactivadas quando o Word foi fechado e de o Word ter retido essas definições.


Iniciar o Word sem executar macros

Verifique se está a iniciar o Word utilizando uma macro do Microsoft Visual Basic for Applications (VBA). Poderá estar a executar uma macro do VBA que inicia o Word sem apresentar qualquer menu ou barra de ferramentas.

Se estiver a iniciar o Word através de um atalho, verifique se a linha de comandos utilizada pelo atalho contém o nome de uma macro. Para tal, siga estes passos:
  1. Localize o atalho que está a utilizar para executar o Word.
  2. Clique com o botão direito do rato no atalho e, em seguida, clique em Propriedades no menu de atalho.
  3. Clique no separador Atalho.
  4. Procure na caixa Destino uma linha de comandos semelhante à seguinte
    "C:\Programas\Microsoft Office\Office10\WINWORD.EXE" /mnome da macro
    , em que /mnome da macro é o nome de uma macro.

  5. Se vir /mnome da macro na linha de comandos, remova-o e, em seguida, inicie o Word normalmente.

    Nota: o parâmetro /m, seguido pelo nome de uma macro, inicia o Word e executa uma macro específica. O parâmetro /m também impede que o Word execute quaisquer macros de execução automática.
Se o Word for iniciado correctamente, significa que o problema foi resolvido. O problema era causado pelo facto de ser executada uma macro quando o Word era iniciado e de essa macro alterar o aspecto da janela do Word.

Para obter informações adicionais sobre os parâmetros da linha de comandos que podem ser utilizados para iniciar o Word, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
210565 WD: Parâmetros de arranque do Word (linha de comandos) e respectiva finalidade

Um programa (como, por exemplo, um suplemento do Word) modificou a interface do utilizador, ocultando as barras de ferramentas ou alterando as definições

Passo 1: Iniciar o Word utilizando predefinições

Iniciar o Word utilizando o parâmetro /a numa linha de comandos faz com que o Word utilize as predefinições para todas as opções e impede que os suplementos e os modelos globais sejam carregados.

O parâmetro /a permite iniciar o Word sem carregar os seguintes componentes:
  • O modelo global (Normal.dot)
  • Todos os modelos suplementares existentes na pasta Arranque
  • Todas as bibliotecas de suplementos (ficheiros .wll)
  • Definições do utilizador armazenadas na chave Data do registo do Windows
Nota: quando o Word é iniciado com o parâmetro /a, as alterações efectuadas no Word que afectem qualquer um destes componentes não serão escritas no disco rígido quando sair do Word, e serão perdidas.

No exemplo que se segue, parte-se do princípio que o Word está localizado na seguinte pasta:
C:\Programas\Microsoft Office\Office10
Nota: poderá ter o Word instalado noutra pasta.

Para iniciar o Word utilizando o parâmetro /a, siga estes passos:
  1. Clique em Iniciar, clique em Executar e clique em Procurar.
  2. Utilize a caixa Procurar em para localizar o ficheiro Winword.exe e, em seguida, clique para seleccioná-lo.
  3. Clique em Abrir.

    Nota: este passo preenche a caixa Abrir na caixa de diálogo Executar.
  4. Clique a seguir a Winword.exe na caixa Abrir.

    Nota: o caminho para o ficheiro Winword.exe na caixa de diálogo Executar está escrito entre aspas. Certifique-se de que clica à direita das aspas de fecho.
  5. Introduza um espaço e, em seguida, escreva /a.

    A instrução existente na caixa Abrir deve ser semelhante ao exemplo seguinte:
    "C:\Programas\Microsoft Office\Office10\Winword.exe" /a
Se o Word for iniciado correctamente, significa que o problema foi resolvido. O problema era causado pelo facto de um programa ou modelo suplementar, de o modelo predefinido normal ou de a chave Data do registo estar a afectar o modo como a janela do Word era apresentada quando o programa era iniciado.

Passo 2: Mudar o nome do modelo global

Nota: Para obter um método automatizado de efectuar este passo, consulte o artigo listado na secção "Referências" deste artigo.

Para impedir que a formatação, as entradas de texto automático e as macros guardadas no modelo global (Normal.dot) afectem o comportamento do Word ou dos documentos abertos, mude o nome do ficheiro Normal.dot.

Nota: mudar o nome do modelo Normal.dot permite determinar rapidamente se este modelo está na origem do problema em questão. Ao mudar o nome ao modelo Normal.dot repõe as predefinições de várias opções, incluindo os estilos personalizados, as barras de ferramentas personalizadas, as macros e as entradas de texto automático. Por este motivo, a Microsoft recomenda vivamente que mude o nome do ficheiro Normal.dot.

Alguns tipos de configuração podem criar mais do que um ficheiro Normal.dot. Estas situações incluem casos em que existem múltiplas versões do Word em execução no mesmo computador ou casos em que existem várias instalações de estação de trabalho no mesmo computador. Nestas situações, certifique-se de que muda o nome de todas as cópias do ficheiro Normal.dot. Para mudar o nome do modelo global (Normal.dot), siga estes passos:
  • Microsoft Windows 98 e Microsoft Windows NT 4.0
    1. Saia de todas as instâncias do Word. Se utilizar o Word como editor de correio electrónico, certifique-se de que termina também o Microsoft Outlook.
    2. Clique em Iniciar (Iniciar), aponte para Localizar (Find) e, em seguida, clique em Ficheiros ou pastas (Files or Folders).
    3. Na caixa Com o nome (Named), escreva Normal.dot.
    4. Na caixa Procurar em (Look in), seleccione o disco rígido local (ou uma localização alternativa de modelos do utilizador, caso esteja a executar o Word a partir de um servidor de rede).
    5. Clique em Localizar agora (Find Now) para procurar o ficheiro.
    6. Para cada ocorrência de Normal.dot apresentada na caixa de diálogo Localizar (Find), clique com o botão direito do rato no ficheiro. Clique em Mudar o nome (Rename) no menu de atalho. Atribua outro nome ao ficheiro, como NormalAntigo.dot ou Normal-1.dot e, em seguida, prima ENTER.
    7. No menu Ficheiro (File), clique em Sair (Exit) para fechar a caixa de diálogo Localizar (Find) e, em seguida, reinicie o Word normalmente (sem utilizar o parâmetro /a).
  • Microsoft Windows Millennium Edition (Me) ou Microsoft Windows 2000
    1. Saia de todas as instâncias do Word. Se utilizar o Word como editor de correio electrónico, certifique-se de que termina também o Microsoft Outlook.
    2. Clique em Iniciar, aponte para Procurar e, em seguida, clique em Ficheiros ou pastas.
    3. Na caixa Procurar ficheiros ou pastas com o nome escreva Normal.dot.
    4. Na caixa Procurar em, seleccione o disco rígido local (ou uma localização alternativa de modelos do utilizador, caso esteja a executar o Word a partir de um servidor de rede).
    5. Clique em Procurar agora para procurar o ficheiro.
    6. Para cada ocorrência de Normal.dot apresentada na caixa de diálogo Localizar, clique com o botão direito do rato no ficheiro. Clique em Mudar o nome no menu de atalho. Atribua outro nome ao ficheiro, como NormalAntigo.dot ou Normal-1.dot e, em seguida, prima ENTER.
    7. No menu Ficheiro, clique em Sair para fechar a caixa de diálogo Localizar e, em seguida, reinicie o Word normalmente (sem utilizar o parâmetro /a).
  • Windows XP
    1. Saia de todas as instâncias do Word. Se utilizar o Word como editor de correio electrónico, certifique-se de que termina também o Microsoft Outlook.
    2. Clique em Iniciar e, em seguida, clique em Procurar.
    3. Clique em Todos os ficheiros e pastas.
    4. Clique em Mais opções avançadas e clique para seleccionar a caixa de verificação Procurar em ficheiros e pastas ocultos.
    5. Na caixa A totalidade ou parte do nome do ficheiro, escreva normal.dot.
    6. Na caixa Procurar em, seleccione o disco rígido local (ou uma localização alternativa de modelos do utilizador, caso esteja a executar o Word a partir de um servidor de rede).
    7. Clique em Procurar para procurar o ficheiro.
    8. No painel da direita da caixa de diálogo Resultados da procura, clique com o botão direito do rato em Normal.dot e, em seguida, clique em Mudar o nome no menu de atalho apresentado. Escreva um novo nome de ficheiro (por exemplo, NormalAntigo.dot) e, em seguida, prima ENTER.
    9. Feche a caixa de diálogo Resultados da procura e, em seguida, reinicie o Word normalmente (sem utilizar o parâmetro /a).
Se o Word for iniciado correctamente, significa que o problema foi resolvido.

Neste caso, o problema era causado por um modelo Normal.dot danificado. Poderá ter de alterar algumas definições para restaurar as suas opções preferidas.

Se o ficheiro Normal.dot ao qual mudou o nome contiver personalizações, tais como estilos, macros ou entradas de texto automático que não sejam fáceis de criar novamente, poderá conseguir copiar estas personalizações a partir do ficheiro Normal.dot antigo para o novo ficheiro Normal.dot, utilizando o Organizador.

Para obter mais informações sobre como utilizar o Organizador, clique em Ajuda do Microsoft Word no menu Ajuda, escreva organizador no Assistente do Office ou no Assistente de respostas e clique em Procurar para visualizar os tópicos devolvidos.

Mudar o nome da chave 'Data' no registo do Windows

Nota: para obter um método automatizado de efectuar este passo, consulte o artigo listado na secção "Referências" deste artigo.

Aviso: a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.
Nota: ao alterar o nome da chave Data, repõe as predefinições de várias opções, incluindo a lista de ficheiros utilizados mais recentemente (MRU, Most Recently Used) no menu Ficheiro e muitas das definições personalizadas ao clicar em Opções no menu Ferramentas. O Word recria a chave Data, utilizando as predefinições incorporadas, da próxima vez que Word for iniciado.

Para mudar o nome da chave Data, siga estes passos:
  1. Saia de todos os programas do Windows.
  2. Clique em Iniciar, clique em Executar, escreva regedit na caixa Abrir e clique em OK.
  3. Localize a chave que se segue clicando duas vezes nas pastas adequadas para a sua versão do Word:

    Para o Microsoft Office Word 2003:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Para o Microsoft Word 2002:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    Para o Microsoft Word 2000:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data
  4. Com a pasta Data seleccionada, clique em Mudar o nome no menu Editar.
  5. Escreva um novo nome para a pasta Data (por exemplo, escreva OldData) e, em seguida, prima ENTER.
  6. Feche o Editor de registo e reinicie o Word normalmente (sem utilizar o parâmetro /a).
Se o Word for iniciado correctamente, significa que o problema foi resolvido. O problema estava relacionado com uma chave Data danificada. Poderá ter de alterar algumas definições para restaurar as suas opções preferidas.


Criar uma macro de pré-visualização

Altere a macro de pré-visualização do Word de modo a apresentar as definições pretendidas.

Por exemplo, para apresentar automaticamente a barra de ferramentas Formatação na pré-visualização, siga estes passos:
  1. No menu Ferramentas, aponte para Macro e, em seguida, clique em Macros.
  2. Altere a selecção na caixa Macros em para Comandos do Word.
  3. Na lista Nome da macro, seleccione Ficheiro Pré-visualizar.
  4. Altere a definição na caixa Macros em para Normal.dot (modelo global).
  5. Clique em Criar.
  6. Crie a seguinte macro:
    Sub FilePrintPreview()
    '
    ' FilePrintPreview Macro
    ' Displays full pages as they will be printed.
    '
       ActiveDocument.PrintPreview
       CommandBars("Formatting").Visible = True
    End Sub
    					
  7. No menu Ficheiro, clique em Fechar e regressar ao Microsoft Word.

Mais Informação

Para obter informações adicionais sobre como personalizar e criar barras de ferramentas e botões das barras, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
291292 HOW TO: Work with toolbars and toolbar buttons: add, create, edit, delete, restore, and more in Word 2002

Referências


Para obter informações adicionais sobre como automatizar a resolução de problemas do Word removendo determinados componentes chave que possam estar danificados ou a provocar um conflito com o Microsoft Word, clique no número de artigo seguinte para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
289506 How to install and use the Support.dot template in Microsoft Word 2002

Propriedades

Artigo: 291484 - Última revisão: 31 de março de 2006 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbsettings kbtoolbar kbmenu kbmacro kbprb KB291484

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com