После запуска программы Word в ней отсутствуют панели инструментов или меню либо личные настройки приняли прежние значения

Переводы статьи Переводы статьи
Код статьи: 291484 - Vizualiza?i produsele pentru care se aplic? acest articol.
Данная статья включает сведения из ранее опубликованной статьи 242368

Внимание! Эта статья содержит сведения об изменении реестра. Перед внесением изменений в системный реестр рекомендуется создать резервную копию системного реестра и изучить процедуру его восстановления. Дополнительные сведения о создании резервной копии, восстановлении и изменении реестра см. в следующей статье базы знаний Майкрософт:
256986 Описание реестра Microsoft Windows
Развернуть все | Свернуть все

В этой статье

Проблема

При запуске программы Microsoft Word возможно возникновение перечисленных ниже проблем.
  • Отсутствуют панели инструментов.
  • Отсутствует меню.
  • Личные настройки пользователя приняли прежние значения.

Временное решение

Для восстановления панелей инструментов, меню или личных настроек используйте один из приведенных ниже способов в соответствии с ситуацией.

Отключение полноэкранного режима

В полноэкранном режиме на экране отображается максимальная часть документа. В этом режиме Word скрывает такие элементы интерфейса, как меню, панели инструментов и полосы прокрутки. Для восстановления панелей инструментов и меню отключите полноэкранный режим.
  • Если документ открыт, выполните одно из перечисленных ниже действий.
    • Нажмите клавиши ALT+В (ALT+V в англоязычной версии), чтобы отобразить меню Вид, после чего для отключения полноэкранного режима нажмите клавишу Э (U в англоязычной версии).
    • Если отображается панель инструментов Во весь экран, щелкните кнопку Вернуть обычный режим.
  • Если документ не открыт, выполните перечисленные ниже действия.
    1. Нажмите клавиши CTRL+N, чтобы создать документ.
    2. Нажмите клавиши ALT+В (ALT+V в англоязычной версии), чтобы отобразить меню Вид, после чего для отключения полноэкранного режима нажмите клавишу Э (U в англоязычной версии).
Перезапустите программу Word. Если она запустится корректно, проблема решена. Причиной возникновения проблемы было то, что программа Word была закрыта при работе в полноэкранном режиме, и эти настройки сохранились.

Дополнительные сведения о полноэкранном режиме см. в следующей статье базы знаний Майкрософт:
290947 Меню и панели инструментов исчезают, а в строке состояния выводится текст «Repeat Value:8» (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Отображение панелей инструментов по умолчанию

Выберите в меню Вид пункт Панели инструментов. Посмотрите, отмечены ли какие-либо панели инструментов. Если нет, отметьте панели инструментов, которые нужно отобразить. Чтобы отметить панель инструментов, щелкните ее название. Повторите это для каждой панели инструментов, которую нужно отобразить. По умолчанию отмечены панели инструментов Стандартная и Форматирование, а также Область задач.

Примечание. Если панели меню нет на экране, нажмите клавиши ALT+В (ALT+V в англоязычной версии), чтобы отобразить меню Вид, после чего нажмите клавишу И (T в англоязычной версии), чтобы отобразить меню Панели инструментов.

Перезапустите программу Word. Если она запустится корректно, проблема решена. Причиной проблемы было то, что при выходе из программы Word панели инструментов по умолчанию и панель меню были отключены, и эти настройки были сохранены.


Запуск Word без выполнения макросов

Проверьте, не используется ли для запуска программы Word макрос Microsoft Visual Basic для приложений, запускающий ее без отображения каких-либо меню и панелей инструментов.

Если Word запускается с помощью ярлыка, проверьте командную строку, в которой указано имя макроса. Для этого выполните перечисленные ниже действия.
  1. Найдите ярлык, используемый для запуска Word.
  2. Щелкните ярлык правой кнопкой мыши и выберите в контекстном меню пункт Свойства.
  3. Откройте вкладку Ярлык.
  4. Найдите в поле Объект командную строку наподобие
    "C:\Program Files\Microsoft Office\Office10\WINWORD.EXE" /mимя_макроса
    , где /mимя_макроса обозначает имя макроса.

  5. Если в командной строке присутствует параметр /mимя_макроса, удалите его и запустите Word обычным способом.

    Примечание. Если задан параметр /m с именем макроса, при запуске Word выполняется указанный макрос. Кроме того, параметр /m запрещает выполнение в Word каких-либо макросов AutoExec.
Если Word запустится корректно, проблема решена. Возникла она из-за того, что макрос, выполнявшийся при запуске программы Word, изменял вид ее окна.

Дополнительные сведения о параметрах командной строки, которые можно использовать для запуска Word, см. в следующей статье базы знаний Майкрософт:
210565 Использование параметров командной строки для запуска Word 2003, Word 2002 и Word 2000

Какая-то программа (например, надстройка Word) изменила пользовательский интерфейс Word, скрыв панели инструментов или изменив заданные пользователем параметры

Действие 1. Запустите Word с параметрами по умолчанию

Запуск программы Word с параметром командной строки /a приводит к принудительному использованию стандартной конфигурации и предотвращает загрузку надстроек и общих шаблонов.

Параметр /a позволяет запустить программу Word без загрузки следующих компонентов:
  • общий шаблон (Normal.dot);
  • любые дополнительные шаблоны в папке «Автозагрузка»;
  • любые библиотеки надстроек (файлы WIL);
  • пользовательские настройки, хранящиеся в разделе данных в реестре Windows.
Примечание. При запуске программы Word с параметром /a все изменения, сделанные в ней и затрагивающие любой из этих компонентов, не записываются на жесткий диск при выходе из программы и будут потеряны.

В приведенном ниже примере предполагается, что программа Word расположена в следующей папке:
C:\Program Files\Microsoft Office\Office10
Примечание. Программа Word может быть установлена в другой папке.

Чтобы запустить Word с параметром /a, выполните перечисленные ниже действия.
  1. Откройте меню Пуск, выберите команду Выполнить, а затем нажмите кнопку Обзор.
  2. В окне Обзор найдите файл Winword.exe и выделите его.
  3. Нажмите кнопку Открыть.

    Примечание. В поле Открыть диалогового окна Выполнить появится нужное значение.
  4. Установите курсор в поле Открыть после текста Winword.exe.

    Примечание. Путь к файлу Winword.exe в диалоговом окне Выполнить будет заключен в кавычки. Убедитесь в том, что курсор находится справа от закрывающих кавычек.
  5. Введите пробел, а затем параметр /a.

    Выражение в поле Открыть должно выглядеть подобным образом:
    "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
Если Word запустится корректно, проблема решена. Возникла она из-за того, что надстройка, используемый по умолчанию шаблон Normal, другой шаблон или раздел данных в реестре влияли на вид окна программы Word при ее запуске.

Действие 2. Переименование общего шаблона

Примечание. Описание способа автоматизированного выполнения этого этапа см. в статье, указанной в разделе Ссылки.

Чтобы форматирование, автотекст и макросы из общего шаблона Normal.dot не влияли на поведение Word и открытых документов, переименуйте файл Normal.dot.

Примечание. Переименование шаблона Normal.dot позволяет быстро узнать, не он ли является причиной описываемой проблемы. При переименовании шаблона Normal.dot восстанавливаются значения по умолчанию некоторых параметров, в том числе пользовательских стилей, панелей инструментов, макросов и записей автотекста. Поэтому корпорация Microsoft настоятельно рекомендует переименовать файл Normal.dot.

В некоторых конфигурациях возможно создание нескольких файлов Normal.dot. Это возможно при запуске на одном компьютере нескольких версий программы Word или в случае наличия на нем нескольких установок рабочих станций. В этих ситуациях нужно переименовать все копии файла Normal.dot. Чтобы переименовать общий шаблон (Normal.dot), выполните перечисленные ниже действия.
  • Microsoft Windows 98 и Microsoft Windows NT 4.0
    1. Закройте все экземпляры программы Word. Если Word используется в качестве редактора электронной почты, необходимо также закрыть программу Microsoft Outlook.
    2. Нажмите кнопку Пуск, выберите пункт Найти, а затем — Файлы и папки.
    3. В поле Имя введите Normal.dot.
    4. В поле Где искать выберите локальный жесткий диск (или другое расположение пользовательского шаблона, если программа Word выполняется на сетевом сервере).
    5. Нажмите кнопку Найти, чтобы найти файл.
    6. Щелкните правой кнопкой мыши каждый файл Normal.dot, который отображается в диалоговом окне Результаты поиска. Выберите в контекстном меню команду Переименовать. Введите новое имя файла, например OldNormal.dot или Normal-1.dot, и нажмите клавишу ВВОД.
    7. Выберите в меню Файл пункт Выход, чтобы закрыть диалоговое окно Результаты поиска, и перезапустите Word обычным способом (без параметра /a).
  • Microsoft Windows Millennium Edition (Me) или Microsoft Windows 2000
    1. Закройте все экземпляры программы Word. Если Word используется в качестве редактора электронной почты, необходимо также закрыть программу Microsoft Outlook.
    2. Нажмите кнопку Пуск, выберите команду Найти, а затем — Файлы и папки.
    3. В поле Искать имена файлов или папок введите Normal.dot.
    4. В поле Где искать выберите локальный жесткий диск (или другое расположение пользовательского шаблона, если программа Word выполняется на сетевом сервере).
    5. Нажмите кнопку Найти, чтобы найти файл.
    6. Щелкните правой кнопкой мыши каждый файл Normal.dot, который отображается в диалоговом окне результатов поиска. Выберите в контекстном меню команду Переименовать. Введите новое имя файла, например OldNormal.dot или Normal-1.dot, и нажмите клавишу ВВОД.
    7. Выберите в меню Файл пункт Закрыть, чтобы закрыть диалоговое окно результатов поиска, и перезапустите Word обычным способом (без параметра /a).
  • Windows XP
    1. Закройте все экземпляры программы Word. Если Word используется в качестве редактора электронной почты, необходимо также закрыть программу Microsoft Outlook.
    2. Нажмите кнопку Пуск и выберите пункт Найти.
    3. Щелкните ссылку Файлы и папки.
    4. Щелкните пункт Дополнительные параметры, а затем установите флажок Поиск в скрытых файлах и папках.
    5. В поле Часть имени файла или имя файла целиком введите normal.dot.
    6. В поле Поиск в выберите локальный жесткий диск (или другое расположение пользовательского шаблона, если программа Word выполняется на сетевом сервере).
    7. Нажмите кнопку Найти, чтобы найти файл.
    8. В правой части диалогового окна Результаты поиска щелкните правой кнопкой мыши файл Normal.dot, а затем выберите в отобразившемся контекстном меню пункт Переименовать. Введите новое имя файла (например, OldNormal.dot) и нажмите клавишу ВВОД.
    9. Закройте диалоговое окно Результаты поиска и перезапустите Word обычным способом (без параметра /a).
Если Word запустится корректно, проблема решена.

В данном случае она была вызвана повреждением шаблона Normal.dot. Возможно, потребуется изменить некоторые настройки, чтобы восстановить предпочтительные параметры.

Если переименованный файл Normal.dot содержит пользовательские настройки, например стили, макросы или записи автотекста, которые трудно восстановить, эти настройки можно скопировать из старого файла Normal.dot в новый с помощью средства «Организатор».

Для получения дополнительных сведений об использовании средства «Организатор» выберите команду Справка: Microsoft Office Word в меню Справка, затем введите в поле помощника Office или мастера ответов строку организатор и нажмите кнопку Поиск.

Переименование раздела данных в реестре Windows

Примечание. Описание способа автоматизированного выполнения этого этапа см. в статье, указанной в разделе Ссылки.

Предупреждение. Неправильное использование редактора реестра может привести к серьезным проблемам, для решения которых может потребоваться переустановка операционной системы. Корпорация Майкрософт не несет ответственности за неправильное использование редактора реестра. При изменении реестра полагайтесь на свой опыт и знания.
Примечание. При переименовании раздела данных некоторые параметры принимают значения по умолчанию. В их число входит список последних использованных файлов в меню Файл и многие параметры, доступные через пункт Параметры меню Сервис. Программа Word восстанавливает раздел данных при очередном запуске, используя встроенные параметры, действующие по умолчанию.

Чтобы переименовать раздел данных, выполните перечисленные ниже действия.
  1. Закройте все программы.
  2. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду regedit и нажмите кнопку ОК.
  3. Найдите указанный ниже раздел, дважды щелкая соответствующие папки (имя папки зависит от версии Word).

    Microsoft Office Word 2003:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    Microsoft Word 2002:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    Microsoft Word 2000:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data
  4. Выделите папку данных и выберите в меню Правка команду Переименовать.
  5. Введите новое имя папки данных (например, OldData) и нажмите клавишу ВВОД.
  6. Закройте редактор реестра и перезапустите Word обычным способом (без параметра /a).
Если Word запустится корректно, проблема решена. Возникла она из-за повреждения раздела данных. Возможно, потребуется изменить некоторые настройки, чтобы восстановить предпочтительные параметры.


Создание макроса предварительного просмотра

Измените в программе Word макрос предварительного просмотра таким образом, чтобы на экране отображались нужные параметры.

Например, чтобы в окне предварительного просмотра автоматически отображалась панель инструментов Форматирование, выполните перечисленные ниже действия.
  1. В меню Сервис выберите пункт Макрос и щелкните Макросы.
  2. В списке Макросы из выберите Команд Word.
  3. В списке Имя выберите макрос FilePrintPreview.
  4. В списке Макросы из выберите Normal.dot (общего шаблона).
  5. Нажмите кнопку Создать.
  6. Создайте следующий макрос:
    Sub FilePrintPreview()
    '
    ' Макрос FilePrintPreview
    ' Отображает целые страницы так, как они будут распечатаны.
    '
       ActiveDocument.PrintPreview
       CommandBars("Formatting").Visible = True
    End Sub
    					
  7. В меню Файл выберите команду Закрыть и вернуться в Microsoft Word.

Дополнительная информация

Дополнительные сведения о настройке и создании панелей инструментов и их кнопок см. в следующей статье базы знаний Майкрософт:
291292 Инструкция. Работа с панелями инструментов и кнопками панелей инструментов в Word 2002: добавление, создание, редактирование, восстановление и прочие действия (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Ссылки


Дополнительные сведения об автоматизации устранения неполадок с программой Word путем удаления некоторых ключевых компонентов, которые могут быть повреждены или конфликтуют с Microsoft Word, см. в следующей статье базы знаний Майкрософт:
289506 Установка и использование шаблона Support.dot в Microsoft Word 2002 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Свойства

Код статьи: 291484 - Последний отзыв: 9 февраля 2007 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Ключевые слова: 
kbsettings kbtoolbar kbmenu kbmacro kbprb KB291484

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com