啟動 Word 時,工具列或功能表列遺失,或者未保留個人化設定

文章翻譯 文章翻譯
文章編號: 291484 - 檢視此文章適用的產品。
本文是下列先前已發佈文件的整合:242368

重要 本文包含修改登錄的相關資訊。修改登錄之前,請務必將它備份起來,並瞭解如何在發生問題時還原登錄。如需有關如何備份、還原和編輯登錄的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
256986 Microsoft Windows 登錄說明
全部展開 | 全部摺疊

在此頁中

徵狀

當您啟動 Microsoft Word 時,可能會遇到下列其中一種徵狀:
  • 工具列遺失。
  • 功能表列遺失。
  • 未保留個人化設定。

其他可行方案

如果要還原工具列、功能表或個人化設定,請根據您的情況使用下列其中一個方法。

關閉全螢幕模式

全螢幕模式會儘可能地在螢幕上顯示您的文件。在這個模式中,Word 會移除功能表列、工具列和捲軸之類的螢幕元素。如果要還原工具列和功能表,請關閉全螢幕模式。
  • 如果文件處於開啟中,請執行下列其中一項操作:
    • 按 ALT+V 以顯示 [檢視] 功能表,然後按 U 以關閉全螢幕模式。
    • 如果顯示 [全螢幕] 工具列,按一下 [關閉全螢幕]
  • 如果文件沒有開啟,請依照下列步驟執行:
    1. 按 CTRL+N 以啟動新文件。
    2. 按 ALT+V 以顯示 [檢視] 功能表,然後按 U 以關閉全螢幕模式。
結束,然後重新啟動 Word。如果 Word 正確地啟動,表示問題已解決。這個問題在於,當啟動全螢幕模式時會關閉 Word,而 Word 保留了該設定。

如需有關全螢幕模式的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
290947 Menus and toolbars disappear and "Repeat Value:8" is displayed on the status bar in Word 2002

開啟預設工具列

[檢視] 功能表上,指向 [工具列]。請注意是否有選取任何工具列。如果沒有選取任何工具列,請選取您想要的工具列。如果要執行這項操作,請按一下工具列名稱。針對您要顯示的每個工具列,重複執行這個程序。根據預設會選取 [一般][格式] 工具列,以及 [工作窗格]

注意 如果看不到功能表列,請按 ALT+V 以顯示 [檢視] 功能表,然後按 T 以顯示 [工具列] 功能表。

結束,然後重新啟動 Word。如果 Word 正確地啟動,表示問題已解決。這個問題在於,當結束 Word 時,關閉了預設工具列和功能表列,而 Word 保留了這些設定。


啟動 Word 而不執行巨集

查看是否有使用 Microsoft Visual Basic for Applications (VBA) 巨集來啟動 Word。有可能是您執行的 VBA 巨集,以不顯示任何功能表或工具列的方式啟動 Word。

如果您是使用捷徑啟動 Word,請檢查該捷徑所使用的命令列,以確定巨集的名稱。如果要執行這項操作,請依照下列步驟執行:
  1. 找到您用來執行 Word 的捷徑。
  2. 用滑鼠右鍵按一下捷徑,然後按一下快顯功能表上的 [內容]
  3. 按一下 [捷徑] 索引標籤。
  4. 查看 [目標] 方塊中,類似下列的命令列:
    "C:\Program Files\Microsoft Office\Office10\WINWORD.EXE" /mmacro name
    其中 /mmacro name 即為巨集的名稱。

  5. 如果命令列中有看到 /mmacro name,請加以移除,然後以標準方式啟動 Word。

    注意/m 參數後面加上巨集名稱會啟動 Word 並執行特定的巨集。/m 參數也可以防止 Word 執行任何 AutoExec 巨集。
如果 Word 正確地啟動,表示問題已解決。這個問題的原因是在啟動 Word 時執行了巨集,而該巨集會變更 Word 視窗的外觀。

如需有關可用來啟動 Word 的命令列參數的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
210565 WD:Word 啟動 (指令行) 參數及其目的

程式 (例如 Word 增益集) 修改過使用者介面、隱藏工具列或變更您的設定

步驟 1:使用預設值啟動 Word

藉由在命令列使用 /a 參數啟動 Word,可以讓 Word 使用所有選項的預設值,並避免載入增益集和共用範本。

/a 參數可以讓您啟動 Word,而不載入下列元件:
  • 共用範本 (Normal.dot)
  • 任何 Startup 資料夾中的增益集範本
  • 任何增益集庫 (.wll 檔案)
  • 儲存在 Windows 登錄中 Data 機碼的使用者設定
注意 當您使用 /a 參數啟動 Word 時,您在 Word 中進行的變更,雖然會影響這些元件,但在結束 Word 後,這些變更都不會寫入硬碟中且會遺失。

以下的範例假設 Word 位於下列資料夾:
C:\Program Files\Microsoft Office\Office10
注意 您的 Word 有可能安裝在不同的資料夾。

如果要使用 /a 參數啟動 Word,請依照下列步驟執行:
  1. 按一下 [開始],再按一下 [執行],然後按一下 [瀏覽]
  2. 使用 [查詢] 方塊找出 Winword.exe,然後按一下以選取。
  3. 按一下 [開啟]

    注意 這個步驟會填滿 [執行] 對話方塊中的 [開啟] 方塊。
  4. 按一下 [開啟] 方塊中 Winword.exe 的後面。

    注意[執行] 對話方塊中的 Winword.exe 檔案路徑會用引號括住。確定您是在結尾引號的右邊按下滑鼠。
  5. 輸入一個空白字元,然後再輸入 /a

    [開啟] 方塊中的陳述式應類似下列範例:
    "C:\Program Files\Microsoft Office\Office10\Winword.exe" /a
如果 Word 正確地啟動,表示問題已解決。這個問題的原因是在啟動 Word 時,有增益集程式或範本、預設 Normal 範本或登錄中的 Data 機碼,影響了 Word 視窗的顯示方式。

步驟 2:重新命名共用範本

注意 如需自動執行此步驟的方法,請參閱本文中<參考> 一節。

如果要避免共用範本 (Normal.dot) 中儲存的格式設定、自動圖文集和巨集影響到 Word 或開啟的文件的行為,請重新命名 Normal.dot 檔案。

注意 重新命名 Normal.dot 範本可讓您快速判斷 Normal 範本是否造成這個問題。重新命名 Normal.dot 範本會將數個選項重設回預設值,包括自訂樣式、自訂工具列、巨集與自動圖文集項目等。考慮到這個因素,Microsoft 強烈建議您重新命名 Normal.dot 檔案。

某些類型的組態可能會建立多個 Normal.dot 檔案。這些情況包括在同一部電腦上執行多種 Word 版本,或同一部電腦上存在數個工作站安裝。在這些情況下,請確定重新命名所有 Normal.dot 的複本。如果要重新命名共用範本 (Normal.dot),請依照下列步驟執行:
  • Microsoft Windows 98 和 Microsoft Windows NT 4.0
    1. 結束 Word 的所有執行個體。如果您使用 Word 做為電子郵件編輯器,也請務必結束 Microsoft Outlook。
    2. 按一下 [開始],指向 [尋找],然後按一下 [檔案或資料夾]
    3. [名稱] 方塊中,輸入 Normal.dot
    4. [尋找在] 方塊中,選取本機硬碟 (或是從網路伺服器執行 Word 的替代使用者範本位置)。
    5. 按一下 [立即尋找],以搜尋檔案。
    6. 針對出現在 [尋找] 對話方塊中的每個 Normal.dot,用滑鼠右鍵按一下檔案。在快顯功能表上按一下 [重新命名]。為檔案指定新名稱,例如 OldNormal.dot 或 Normal-1.dot,然後按 ENTER。
    7. [檔案] 功能表上,按一下 [結束] 以關閉 [尋找] 對話方塊,然後以標準方式重新啟動 Word (而不使用 /a 參數)。
  • Microsoft Windows Millennium Edition (Me) 或 Microsoft Windows 2000
    1. 結束 Word 的所有執行個體。如果您使用 Word 做為電子郵件編輯器,也請務必結束 Microsoft Outlook。
    2. 按一下 [開始],指向 [搜尋],然後按一下 [檔案或資料夾]
    3. [搜尋名稱如下的檔案或資料夾] 方塊中,輸入 Normal.dot
    4. [尋找在] 方塊中,選取本機硬碟 (或是從網路伺服器執行 Word 的替代使用者範本位置)。
    5. 按一下 [立即搜尋],以搜尋檔案。
    6. 針對出現在 [搜尋] 對話方塊中的每個 Normal.dot,用滑鼠右鍵按一下檔案。在快顯功能表上按一下 [重新命名]。為檔案指定新名稱,例如 OldNormal.dot 或 Normal-1.dot,然後按 ENTER。
    7. [檔案] 功能表上,按一下 [關閉] 以關閉 [搜尋] 對話方塊,然後以標準方式重新啟動 Word (而不使用 /a 參數)。
  • Windows XP
    1. 結束 Word 的所有執行個體。如果您使用 Word 做為電子郵件編輯器,也請務必結束 Microsoft Outlook。
    2. 按一下 [開始],然後按一下 [搜尋]
    3. 按一下 [所有檔案和資料夾]
    4. 按一下 [進階選項],然後按一下以選取 [搜尋隱藏檔案及資料夾] 核取方塊。
    5. [部份或完整的檔案名稱] 方塊中,輸入 normal.dot
    6. [尋找在] 方塊中,選取本機硬碟 (或是從網路伺服器執行 Word 的替代使用者範本位置)。
    7. 按一下 [搜尋],以搜尋檔案。
    8. [搜尋結果] 對話方塊右邊的窗格中,用滑鼠右鍵按一下 [Normal.dot],然後在出現的快顯功能表上按一下 [重新命名]。輸入新的檔案名稱 (例如 OldNormal.dot),然後按下 ENTER。
    9. 關閉 [搜尋結果] 對話方塊,然後以您平常的方式重新啟動 Word (而不使用 /a 參數)。
如果 Word 正確地啟動,表示問題已解決。

在這個案例中,問題的原因是損毀的 Normal.dot 範本。您可能需要變更少數設定,還原您喜好的選項。

如果您所重新命名的 Normal.dot 檔案包含自訂,例如樣式、巨集或自動圖文集等無法輕易重建的項目,您可以使用「組合管理」,將舊 Normal.dot 檔案的自訂項目複製到新 Normal.dot 檔案內。

如需有關如何使用「組合管理」的詳細資訊,請按一下 [說明] 功能表上的 [Microsoft Word 說明],在「Office 小幫手」或「解答精靈」中輸入組合管理,然後按一下 [搜尋] 以檢視傳回的主題。

重新命名 Windows 登錄中的 Data 機碼

注意 如需自動執行此步驟的方法,請參閱本文中<參考> 一節。

警告 不當使用「登錄編輯程式」可能會導致嚴重的問題,甚至必須重新安裝作業系統。Microsoft 不保證可以解決您不當使用「登錄編輯程式」所導致的問題。請自行承擔使用「登錄編輯程式」的一切風險。
注意 重新命名 Data 機碼會將數個選項重設回預設值,包括列於 [檔案] 功能表上的最近使用 (MRU) 檔案清單,以及您按一下 [工具] 功能表上的 [選項] 時自訂的許多設定。下次啟動 Word 時,Word 會使用內建的預設值重建 Data 機碼。

如果要重新命名 Data 機碼,請依照下列步驟執行:
  1. 結束所有 Windows 程式。
  2. 按一下 [開始],再按一下 [執行],在 [開啟] 方塊中輸入 regedit,然後按一下 [確定]
  3. 按兩下適合您版本的 Word 的資料夾,以找出下列機碼:

    如果是 Microsoft Office Word 2003:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data
    如果是 Microsoft Word 2002:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data
    如果是 Microsoft Word 2000:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data
  4. 在 Data 資料夾為選取狀態時,按一下 [編輯] 功能表上的 [重新命名]
  5. 為 Data 資料夾輸入新名稱 (例如,輸入 OldData),然後按 ENTER。
  6. 結束登錄編輯程式,然後以標準方式重新啟動 Word (而不使用 /a 參數)。
如果 Word 正確地啟動,表示問題已解決。這個問題的原因是損毀的 Data 機碼。您可能需要變更少數設定,還原您喜好的選項。


建立預覽列印巨集

在 Word 中變更預覽列印巨集,以顯示您要的設定。

例如,如果要在預覽列印中自動顯示 [格式] 工具列,請依照下列步驟執行:
  1. [工具] 功能表上,指向 [巨集],然後按一下 [巨集]
  2. [巨集作用於] 方塊中的選取變更為 [Word 指令]
  3. [巨集名稱] 清單中,按一下 [FilePrintPreview]
  4. [巨集作用於] 方塊中的設定變更為 [Normal.dot (共用範本)]
  5. 按一下 [建立]
  6. 建立以下巨集:
    Sub FilePrintPreview()
    '
    ' FilePrintPreview Macro
    ' Displays full pages as they will be printed.
    '
       ActiveDocument.PrintPreview
       CommandBars("Formatting").Visible = True
    End Sub
    					
  7. [檔案] 功能表上,按一下 [關閉並回到 Microsoft Word]

其他相關資訊

如需有關如何自訂並建立工具列和工具列按鈕的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
291292 HOW TO:使用工具列與工具列按鈕:在 Wrod 2002 中新增、建立、編輯、刪除、還原等等

?考


如需有關如何移除可能對 Microsoft Word 造成損害或衝突的特定機碼元件,以自動疑難排解 Word 問題的詳細資訊,請按一下下面的文件編號,以檢視「Microsoft 知識庫」中的文件:
289506 HOW TO:在 Microsoft Word 2002 中安裝並使用 Support.dot 範本

屬性

文章編號: 291484 - 上次校閱: 2006年12月21日 - 版次: 5.0
這篇文章中的資訊適用於:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
關鍵字:?
kbsettings kbtoolbar kbmenu kbmacro kbprb KB291484
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com