Vorgehensweise, wenn Ihr Computer mit einer Office für Mac-Programm installiert einen Makrovirus kann

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 291824 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Ein Microsoft Word 98-Version dieses Artikels finden Sie unter 181080.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel beschreibt was Makroviren sind, Vorgehensweise, wenn Ihrer Meinung nach Ihrem Computer einen Word-Makrovirus sein kann und wie Sie sicherstellen, dass Ihre Dokumente nicht mit einen Makrovirus infiziert werden.

Weitere Informationen

Der erste Makrovirus wurde im Sommer 1995 entdeckt. Seit diesem Zeitpunkt haben andere Makroviren angezeigt.

Ein Makrovirus ist ein bösartiges Programm, das mithilfe eines Programms wie z. B. Word der Makrosprache geschrieben wird. Der Virus verbreitet sich selbst zwischen Datendateien und Betriebssystem Ihres Computers oder Ihrer Dateien beschädigen kann.

Word-Makroviren nicht kostenlos über das Internet oder anderen Medien übertragen; Sie können nur übertragen werden, wenn ein Benutzer ein Dokument oder eine Vorlage, die das Makro Virus enthält, öffnet.

Makroviren können nicht per E-mail übertragen werden, wenn eine betroffene Dokument in der e-Mail-Nachricht eingebettet ist und der Empfänger das Dokument öffnet.

Ein Makrovirus Symptome

Im folgenden werden einige Symptome von Word-Makroviren, die bekanntermaßen Auswirkungen auf Word und Word-Dokumenten:
  • Wenn Sie versuchen, ein Dokument zu speichern, kann Word nur das Dokument als eine Vorlage speichern.

    -oder-
  • Das Symbol für die Datei sieht wie ein Dokument, sondern ein Vorlage.

    -oder-
  • Wenn Sie ein Dokument öffnen, wird ein Dialogfeld mit die Nummer 1.

    -oder-
  • Die Makro- und Anpassen -Befehle werden nicht mehr im Menü Extras angezeigt.

    -oder-
  • Neue Makros in der Liste der Makros angezeigt. AutoOpen, FileSaveAs und Makros möglicherweise auch angezeigt, wenn Sie bereits über Makros durch diese Namen hatten, kann deren Inhalt durch den Makrovirus geändert werden.

    -oder-
  • Ungewöhnlichen oder unerwartete Meldungen angezeigt, wenn Sie ein Word-Dokument oder eine Vorlage öffnen.
Notizen
  • In Word 2001 für Mac, können Sie die Makrovirusschutz -Option festlegen (auf der Sie im Menü Bearbeiten klicken Sie auf Einstellungen und klicken Sie dann auf die Registerkarte Allgemein ) die Benachrichtigung erhalten, wenn Sie eine Datei öffnen, Makros enthält, unabhängig davon, was, die Makros tun, entworfen wurde. In Word X für Mac können Sie die Option Makrovirusschutz indem im Menü Word auf Einstellungen , auf die Registerkarte Allgemein klicken und dann auf die Option Makrovirusschutz aktivieren oder deaktivieren festlegen. In Word 2004 für Mac können Sie die Option Makrovirusschutz indem im Menü Word auf Einstellungen , klicken Sie auf die Registerkarte Sicherheit und dann auf die Option Makrovirusschutz aktivieren oder deaktivieren festlegen. Für eine dauerhafte Lösung müssen Sie antivirus-Software verwenden, die zum Erkennen und verhindern von Makroviren soll.
  • Word nicht nach Makroviren suchen oder entfernen Sie alle Makroviren aus vorhandener Dokumente und Vorlagen. Er gewarnt nur wenn das Dokument, das Sie öffnen Makros enthält. Anschließend können Sie entweder das Dokument mit den aktiven Makros öffnen oder mit deaktivierten Makros öffnen. Sie sollten ein Dokument nur mit aktiven Makros öffnen, wenn Sie absolut sicher sind, dass das Dokument keine schädigenden Makroviren enthält.
  • Antivirus Programme von Fremdanbietern müssen häufig aktualisiert werden, um wirksam zu bleiben. Updateinformationen erhalten Sie den Kreditor.
  • Disinfectant ein Freeware-antivirus-Dienstprogramm für Mac OS 9 und frühere Versionen bietet keinerlei Schutz vor Makroviren. Entwicklung für das Disinfectant-Programm wurde eingestellt. Die endgültige Version des Disinfectant ist Version 3.7.1.

    Hyperlinks zu aktuellen antivirus-Software finden Sie auf die Links, die im nächsten Abschnitt sind. ?S Norton Antivirus von Symantec und Sophos, beide für Mac OS X integriert werden beide nach Makroviren suchen.

Installieren Sie ein Antivirenprogramm

Installieren Sie für eine langfristige Lösung für Makroviren Antivirussoftware, die speziell für die Makroviren zu erkennen. Weitere Informationen zu Herstellern von Antivirensoftware, Software erkennen und verhindern von Makroviren, einschließlich finden Sie die folgende KB-Artikelnummer:
49500Liste von Antivirussoftware-Herstellern
Die Kontaktinformationen bezüglich der in diesem Artikel erwähnten Fremdanbieter sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Microsoft garantiert nicht die Genauigkeit dieser Kontaktinformationen von Drittanbietern.

Wenn Sie Ihrer Meinung nach Ihrem Computer möglicherweise einen Makrovirus

Verwenden Sie die folgenden Methoden, temporäre Lösungen nur, wenn man von Ihrem Computer möglicherweise einen Makrovirus.

Methode 1: Deaktivieren Sie der Makros und kopieren Sie den Text in ein neues Dokument

Wenn treten nicht auf die weiter oben in diesem Artikel beschriebenen Symptome, aber Sie möchten nicht durch ein Makrovirus beeinflusst werden, halten Sie die UMSCHALTTASTE gedrückt, wenn Sie eine Datei öffnen, die durch einen Makrovirus infiziert werden kann. Durch Drücken der UMSCHALTTASTE verhindert alle Word Auto-Makros ausgeführt werden, wenn ein Makrovirus vorhanden ist, ist es nicht geladen.

Methode 2: Löschen Sie das Makro und Wiederherstellen Sie des Dokuments

Gehen Sie wenn die weiter oben in diesem Artikel beschriebenen Symptome auftreten oder wenn Sie vermuten, dass Sie einen Makrovirus verfügen, der nicht in diesem Artikel beschrieben ist, folgendermaßen vor um verdächtige Makro zu löschen und um betroffene Dokument korrigieren.

Hinweis: Dies ist nur eine temporäre Lösung, da neue Makros erstellt werden, diese Schritte funktionieren nicht auf neue Makros.
  1. Schließen Sie Word, und verschieben Sie die Formatvorlage Normal auf den Desktop.
  2. Erstellen Sie eine Sicherungskopie der eine betroffene Datei.
  3. Öffnen Sie Word. Klicken Sie im Menü Datei auf Öffnen .
  4. Navigieren Sie zu dem Ordner, der die betroffene Datei enthält.
  5. Klicken Sie auf die betroffene Datei.
  6. Drücken Sie und halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf Öffnen . Halten Sie die UMSCHALTTASTE gedrückt, bis die betroffene Datei in Word geöffnet ist.

    Hinweis: Beim Öffnen einer Datei die UMSCHALTTASTE gedrückt halten die Ausführung von Word automatische Makros verhindert.
  7. Um eine verdächtige Makro zu löschen, gehen Sie folgendermaßen:
    1. Im Menü Extras auf Makro , und klicken Sie auf Makros .
    2. Makros in Wählen Sie Popup, im Active alle Vorlagen und Dokumenten .
    3. Wählen Sie das fehlerverdächtige-Makro, und klicken Sie dann auf Löschen . Klicken Sie auf Ja , wenn Sie dazu aufgefordert werden, ob Sie das Makro löschen möchten.
    4. Wiederholen Sie die Schritt c für alle verdächtigen Makros.
    5. Klicken Sie auf Abbrechen , um das Dialogfeld Makro zu schließen.
  8. Gehen Sie folgendermaßen vor um den Text eines infizierten Dokuments wiederherzustellen,
    1. Wählen Sie das gesamte Dokument, indem BEFEHLSTASTE + A drücken oder auf im Menü Bearbeiten auf Alles markieren .
    2. Löschen der letzten Absatzmarke des Dokuments aus der Auswahl durch Drücken von UMSCHALT + nach-links.
    3. Klicken Sie im Menü Bearbeiten auf Kopieren .
    4. Klicken Sie im Menü Datei auf neu . Wählen Sie die Vorlage, die Sie verwenden möchten, und klicken Sie dann auf OK .
    5. Klicken Sie im Menü Bearbeiten auf Einfügen .
    6. Wiederholen Sie die Schritt 7, um sicherzustellen, dass das virus-containing Makro nicht repliziert wurde.
    7. Speichern Sie das Dokument.
  9. Wiederholen Sie diese Schritte für jedes Dokument, die Sie vermuten einen Makrovirus enthalten kann.
Hinweis: Wenn Methode 2 nicht funktioniert, versuchen Sie Methode 3.

Methode 3: Verwenden Sie organisieren, um vorübergehend einen Makrovirus bereinigen

Verwenden Sie das Dialogfeld Organisieren, um den Makrovirus zu reinigen. Bedenken Sie, wenn Sie andere Dateien öffnen, nachdem Sie die infizierte Datei geöffnet haben, diese Dateien höchstwahrscheinlich sowie infiziert sind.

Gehen Sie folgendermaßen vor, um den Virus aus der normale Vorlage zu entfernen:
  1. Schließen Sie alle Dokumente. Wenn eine infizierte Dokument geöffnet ist, können Sie problemlos normale Vorlage re-infect.
  2. Im Menü Extras klicken Sie auf Vorlagen und Add-Ins und dann auf die Schaltfläche Organisieren .
  3. Klicken Sie auf die Registerkarte Makroprojektelemente , und dann umbenennen Sie oder löschen Sie alle der folgenden Makros:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • Befehl
    • FileSaveAs
    • Makros
    • ToolsMacro
  4. Klicken Sie auf Schließen .
  5. Gedrückthalten UMSCHALTTASTE während Sie im Menü Datei , die Vorlage zu speichern Alles speichern klicken.
um einen Makrovirus aus eine infizierte Dokument zu entfernen:

Wenn eine Datei infiziert ist, verwenden Sie dieselbe Methode wie in den Schritten 1 bis 5, aber entfernen Sie die Makros aus beiden normale Vorlage und auch aus dem infizierten Dokument (Vorlage), während im Dialogfeld Organisieren. Wenn Sie fertig sind, halten UMSCHALTTASTE, während Sie im Menü Datei auf Alles speichern klicken , und dann auf die nächste Datei verschieben. Bedenken Sie, dass bei jedem eine infizierte Datei öffnen Sie Ihre normale Vorlage infiziert so, dass Sie wiederholt die Makros aus der normale Vorlage entfernen müssen.

Methode 4: Fügen Sie die infizierte Datei in ein neues Dokument

Diese Methode ist besonders nützlich, mit dem Makrovirus "CLIENTZUGRIFFSPUNKT", der Sie im Menü Extras Makro und Anpassen entfernt.

Hinweis: In dieser Situation funktionieren Vorlagen und Add-Ins im Menü Extras nicht.
  1. Schließen Sie Word, und verschieben Sie normale Vorlage auf dem Desktop.
  2. Öffnen Sie Word und stellen Sie sicher, dass im Menü Extras auf Makro und anpassen angezeigt werden.
  3. Öffnen Sie ein neues Dokument. Klicken Sie im Menü Einfügen auf Datei .
  4. Navigieren Sie zu dem Ordner mit der betroffene Datei.
  5. Klicken Sie auf die betroffene Datei.
  6. Drücken Sie und halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann auf Öffnen . Die UMSCHALTTASTE gedrückt halten weiter, bis die betroffene Datei in Word geöffnet ist.
    Hinweis: Beim Öffnen einer Datei die UMSCHALTTASTE gedrückt halten verhindert Word Auto-Makros ausgeführt werden.
  7. Um zu überprüfen, ob Makros vorhanden sind, im neuen Dokument (keine sollten aufgelistet werden), zeigen Sie im Menü Extras auf Makro , und klicken Sie auf Makros . Klicken Sie in der Makros in Popupmenü Liste auf alle aktiven Dokumentvorlagen und Dokumenten . Unter Makroname sollte keine Makros aufgeführt sein. Klicken Sie auf Abbrechen .
  8. Speichern Sie die Datei mit einem anderen Dateinamen.
  9. Löschen Sie die infizierte Datei.

Eigenschaften

Artikel-ID: 291824 - Geändert am: Mittwoch, 31. Januar 2007 - Version: 3.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office V. X für Macintosh
  • Microsoft Office 2001 für Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X für Macintosh
  • Microsoft Word 2001 für Macintosh
Keywords: 
kbmt kbinfo KB291824 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 291824
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com