Che cosa fare se il computer con un Office per Mac programma dispone di un virus macro

Traduzione articoli Traduzione articoli
Identificativo articolo: 291824 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la una versione di Microsoft Word 98 di questo articolo, vedere 181080.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Questo articolo viene descritto che cosa sono i virus delle macro, che cosa fare se si ritiene che il computer sia un virus macro di Word e come assicurarsi che i documenti non diventano contiene un virus macro.

Informazioni

Il primo virus macro Ŕ stato rilevato nell'estate del 1995. Da allora, sono visualizzati altri virus macro.

Un virus macro Ŕ un programma dannoso che viene scritto utilizzando il linguaggio macro di un programma, ad esempio Word. Il virus si propaga automaticamente tra i file di dati e pu˛ danneggiare i file o del sistema operativo.

Virus macro in Word non viaggi liberamente attraverso Internet o qualsiasi altro supporto, pu˛ essere trasferiti solo quando un utente apre un documento o modello che contiene la macro virus.

Virus macro possono essere trasferiti tramite posta elettronica, a meno che non un documento interessato Ŕ incorporato nel messaggio di posta elettronica e il destinatario apre il documento.

Sintomi di un virus macro

Di seguito sono alcuni sintomi di virus macro in Word che influiscono su Word e in Word documenti:
  • Quando si tenta di salvare un documento, Word solo consente di salvare il documento come un modello.

    - oppure -
  • L'icona per il file apparirÓ come un modello anzichÚ di un documento.

    - oppure -
  • Quando si apre un documento, viene visualizzata una finestra di dialogo che mostra il numero 1.

    - oppure -
  • I comandi macro e Personalizza non Ŕ pi¨ visualizzato nel menu Strumenti .

    - oppure -
  • Nuove macro visualizzato nell'elenco di macro. Pu˛ essere visualizzato anche macro AutoOpen e FileSaveAs; se si dispone giÓ di macro da questi nomi, il contenuto potrebbe essere modificato dal virus macro.

    - oppure -
  • I messaggi inusuali o imprevisti vengono visualizzati quando si apre un documento o modello.
note
  • In Word 2001 per Mac, Ŕ possibile impostare l'opzione di Protezione da virus macro (dal menu Modifica , fare clic su Preferenze e quindi scegliere la scheda Generale ) che consente di notificare l'eventuale si apre un file contenente macro, indipendentemente da cosa le macro. In Word X per Mac, Ŕ possibile impostare l'opzione di Protezione da virus macro scegliendo Preferenze dal menu Word , fare clic sulla scheda Generale e selezionando l'opzione Protezione da virus macro per attivarla o disattivare. In Word 2004 per Mac, Ŕ possibile impostare l'opzione di Protezione da virus macro scegliendo Preferenze dal menu Word , fare clic sulla scheda protezione e selezionando l'opzione Protezione da virus macro per attivarla o disattivare. Per una soluzione permanente, Ŕ necessario utilizzare software antivirus Ŕ progettato specificatamente per rilevare e prevenire i virus delle macro.
  • Word non cercare i virus delle macro o rimuovere eventuali virus macro esistenti di documenti e modelli. Un messaggio solo informa se il documento che si sta aprendo contiene delle macro. Quindi Ŕ possibile aprire il documento con le macro attive o aprirlo con le macro disattivate. Non Ŕ consigliabile aprire un documento con le macro attivo, se non si Ŕ assolutamente certi che il documento non contenga alcun virus macro dannosi.
  • Per rimanere efficace Ŕ necessario aggiornare frequentemente programmi antivirus di terze parti. Contattare il fornitore per informazioni sull'aggiornamento.
  • Disinfectant, un'utilitÓ di antivirus di freeware per Mac OS 9 e versioni precedenti, non consente di proteggere dai virus macro. Lo sviluppo del programma Disinfectant Ŕ stato interrotto. La versione finale di Disinfectant Ŕ la versione 3.7.1.

    Per i collegamenti ai software antivirus aggiornato, visitare i collegamenti nella sezione successiva. Entrambi antivirus ?s Norton, Symantec e Sophos, entrambi creati per Mac OS X, verrÓ analizzato per individuare eventuali virus macro.

Installare un programma antivirus

Per una soluzione a lungo termine per i virus delle macro, installare software antivirus progettato per rilevare i virus delle macro. Per ulteriori informazioni sui fornitori di software antivirus, incluso il software in grado di rilevare e impedire virus macro, fare il clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
49500Elenco dei fornitori di software antivirus
Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono pertanto soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza delle informazioni sul contatti-altri produttori.

Operazioni da eseguire quando si ritiene che il computer potrebbe essere presente un virus di macro

Utilizzare i metodi seguenti come soluzioni temporanee solo quando si ritiene che il computer Ŕ possibile che un virus macro.

Metodo 1: Disattivare le macro e copiare il testo in un nuovo documento

Se non si verificano i sintomi descritti in precedenza in questo articolo, ma non si desidera essere interessati da un virus macro, tenere premuto il tasto MAIUSC quando si apre un file che potrebbe essere infetti da virus macro. Premendo MAIUSC impedisce l'esecuzione di qualsiasi macro automatiche di Word, se un virus macro Ŕ presente, non Ŕ caricato.

Metodo 2: Eliminare la macro e recuperare il documento

Se si verificano i sintomi descritti in precedenza in questo articolo o se si ritiene che si sia un virus macro che non Ŕ descritto in questo articolo, attenersi alla seguente procedura per eliminare la macro sospetta e correggere il documento interessato.

Nota Si tratta solo una soluzione temporanea, poichÚ vengono create nuove macro, questa procedura non funzionino in nuove macro.
  1. Chiudere Word e spostare il modello normale sul desktop.
  2. Eseguire una copia di backup di un file interessato.
  3. Aprire Word. Nel menu file , fare clic su Apri .
  4. Passare alla cartella che contiene il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e scegliere Apri . Continuare premuto MAIUSC finchÚ non viene aperto il file interessato.

    Nota Premuto MAIUSC durante l'apertura di un file impedisce qualsiasi macro automatiche di Word l'esecuzione.
  7. Per eliminare una macro sospetta, attenersi alla seguente procedura:
    1. Scegliere macro dal menu Strumenti , quindi macro .
    2. Nel menu a comparsa Macro In selezionare tutti i modelli Active e documenti .
    3. Selezionare la macro sospetta e quindi fare clic su Elimina . Fare clic su quando viene richiesto se si desidera eliminare la macro.
    4. Ripetere il passaggio c per tutte le macro sospette.
    5. Fare clic su Annulla per chiudere la finestra di dialogo macro .
  8. Per recuperare il testo di un documento infetto, attenersi alla seguente procedura:
    1. Selezionare l'intero documento premendo comando+A oppure scegliere Seleziona tutto dal menu Modifica .
    2. Per eliminare l'ultimo segno di paragrafo del documento dalla selezione, premere MAIUSC+freccia sinistra.
    3. Nel menu Modifica , fare clic su Copia .
    4. Nel menu file , fare clic su Nuovo . Selezionare il modello che si desidera utilizzare e quindi fare clic su OK .
    5. Scegliere Incolla dal menu Modifica .
    6. Ripetere il passaggio 7 per garantire che la macro virus-containing non sia stata replicata.
    7. Salvare il documento.
  9. Ripetere questi passaggi per qualsiasi documento che si sospetta che potrebbe contenere un virus macro.
Nota Se il metodo 2 non funziona, provare il metodo 3.

Metodo 3: Utilizzare la libreria per temporaneamente pulire un virus macro

Utilizzare la libreria per pulire il virus macro. Tenere presente che se si aprono altri file dopo aver aperto il file infetto, questi file probabilmente infetti nonchÚ.

Per rimuovere il virus dal modello Normal, attenersi alla seguente procedura:
  1. Chiudere tutti i documenti. Se Ŕ aperto un documento di infetto, Ŕ possibile re-infect facilmente il modello Normal.
  2. Dal menu Strumenti , scegliere modelli e aggiunte e quindi scegliere il pulsante libreria .
  3. Fare clic sulla scheda Macro , quindi rinominare o eliminare tutte le macro seguenti:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • FileNew
    • FileOpen
    • FileSalva
    • FileSaveAs
    • Macro
    • ToolsMacro
  4. Fare clic su Chiudi .
  5. Premere e tenere premuto MAIUSC mentre si scegliere Salva tutto dal menu file per salvare il modello.
per rimuovere un virus macro in un documento infetto:

Se Ŕ stato infettato da un file, utilizzare lo stesso metodo i passaggi da 1 a 5, ma rimuovere le macro da entrambi il modello Normal sia dal documento (modello), mentre nella libreria infetto. Al termine, tenere premuto MAIUSC mentre si scegliere Salva tutto dal menu file e quindi spostare il file successivo. Tenere presente che ogni volta che si apre un file infetto, infetta il modello Normal, in modo che Ŕ necessario rimuovere ripetutamente le macro dal modello Normal.

Metodo 4: Inserire il file infetto in un nuovo documento

Questo metodo Ŕ particolarmente utile con il virus macro "CAP", che rimuove la macro e Personalizza dal menu Strumenti .

Nota In questo caso, modelli e aggiunte dal menu Strumenti potrebbero non funzionare.
  1. Chiudere Word e quindi spostare il modello normale sul desktop.
  2. Aprire Word e quindi verificare che macro e personalizzare siano visualizzati dal menu Strumenti .
  3. Aprire un nuovo documento. Nel menu Inserisci , fare clic su file .
  4. Passare alla cartella contenente il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e scegliere Apri . Continuare a tenere premuto MAIUSC finchÚ non viene aperto il file interessato.
    Nota Premuto MAIUSC durante l'apertura di un file impedisce macro automatiche di Word l'esecuzione.
  7. Per verificare l'esistenza di eventuali macro nel nuovo documento (nessuno dovrebbe essere elencato), scegliere macro dal menu Strumenti e quindi fare clic su macro . Nell'elenco a comparsa Macro In fare clic su tutti i modelli attivi e documenti . Nella casella Nome Macro non dovrebbe essere elencata alcuna macro. Fare clic su Annulla .
  8. Salvare il file con un nome di file diverso.
  9. Eliminare il file infetto.

ProprietÓ

Identificativo articolo: 291824 - Ultima modifica: mercoledý 31 gennaio 2007 - Revisione: 3.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office X per Mac Standard Edition
  • Microsoft Office 2001 per Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X per Macintosh
  • Microsoft Word 2001 per Mac
Chiavi:á
kbmt kbinfo KB291824 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 291824
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com