O que fazer se o computador com do Office para Mac programa instalado tem um vírus em macros

Traduções de Artigos Traduções de Artigos
Artigo: 291824 - Ver produtos para os quais este artigo se aplica.
Para obter uma versão de Microsoft Word 98 deste artigo, consulte 181080.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo descreve o que são vírus em macros, o que fazer se achar que o computador pode ter um vírus em macros do Word e como garantir que os documentos não ficar infectados com um vírus em macros.

Mais Informação

O primeiro vírus em macros foi descoberto no Verão de 1995. Desde esse momento, foram apresentadas outros vírus em macros.

Um vírus de macro é um programa malicioso é escrito utilizando linguagem de macros de um programa como o Word. O vírus propaga-se automaticamente entre ficheiros de dados e pode danificar os ficheiros ou sistema operativo do computador.

Vírus em macros do Word não transmitidos livremente da Internet ou outro suporte; só podem ser transferidos quando um utilizador abre um documento ou modelo que contém a macro de vírus.

Vírus de macros não podem ser transferidos por correio electrónico, a menos que um documento afectado estiver incorporado na mensagem de correio electrónico e o destinatário abre o documento.

Sintomas de um vírus em macros

Seguem-se alguns sintomas de vírus em macros do Word que afectam o Word e o Word documentos:
  • Quando tenta guardar um documento, o Word só permite guardar o documento como um modelo.

    - ou -
  • O ícone para o ficheiro assemelha-se um modelo em vez de um documento.

    - ou -
  • Quando abre um documento, aparece uma caixa de diálogo que mostra o número 1.

    - ou -
  • Os comandos de macro e Personalizar já não aparecem no menu Ferramentas .

    - ou -
  • Novas macros aparecem na lista de macros. Também podem aparecer macros AutoOpen e FileSaveAs; se já teve macros com estes nomes, o respectivo conteúdo pode ser modificado pelo vírus de macro.

    - ou -
  • Aparecem mensagens invulgares ou inesperadas quando abre um documento ou modelo.
notas
  • No Word 2001 para Mac, pode definir a opção de Protecção contra vírus de macro (no menu Editar , clique em Preferências e, em seguida, clique no separador Geral ) que foi concebido para notificá-lo se abrir um ficheiro que contém macros, independentemente de o fazer as macros. Word X para Mac, pode definir a opção de Protecção contra vírus de macro clicando em Preferências no menu do Word , clicando no separador Geral e, em seguida, clicando na opção de Protecção contra vírus de macro para o activar ou desactivar. Word 2004 para Mac, pode definir a opção de Protecção contra vírus de macro clicando em Preferências no menu do Word , clicando no separador segurança e, em seguida, clicando na opção de Protecção contra vírus de macro para o activar ou desactivar. Para obter uma solução permanente, tem de utilizar software antivírus especificamente concebido para detectar e prevenir vírus em macros.
  • O Word não procure vírus em macros ou remova quaisquer vírus em macros de documentos existentes e modelos. Avisa-lo apenas-se o documento que está a abrir contém macros. Em seguida, pode abrir o documento com as macros activas ou abri-lo com macros desactivadas. Não deverá abrir um documento com activa macros, a menos que seja absolutamente-se de que o documento contém sem vírus em macros prejudiciais.
  • Programas antivírus de outros fornecedores devem ser actualizados frequentemente seja eficaz. Contacte o fornecedor para obter informações sobre a actualização.
  • Disinfectant, um utilitário de anti-vírus freeware para Mac OS 9 e versões anteriores, não ajuda a proteger contra vírus de macros. Desenvolvimento no programa Disinfectant foi interrompido. A versão final do Disinfectant é a versão 3.7.1.

    Para ligações a software antivírus actualizado, visite as ligações na secção seguinte. AntiVirus ?s Norton, Symantec e Sophos, criados para o Mac OS X, irá verificar vírus de macro.

Instalar um programa antivírus

Para obter uma solução a longo prazo para vírus em macros, instale software antivírus especificamente concebido para detectar vírus de macros. Para obter informações adicionais sobre fornecedores de software anti-vírus, incluindo software capaz de detectar e impedir infecções de vírus em macros, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
49500Lista de fornecedores de software antivírus
Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

O que fazer quando pensa que o computador poderá ter um vírus de macro

Utilize os seguintes métodos forma soluções temporárias quando pensa que o computador podem ter um vírus em macros.

Método 1: Desactivar as macros e copiar o texto para um novo documento

Se não tiver nenhum dos sintomas descritos anteriormente neste artigo, mas não pretende ser afectado por um vírus de macro, mantenha premida a tecla SHIFT quando abre um ficheiro pode estar infectado por um vírus em macros. Premindo a tecla SHIFT impede macros automáticas do Word a execução; se existir um vírus em macros, não é carregado.

Método 2: Eliminar a macro e recuperar o documento

Se detectar os sintomas descritos anteriormente neste artigo ou suspeite que tem um vírus em macros que não é descrito neste artigo, siga estes passos para eliminar a macro suspeita e corrigir documento afectado.

Nota Esta é apenas uma solução temporária; porque estão a ser criadas novas macros, estes passos poderão não funcionar em novas macros.
  1. Feche o Word e mova o modelo normal para o ambiente de trabalho.
  2. Efectue uma cópia de um ficheiro afectado.
  3. Abra o Word. No menu ficheiro , clique em Abrir .
  4. Navegue para a pasta que contém o ficheiro afectado.
  5. Clique para seleccionar o ficheiro afectado.
  6. Prima e mantenha premida a tecla SHIFT e clique em Abrir . Mantenha a tecla a tecla SHIFT até que o ficheiro afectado está aberto no Word.

    Nota Mantendo a tecla SHIFT enquanto abre um ficheiro impede macros automáticas do Word a execução.
  7. Para eliminar uma macro suspeita, utilize os seguintes passos:
    1. No menu Ferramentas , aponte para macro e, em seguida, clique em macros .
    2. No Macros no menu de contexto, seleccione todos os modelos de Active Directory e documentos .
    3. Seleccione a macro suspeita e, em seguida, clique em Eliminar . Clique em Sim quando lhe for perguntado se pretende eliminar a macro.
    4. Repita o passo c para todas as macros suspeitas.
    5. Clique em ' Cancelar ' para fechar a caixa de diálogo macro .
  8. Para recuperar o texto de um documento infectado, siga estes passos:
    1. Seleccione todo o documento premindo COMMAND + A ou clicando em Seleccionar tudo no menu Editar .
    2. Elimine a última marca de parágrafo do documento a partir da selecção premindo SHIFT+seta para a esquerda.
    3. No menu Editar , clique em Copiar .
    4. No menu ficheiro , clique em Novo . Seleccione o modelo que pretende utilizar e, em seguida, clique em OK .
    5. No menu Editar , clique em Colar .
    6. Repita o passo 7 para garantir que a macro que contenha o vírus não foi replicado.
    7. Guarde o documento.
  9. Repita estes passos para qualquer documento que suspeita pode conter um vírus de macro.
Nota Se o método 2 não funcionar, tente o método 3.

Método 3: Utilizar o organizador para limpar temporariamente um vírus em macros

Utilize o organizador para limpar o vírus em macros. Tenha em atenção que se abrir outros ficheiros depois de abrir o ficheiro infectado, estes ficheiros provavelmente estão infectados bem.

Para remover o vírus do modelo normal, siga estes passos:
  1. Feche todos os documentos. Se abrir um documento infectado, pode facilmente re-infect o modelo normal.
  2. No menu Ferramentas , clique em modelos e suplementos e, em seguida, clique no botão Organizador .
  3. Clique no separador Itens do projecto de macro e, em seguida, mudar o nome ou eliminar todas as seguintes macros:
    • NewMacros
    • AutoClose
    • Execução automática
    • AutoOpen
    • FileExit
    • FicheiroNovo
    • FileOpen
    • FileSave
    • FileSaveAs
    • Macros
    • ToolsMacro
  4. Clique em Fechar .
  5. Prima e mantenha premida a tecla SHIFT enquanto clica em Guardar tudo no menu ficheiro para guardar o modelo.
para remover um vírus em macros de um documento infectado:

Se um ficheiro infectado, utilize o mesmo método como nos passos 1 a 5, mas remover as macros do modelo normal e também do documento (modelo) enquanto o organizador infectado. Quando tiver terminado, prima e mantenha a tecla SHIFT enquanto faz clique em Guardar tudo no menu ficheiro e, em seguida, mover para o seguinte ficheiro. Tenha em consideração que sempre que abrir um ficheiro infectado, infecta o modelo normal, pelo que terá de remover repetidamente as macros do modelo normal.

Método 4: Inserir o ficheiro infectado num novo documento

Este método é particularmente útil com o vírus de macro "CAP", que remove a macro e Personalizar no menu ' Ferramentas '.

Nota Nesta situação, modelos e suplementos no menu Ferramentas poderão não funcionar.
  1. Feche o Word e mova o modelo normal ao ambiente de trabalho.
  2. Abra o Word e, em seguida, verifique se macro e personalizar aparecem no menu Ferramentas .
  3. Abra um novo documento. No menu Inserir , clique em ficheiro .
  4. Navegue para a pasta que contém o ficheiro afectado.
  5. Clique para seleccionar o ficheiro afectado.
  6. Prima e mantenha premida a tecla SHIFT e clique em Abrir . Continue a manter a tecla SHIFT até que o ficheiro afectado seja aberto no Word.
    Nota Mantendo a tecla SHIFT enquanto abre um ficheiro impede macros automáticas do Word em execução.
  7. Para verificar se existem macros no novo documento (nenhum deverá estar listado), aponte para macro no menu Ferramentas e, em seguida, clique em macros . Na Macros em janelas de pop-up lista, clique todos os modelos e documentos activos . Em Nome da macro , deverão estar listadas não macros. Clique em ' Cancelar ' .
  8. Guarde o ficheiro com um nome de ficheiro diferente.
  9. Elimine o ficheiro infectado.

Propriedades

Artigo: 291824 - Última revisão: 31 de janeiro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office X Standard Edition para Macintosh
  • Microsoft Office 2001 para Macintosh
  • Microsoft Office Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Macintosh
Palavras-chave: 
kbmt kbinfo KB291824 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 291824

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com