Проблемы
Рассмотрим следующий сценарий.
-
Вы установили накопительное обновление 1 для SQL Server 2008 R2 с пакетом обновления 1 (SP1) или более поздних обновлений, установленных на компьютере, для которого установлен японский язык.
-
Кодовая страница Windows (кодовая страница ANSI) содержит полуширинные символы на компьютере.
-
Отчет экспортируется в формат PDF, а выбранный шрифт имеет полную ширину символа ± (плюс-минус).
В этом случае вы можете столкнуться с одной или несколькими из указанных ниже проблем в созданном PDF-файле.
-
После апострофов есть лишние пробелы.
-
Текст перед символами денежных знаков перекрывает знаки доллара.
-
Некоторые специальные символы вызывают проблемы с пробелами.
Примечание. Эта проблема также возникает в SQL Server 2012 и SQL Server 2014.
Причина
Эта проблема возникает из-за неправильного изменения Unicode, так как SQL Server 2008 R2 SP2 CU1.
Решение
Эта проблема впервые устранена в следующем накопительном обновлении SQL Server.
Накопительное обновление 4 для SQL Server 2014 /en-us/help/2999197
Накопительное обновление 2 для SQL Server 2012 SP2 /en-us/help/2983175
Накопительное обновление 11 для SQL Server 2008 R2 с пакетом обновления 2 (SP2) /en-us/help/2926028
Все новые накопительные обновления для SQL Server содержат все исправления и все исправления для системы безопасности, которые были включены в предыдущий накопительный пакет обновления. Ознакомьтесь с самыми последними накопительными обновлениями для SQL Server.
Примечание.После установки этого накопительного обновления может возникнуть описанная ниже проблема. Если сервер отчетов находится в системе, для которой установлен японский язык, а ± (знак плюса) в отчете экспортирован в формат PDF, некоторые символы могут перекрываться. Чтобы обойти эту проблему, воспользуйтесь одним из описанных ниже методов.
-
Замените шрифтом, который использует Полуширинный символ "±".
-
Измените языковой стандарт сервера, на котором запущены службы SQL Server 2008 R2 Reporting Services или SQL Server 2012 Reporting Services на английский.
Статус
Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".