Transferring files by using SMB2 or SMB3 causes memory leak on a Windows computer

Article translations Article translations
Article ID: 2928360 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

When multiple users repeatedly transfer files with explicit credentials on a computer that is running Windows 8.1, Windows Server 2012 R2, Windows 8 or Windows Server 2012 by using Server Message Block version 2 (SMB2) or SMB3 protocol, it will cause a memory leak, and then the nonpaged pool memory will be exhausted.

Cause

When an SMB2 or an SMB3 session has explicit credentials, it will hold a reference to the credential object. However, currently the cleanup for the session entry does not remove the reference. Therefore, the credential object becomes leaked.

Resolution

To resolve this issue for Windows 8.1 and Windows Server 2012 R2, install update 2919355.
To resolve this issue for Windows 8 and Windows Server 2012, install the hotfix that is described in this article.

Update information for Windows 8.1 and Windows Server 2012 R2

For more information about how to obtain update 2919355, click the following article number to view the article in the Microsoft Knowledge Base:
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Hotfix information for Windows 8 or Windows Server 2012

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following:
  • Windows 8
  • Windows Server 2012

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 8 and Windows Server 2012 file information and notes

Collapse this imageExpand this image
assets folding start collapsed
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys6.2.9200.20926304,64023-Jan-201404:06x86
Collapse this imageExpand this image
assets folding end collapsed
For all supported x64-based versions of Windows 8 and Windows Server 2012
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys6.2.9200.20927362,49627-Jan-201404:32x64
Collapse this imageExpand this image
assets folding end collapsed
Collapse this imageExpand this image
assets folding end collapsed

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Additional file information

Additional file information for Windows 8 and Windows Server 2012

Collapse this imageExpand this image
assets folding start collapsed
Additional files for all supported x86-based versions of Windows 8
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File propertyValue
File nameUpdate.mum
File versionNot applicable
File size1,594
Date (UTC)27-Jan-2014
Time (UTC)13:21
PlatformNot applicable
File nameX86_f1c1e156d78927fc1c8890a759444bc7_31bf3856ad364e35_6.2.9200.20927_none_464dba6979f89d43.manifest
File versionNot applicable
File size698
Date (UTC)27-Jan-2014
Time (UTC)13:21
PlatformNot applicable
File nameX86_microsoft-windows-smbminirdr_31bf3856ad364e35_6.2.9200.20927_none_7d09ffc53b6e69d0.manifest
File versionNot applicable
File size57,195
Date (UTC)27-Jan-2014
Time (UTC)02:14
PlatformNot applicable
Collapse this imageExpand this image
assets folding end collapsed
Additional files for all supported x64-based versions of Windows 8 and Windows Server 2012
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File propertyValue
File nameAmd64_ca5a725ffb20f96742b7cecdf26903b9_31bf3856ad364e35_6.2.9200.20927_none_9739df9b36080055.manifest
File versionNot applicable
File size702
Date (UTC)27-Jan-2014
Time (UTC)13:22
PlatformNot applicable
File nameAmd64_microsoft-windows-smbminirdr_31bf3856ad364e35_6.2.9200.20927_none_d9289b48f3cbdb06.manifest
File versionNot applicable
File size57,199
Date (UTC)27-Jan-2014
Time (UTC)06:23
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,602
Date (UTC)27-Jan-2014
Time (UTC)13:22
PlatformNot applicable
Collapse this imageExpand this image
assets folding end collapsed
Collapse this imageExpand this image
assets folding end collapsed

References

See the terminology Microsoft uses to describe software updates for more information.

Properties

Article ID: 2928360 - Last Review: April 11, 2014 - Revision: 4.2
Applies to
  • Windows 8.1 Enterprise
  • Windows 8.1
  • Windows 8.1 Pro
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 R2 Essentials
  • Windows Server 2012 R2 Foundation
  • Windows Server 2012 R2 Standard
  • Windows 8 Enterprise
  • Windows 8 Pro
  • Windows 8
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseinter kbsurveynew KB2928360

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com