Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

You have a server that is running Windows Server 2008 R2 Service Pack 1 (SP1). When you use Windows PowerShell scripts to monitor Active Directory replication status across domain controllers through a Windows Management Instrumentation (WMI) query that uses a specific class on a high frequency, the scripts stop working after a short period.

Additionally, when this issue occurs, other WMI queries may fail. Therefore, other monitoring scripts may break.

Cause

This issue occurs because the WMI query uses a specific class that does not release resources correctly, and this causes a memory leak.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may be prompted to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Windows Server 2008 R2 file information notesImportant Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Replprov.dll

6.1.7601.22619

67,072

07-Mar-2014

02:38

x64

Replprov.mof

Not applicable

18,236

20-Nov-2010

04:05

Not applicable


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684
Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File property

Value

File name

Amd64_32ae18b49b6574220f61ac550a46e9f9_31bf3856ad364e35_6.1.7601.22619_none_dcf5e85a9499e8ba.manifest

File version

Not applicable

File size

730

Date (UTC)

07-Mar-2014

Time (UTC)

08:33

Platform

Not applicable

File name

Amd64_microsoft-windows-a..replicationprovider_31bf3856ad364e35_6.1.7601.22619_none_7f03d41419251aab.manifest

File version

Not applicable

File size

11,116

Date (UTC)

07-Mar-2014

Time (UTC)

05:41

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

1,706

Date (UTC)

07-Mar-2014

Time (UTC)

08:33

Platform

Not applicable


Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×