You cannot enable bidirectional support after you upgrade to Windows 8.1 or Windows Server 2012 R2

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Article ID: 2934887 - View products that this article applies to.
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Symptoms

Consider the following scenario:

  • You have a computer that is running Windows RT, Windows 8, or Windows Server 2012.
  • You connect a printer to the computer through a USB or WSD port, and then you install the printer driver on the computer.
  • You turn off or disconnect the printer, and then you upgrade the computer to Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2.
  • You turn on and reconnect the printer to the computer.
In this scenario, you may encounter one of the following issues:

  • The Enable bidirectional support check box under the Ports tab of the printer properties is disabled and appears dimmed.
  • When you try to print something, a notification in the printer application shows that the bidirectional support is turned off.

Cause

This issue occurs because the language monitor is not associated correctly with the printer driver.

Resolution

If you have upgraded from Windows RT, Windows 8, or Windows Server 2012 to Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2 and you encounter one of these issues, you have to use one of the workarounds in the "Resolution" section in KB 2909960. For more information about the workarounds in the "Resolution" section in KB 2909960, click the following article number to view the article in the Microsoft Knowledge Base:

2909960 Printer port settings are not migrated after upgrading to Windows 8.1
If you have not upgraded to Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2, upgrade the computer by using a Windows image that contains update 2919355 that was released on April 8, 2014. For more information this update rollup package, click the following article number to view the article in the Microsoft Knowledge Base:  
2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 2934887 - Last Review: April 8, 2014 - Revision: 1.0
Applies to
  • Windows 8.1 Enterprise
  • Windows 8.1 Pro
  • Windows 8.1
  • Windows RT 8.1
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 R2 Essentials
  • Windows Server 2012 R2 Foundation
  • Windows Server 2012 R2 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2934887

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