COMMENT FAIRE : Concevoir et préparer une liste d'adresses de publipostage dans Word 2002

Traductions disponibles Traductions disponibles
Numéro d'article: 294688 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F294688
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article décrit les formats acceptables pour une liste d'adresses de publipostage et contient des suggestions et des questions qu'il serait judicieux de vous poser lorsque vous créez une liste d'adresses.




CONCEPTION D'UNE SOURCE DE DONNÉES : Dans Microsoft Word, vous pouvez créer une nouvelle liste d'adresses au sein de l'Assistant Fusion et publipostage. Lorsque vous choisissez " Étape 3 : Sélection des destinataires " dans l'Assistant, l'option Saisie d'une nouvelle liste vous est proposée. Cette option vous permet de créer votre liste d'adresses.

Vous pouvez aussi créer une liste d'adresses à partir d'un tableau Word. Vous pouvez également utiliser n'importe quel format de type base de données, comme un fichier texte dans lequel les champs sont séparés par des virgules ou des tabulations et les enregistrements par des marques de paragraphe.

Dans une liste d'adresses, chaque catégorie d'informations, comme le nom, est appelée un champ. L'ensemble des champs qui constituent les informations sur une personne est appelé un enregistrement.


Éléments à prendre en considération lors de la conception d'une source de données

Avant de créer une liste d'adresses, vous devez décider des informations que vous voulez inclure et du mode d'utilisation de ces informations, puis concevoir la base de données. Cela vous permettra d'économiser du temps et du travail par la suite.


Certains enregistrements contiennent-ils plus d'informations que d'autres ?

Certains de vos enregistrements de données peuvent contenir plus d'informations que d'autres. Par exemple, certaines entrées peuvent contenir le nom d'une entreprise, l'intitulé d'un service et jusqu'à trois lignes pour l'adresse. D'autres entrées peuvent ne contenir qu'un nom, le numéro et le nom de la rue sur une deuxième ligne et une troisième ligne avec le code postal et la ville.

Dans une liste d'adresses, tous les enregistrements de données doivent contenir le même nombre de champs de données. Créez votre liste d'adresses de façon à ce qu'elle ait suffisamment de champs de données pour correspondre à l'enregistrement contenant le plus de champs. Vous n'avez pas besoin de renseigner tous les champs d'un enregistrement de données ; vous pouvez laisser certains champs vides. Word supprime automatiquement les enregistrements vides.


Envisagez-vous de trier les données ?

Si vous prévoyez de trier vos données, vous devez les disposer de façon à pouvoir les trier sur la base de certains critères. Le code postal et la ville, par exemple, sont généralement imprimés sur la même ligne de l'étiquette de publipostage, c'est pourquoi il peut être judicieux d'inclure toutes ces informations dans le même champ. Toutefois, si vous incluez toutes ces informations dans le même champ, il vous sera impossible de trier vos enregistrements par code postal ou par ville. Dans ce cas, il convient de séparer chacun des éléments d'information et de les inclure dans des champs distincts.

Cela est également le cas si vous souhaitez trier vos données par noms de destinataire. Dans ce cas, vous devez séparer les noms et les prénoms et les inclure dans des champs distincts.


Souhaitez-vous utiliser un code-barres POSTNET ?

Pour accélérer la remise du courrier aux États-Unis, vous pouvez imprimer un code-barres POSTNET sur les étiquettes et les enveloppes de publipostage. Pour pouvoir utiliser un code-barres, le code postal et l'adresse postale du destinataire (numéro et nom de rue ou numéro de boîte postale) doivent être dans leurs propres champs de données, séparément de tous les autres éléments de l'adresse.


Comptez-vous utiliser les informations contenues dans un champ particulier de différentes manières ?

Dans une lettre type, la première ligne de l'adresse du destinataire contient généralement une civilité et le nom complet du destinataire. La formule de politesse peut contenir uniquement la civilité et le nom ou simplement le prénom. Si vous placez le titre, le prénom et le nom dans des champs distincts, vous pouvez utiliser le même champ pour imprimer le nom à la fois dans l'adresse et dans la formule de politesse. En variante, vous pouvez utiliser un champ pour le titre et le nom complets dans l'adresse du destinataire et un deuxième champ pour le titre et le nom dans la formule de politesse.


Comptez-vous utiliser la liste d'adresses pour plusieurs documents fusionnés ?

Vous pouvez fusionner une liste d'adresses spécifique avec n'importe quels type et nombre de documents principaux. Lors de la préparation d'une liste d'adresses pour imprimer des lettres types, concevez les informations relatives aux destinataires de façon à pouvoir utiliser la même source de données pour imprimer les adresses sur des étiquettes ou des enveloppes de publipostage.


Combien de champs (éléments d'information) avez-vous pour chaque enregistrement (la collection des éléments d'information) ?

Si vous n'avez que quelques éléments d'information pour chaque enregistrement, vous pouvez utiliser l'Assistant Fusion et publipostage (dans le menu Outils) de Word. Cela vous permet d'accéder à la boîte de dialogue Destinataires du publipostage pour préparer votre liste d'adresses.

La boîte de dialogue Destinataires du publipostage est limitée à 255 champs. Si votre nombre de champs dépasse cette valeur, il n'est pas recommandé d'utiliser la boîte de dialogue Destinataires du publipostage. Au lieu de cela, créez la liste d'adresses sous la forme d'un fichier texte délimité par des tabulations ou d'un fichier texte délimité par des virgules dans une feuille de calcul Microsoft Excel ou dans une base de données Microsoft Access.


Organisation des données en tableaux ou paragraphes

Lorsque vous organisez vos données sous la forme d'un tableau, celui-ci devrait contenir une colonne pour chaque nom de champ que vous voulez utiliser. La première ligne du tableau est la ligne d'en-tête, et chaque ligne suivante contient les informations pour un enregistrement de données.

Même s'il se peut qu'il y ait des retours de ligne dans chaque cellule, le texte sera imprimé correctement. Vous trouverez ci-dessous une liste d'éléments à prendre en compte lorsque vous utilisez une liste d'adresses existante comme source de données.
  • À moins que vous n'utilisiez une source d'en-tête distincte, assurez-vous que l'enregistrement d'en-tête est le premier enregistrement (la première ligne de cellules) dans la liste d'adresses. Vérifiez qu'il n'y a pas d'espaces, de texte ou d'interlignes avant l'enregistrement d'en-tête. L'enregistrement d'en-tête ne doit contenir aucun espace. Chaque champ d'en-tête est limité à 40 caractères et doit commencer par une lettre. Chaque caractère suivant doit être une lettre, un chiffre ou le caractère de soulignement. Chaque champ d'en-tête doit être renseigné.
  • Assurez-vous que le nombre de champs de données dans chaque enregistrement de données est égal au nombre de noms de champs dans l'enregistrement d'en-tête. Si un enregistrement ne contient pas d'informations pour un champ donné, laissez la cellule vide pour ce champ.
  • Disposez les informations dans les enregistrements de données dans le même ordre, de gauche à droite, que les noms de champs correspondants dans l'enregistrement d'en-tête. L'ordre de vos colonnes dans la lite d'adresses importe peu, puisque vous contrôlerez l'emplacement de vos données dans le document principal de publipostage.

Conception d'une liste d'adresses contenant un grand nombre de champs

La boîte de dialogue Destinataires du publipostage crée une liste d'adresses (.mdb) pour le fichier de données. Dans Microsoft Word 2002, le nombre maximum de champs pour la boîte de dialogue Destinataires du publipostage est de 255.

Pour créer une nouvelle base de données à partir de la boîte de dialogue Destinataires du publipostage, procédez comme suit :
  1. Dans le menu Outils, pointez sur Lettres et publipostage, puis cliquez sur Assistant Fusion et publipostage. Suivez les étapes de l'Assistant Fusion et publipostage jusqu'à " Étape 3 : Sélection des destinataires ". C'est ici que vous allez préparer votre liste d'adresses.
  2. Cliquez sur Saisie d'une nouvelle liste.
  3. Cliquez sur Créer. La boîte de dialogue Nouvelle liste d'adresses s'affiche à l'écran. Dans cette boîte de dialogue, saisissez les informations d'adressage pour chaque enregistrement. S'il n'y a aucune information prévue pour un champ particulier, laissez la zone correspondante vide. Par défaut, Word ignore les champs vides, et le publipostage ne sera donc pas affecté par la présence d'entrées vides dans le formulaire de données. Les informations contenues dans chaque formulaire constituent un enregistrement de données.
  4. Après avoir saisi les informations correspondant à un enregistrement, cliquez sur Nouvelle entrée pour passer à l'enregistrement suivant. Pour supprimer un enregistrement, cliquez sur Supprimer l'entrée. Pour rechercher un enregistrement spécifique, cliquez sur Rechercher l'entrée. Pour filtrer ou trier vos enregistrements, cliquez sur Filtre et tri.

    REMARQUE : Si vous souhaitez personnaliser votre liste d'adresses, cliquez sur Personnaliser. Dans la boîte de dialogue Personnaliser la liste d'adresses, vous pouvez ajouter, supprimer, renommer et réorganiser les champs de publipostage.
  5. Dans la boîte de dialogue Nouvelle liste d'adresses, cliquez sur Fermer.
  6. Dans la boîte de dialogue Enregistrer la liste d'adresses, dans la zone Nom du fichier, tapez le nom que vous souhaitez donner à votre source de données, puis cliquez sur Enregistrer.
  7. Dans la boîte de dialogue Destinataires du publipostage, apportez les modifications souhaitées, puis cliquez sur OK.
Vous venez de créer une nouvelle liste d'adresses et vous êtes prêt à passer à l'étape suivante de l'Assistant Fusion et publipostage, qui consiste à rédiger votre lettre.

Pour plus d'informations sur la création d'une lettre type, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
294683 WD2002 : Procédure pour créer des lettres types à l'aide de la fonctionnalité Fusion et publipostage
Si vous avez besoin de plus de 255 champs de données dans votre liste d'adresses, Word ne peut pas organiser les données à partir de la boîte de dialogue Destinataires du publipostage. Au lieu de cela, vous pouvez préparer vos informations sous la forme de paragraphes séparés dans un document Word. L'enregistrement d'en-tête et chaque enregistrement de données doit se terminer par une marque de paragraphe qui constitue le séparateur d'enregistrements. Chaque nom de champ dans l'enregistrement d'en-tête et chaque champ dans l'enregistrement de données doivent être séparés par un caractère de tabulation ou une virgule, qui constitue le séparateur de champs de données. Si l'un des champs de données est vide, vous devez inclure un séparateur de champs pour identifier le champ vide.

Si vous utilisez une liste d'adresses provenant d'une base de données ou d'un tableur, vous pouvez exporter ces données au format de texte ASCII, séparées par des virgules ou des tabulations. Vous pouvez aussi avoir la possibilité de rattacher la base de données en utilisant la connectivité de bases de données ouvertes (ODBC), l'échange dynamique de données (EED) ou un convertisseur. Si vous exportez vos données au format ASCII et que Word ne reconnaît pas automatiquement les séparateurs de champs et d'enregistrements, Word vous invite à sélectionner les séparateurs la première fois que vous utilisez la liste d'adresses. Lorsque vous préparez une liste d'adresses dans ce format sous Word, il convient d'utiliser une marque de paragraphe pour délimiter les enregistrements de données et un caractère de tabulation ou une virgule pour délimiter les champs de données.

Outre les règles générales à suivre pour organiser une liste d'adresses, les règles ci-dessous s'appliquent également aux listes d'adresses préparées au format texte standard :
  • Appuyez sur ENTRÉE pour terminer chaque enregistrement de données avec une marque de paragraphe. Assurez-vous qu'il n'y a pas de marques de paragraphe supplémentaires entre ou après les enregistrements de données. Word interprète les paragraphes vides (lignes vides) comme des enregistrements vides.
  • Utilisez le même séparateur de champs dans l'enregistrement d'en-tête et dans l'enregistrement de données. Par exemple, vous ne pouvez pas utiliser des caractères de tabulation dans l'enregistrement d'en-tête et des virgules dans les enregistrements de données. Le texte dans les champs de données pouvant comprendre des virgules, il est préférable d'utiliser des caractères de tabulation.
  • Si un enregistrement de données ne contient pas d'informations pour un champ de donnés spécifique, insérez deux caractères de tabulation ou deux virgules pour indiquer le champ vide. N'insérez pas un deuxième séparateur de champs si le champ de données est le dernier dans l'enregistrement de données.
  • Délimitez le champ de données par des guillemets s'il contient l'un des caractères suivants :
    • Un caractère de tabulation ou une virgule, si vous utilisez ce même caractère pour séparer les champs
    • Un saut de ligne ou une marque de paragraphe
    • Un caractère que vous avez spécifié comme séparateur de listes dans la section Paramètres régionaux du Panneau de configuration dans Microsoft Windows
  • Si les informations dans un champ de données contiennent des guillemets (" "), tapez des doubles guillemets ("" ""). Lors de la fusion des informations provenant du champ de données, une seule paire de guillemets sera imprimée.

Détermination de l'utilisation d'une source d'en-tête distincte

Dans la plupart des cas, il est commode de faire figurer le nom de champ pour chaque champ de données dans la première ligne, ou premier enregistrement, de la liste d'adresses. Toutefois, il peut être préférable de faire figurer les noms de champs dans une source d'en-tête distincte pour les raisons suivantes :
  • Vous pouvez utiliser la même ligne d'en-tête et les mêmes noms de champs pour fusionner les données provenant de sources différentes sans avoir à répéter ou à modifier la ligne d'en-tête dans chaque liste d'adresses ni à modifier les noms des champs de fusion dans le document principal.
  • Parfois, une liste d'adresses provenant d'un autre programme ne comprend pas d'enregistrement d'en-tête ou les noms de champs dans l'enregistrement d'en-tête ne correspondent pas aux noms des champs de fusion dans votre document principal. Si vous ne pouvez pas modifier ou ajouter un enregistrement d'en-tête dans la liste d'adresses (parce que la liste est en lecture seule, par exemple), vous pouvez utiliser une source d'en-tête distincte contenant les noms de champs que vous spécifiez.

Ajout du bouton " Ouvrir la source d'en-tête de publipostage "

Si vous utilisez une source d'en-tête distincte, vous devez spécifier à la fois la source d'en-tête et la liste d'adresses avant de pouvoir fusionner le document principal avec la liste d'adresses.

Pour utiliser une source d'en-tête dans un publipostage Word, vous devez ajouter le bouton Ouvrir la source d'en-tête de publipostage à la barre d'outils Fusion et publipostage. Pour cela, procédez comme suit :
  1. Dans le menu Affichage, pointez sur Barre d'outils, puis cliquez sur Fusion et publipostage. La barre d'outils Fusion et publipostage s'affiche.
  2. Dans le menu Outils, cliquez sur Personnaliser.
  3. Dans l'onglet Commandes, cliquez sur Toutes les commandes dans la liste Catégories.
  4. Dans la liste Commandes, sélectionnez et faites glisser FusionOuvrirSourceEnTête dans la barre d'outils Fusion et publipostage.
  5. Cliquez sur Fermer pour quitter la boîte de dialogue Personnaliser.

Conception d'une source d'en-tête

Lorsque vous spécifiez une source d'en-tête, pensez à respecter les règles suivantes :
  • Le nombre de noms de champs dans la source d'en-tête doit être égal au nombre de champs de données dans la liste d'adresses.
  • Les noms de champs dans la source d'en-tête doivent figurer dans le même ordre que les informations correspondantes dans la liste d'adresses.
  • Utilisez le même séparateur de champs (caractère de tabulation ou virgule) pour la source d'en-tête et la liste d'adresses.
  • Si votre document principal contient déjà des champs de fusion, utilisez les mêmes champs de fusion dans votre source d'en-tête. Si vous ne le faites pas, vous devrez remplacer les champs de fusion dans le document principal pour qu'ils correspondent aux noms de champs dans la source d'en-tête. Après avoir spécifié une source d'en-tête, vous pouvez la modifier exactement comme vous modifiez la liste d'adresses.

Utilisation d'un enregistrement d'en-tête provenant d'une autre liste d'adresses

Si vous avez une liste d'adresses qui contient un enregistrement d'en-tête, vous pouvez l'utiliser comme source d'en-tête. Par exemple, si vous décomposez votre liste d'adresses en plusieurs documents, vous pouvez spécifier les noms de champs dans l'enregistrement d'en-tête de la première liste d'adresses. Lorsque vous effectuez une fusion à partir d'autres listes d'adresses qui n'ont pas d'enregistrement d'en-tête, spécifiez la première liste d'adresses comme source d'en-tête. Ensuite, spécifiez tour à tour chacune des listes d'adresses restantes.

Word ignore les enregistrements de données provenant de la première liste d'adresses et utilise uniquement l'enregistrement d'en-tête.


Types de données utilisables avec la fonctionnalité de fusion et publipostage

Vous pouvez fusionner pratiquement n'importe quel type d'informations provenant d'une source de donnés de publipostage, y compris :
  • N'importe quels textes ou chiffres
  • Les graphiques pour lesquels vous avez installé un filtre d'importation graphique

    Pour plus d'informations sur les filtres d'importation graphiques fournis avec Word, cliquez sur Aide sur Microsoft Word dans le menu ? (Aide), tapez Types de fichiers graphiques utilisables dans Word dans le Compagnon Office ou l'Aide Intuitive, puis cliquez sur Rechercher pour afficher les rubriques correspondantes.

    Pour plus d'informations sur les procédures à suivre pour installer des filtres d'importation graphique et des convertisseurs de fichiers, cliquez sur Aide sur Microsoft Word dans le menu ? (Aide), tapez Installation ou suppression de composants individuels dans le Compagnon Office ou l'Aide Intuitive, puis cliquez sur Recherche pour afficher les rubriques correspondantes.

    REMARQUE : Si les graphiques sont contenus dans une liste d'adresses provenant d'un programme autre que Word, vous devez convertir le fichier en utilisant un convertisseur de formats de fichiers.
  • Les objets créés dans des programmes prenant en charge la liaison et l'imbrication d'objets (OLE) tels que l'Éditeur d'équations
  • Les champs Word qui affichent un résultat, comme un champ {=} (formule)
Pour ajouter des informations autres que du texte ou des chiffres à une liste d'adresses que vous avez créée dans Word, vous devez afficher la liste d'adresses dans une fenêtre de document. Pour cela, ouvrez la source d'adresses dans Microsoft Word à l'aide de la commande Ouvrir du menu Fichier. Ou bien, ouvrez la liste d'adresses dans le programme d'origine où a été créé le document. Ensuite, insérez les informations dans la colonne et la ligne correspondantes du tableau de liste d'adresses.


Types de données non utilisables

Vous ne pouvez pas fusionner du texte ou des graphiques qui sont contenus dans un cadre dans la liste d'adresses. Toutefois, vous pouvez placer les champs de fusion à l'intérieur de cadres. Lorsque vous fusionnez les documents, le texte et les graphiques de la liste d'adresses sont placés dans le cadre.


RÉFÉRENCES : Pour plus d'informations sur la fusion et le publipostage dans Word, cliquez sur Aide sur Microsoft Word dans le menu ? (Aide), tapez Présentation du publipostage dans le Compagnon Office ou l'Aide Intuitive, puis cliquez sur Rechercher pour afficher les rubriques correspondantes.

Propriétés

Numéro d'article: 294688 - Dernière mise à jour: dimanche 15 mai 2011 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
Mots-clés : 
kbdta kbhowto kbhowtomaster kbmerge KB294688
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com