Разработка и настройка списка адресов слияния в Word

Переводы статьи Переводы статьи
Код статьи: 294688 - Vizualiza?i produsele pentru care se aplic? acest articol.
Для Microsoft Word 2000 версии этой статьи см. 212322.
Развернуть все | Свернуть все

В этой статье

Аннотация

В этой статье допустимых форматов для список адресов слияния и включает предложения и вопросы, которые Чтобы задать себе, как создать список адресов.

Создание источника данных

В Microsoft Word, можно создать новый список адресов в Мастер слияния. При выборе «Шаг 3: Выбор получателей» в мастере в Ввести новый список параметр доступен. Этот параметр создает свой адрес список.

Другой способ создания списка адресов, из таблицы Word. Вы также можно использовать любой формат базы данных, такой как текстовый файл, в котором поля разделенных запятыми или символами табуляции, а записи разделяются абзаца метки.

В список адресов каждая категория данных, например Фамилия, называется полем. Набор полей, составляющих сведения примерно один человек будет называться записью.

Что следует учесть при создании источника данных

Перед созданием списка адресов, определить, какую информацию вы включить и как следует использовать эти сведения, а затем разработать базой данных. Это сохранит вам время и трудозатраты позже.

У некоторых записей больше информации, чем другие?

Некоторые записи данных может иметь больше информации, чем другие записи. Например некоторые операции могут иметь название организации, отдел Заголовок и до трех строк для адреса. Другие элементы могут иметь только имя, почтовый адрес одной строки и третья строка с Город, штат, и Почтовый индекс.

В списке адресов каждой записи данных должны иметь одинаковый количество полей данных. Создать список адресов, чтобы он имел достаточное количество данных поля должны соответствовать записи с наиболее поля. Не требуется Заполните все поля в записи данных; Некоторые поля можно оставить незаполненным. Word автоматически отключает пустые записи.

Вы планируете сортировки данных?

Если планируется сортировать данные, необходимо организовать их таким образом, можно сортировать данные, на основе определенных критериев. Например, Город, состояние, и Почтовый индекс обычно печатаются на одной строке почтовой наклейки, поэтому вы может потребоваться включить всю эту информацию в одном поле. При наличии все эти сведения в поле невозможно отсортировать записи на основе на состояние или почтового индекса. В этом случае следует отличать каждого фрагмента информацию в отдельные поля.

То же самое верно, если вы хотите сортировать данные по фамилии адресаты. В этом случае необходимо Разделите на отдельные имена и фамилии поля.

Будет использоваться информация в конкретном поле по-разному?

В бланке в первой строке внутри адреса обычно содержит обращение и полное имя адресата. Возможно обращение содержат только обращение и фамилию или только имя. Если вы поместить заголовок, имя и фамилию в отдельные поля, можно использовать одного поля для печати фамилии в адрес и приветствие. Кроме того, можно использовать одно поле для полного заголовка и имя в адрес и второе поле для названия и фамилии в Приветствие.

Список адресов будет использоваться для нескольких документов слияния?

Один адрес списка, можно объединить с любой тип и количество основных документов. При настройке списка адресов для печати писем, планирование адресат информации таким образом, можно использовать тот же источник данных для печати адресов в почтовые наклейки или конверты.

Сколько полей (порции информации) у каждой записи (коллекция порции информации)?

Если у вас есть несколько видов информации для каждой записи, можно с помощью мастера слияния (на Сервис меню) в Word. Это позволяет получить доступ к Получатели слияния диалоговое окно для настройки списка адресов.

Не существует ограничение в 255 полей Получатели слияния диалоговое окно. Если ваш номер поля превышает это значение, не Используйте слияние. Вместо этого воспользуйтесь одним из следующих:
  • Используйте Microsoft Excel в качестве источника данных. Максимальное количество полей данных в Excel листе — 256.
  • Использовать базу данных Microsoft Access данные источник.
  • Использовать текст с разделителями запятыми или с разделителями табуляцией текстового файла файл в качестве источника данных.
Снижает производительность слияния как число полей в Строка верхнего колонтитула увеличивается. Конфигурация на компьютере и доступных память может также ограничить число полей, добавляемых в данных документ.

Заголовок записи (строки) не может содержать пробелы. Каждый поле заголовка не более 40 знаков и должно начинаться с буквы. Каждый последующий символ должен быть буквой, число или знак подчеркивания. Все поля заголовка должно быть заполнено. Обратите внимание, что ограничения, описанные здесь, отличаются в некоторых языковых версий Microsoft Word.

Организация данных в таблицах или абзацев

При организации данных в таблице таблица должна содержать столбец для каждого поля имени, которую требуется использовать. Первая строка таблицы — Это строка названия; Каждая следующая строка содержит сведения о данных запись.

Несмотря на то, что текст могут переноситься в каждой ячейке, оно будет напечатано правильно. Ниже приведен список элементов, которые необходимо учитывать при использовании существующий список адресов как источник данных:
  • Если не используется отдельный заголовок источника убедитесь, что запись заголовка является первой записи (строка ячеек) в списке адресов. Убедитесь, что что есть пробелы, текст или пустые строки перед заголовком. В запись заголовка не может содержать пробелы. Каждый заголовок поля ограничена 40 символов и должно начинаться с буквы. Каждый последующий символ должен быть буквы, числа или символа подчеркивания. Необходимо заполнить все поля заголовка в.
  • Убедитесь в том, что число данных поля в каждой записи равно количеству имена полей в строке заголовков. Если запись Нет информации для определенного поля, оставьте ячейку для этого поля пустой.
  • Упорядочить данные в записи данных в том же порядок, слева направо, как соответствующие имена полей в строке заголовков. Порядок столбцов в списке адресов не имеет значения, так как вы будет контролировать расположение данных в основной документ слияния документ.

Создание списка адресов, который содержит много полей

В Слияние получателей диалоговое окно Создание списка адресов (.mdb) для файла данных. В Максимальное число полей для Microsoft Word Слияние получателей диалоговое окно является 255. для создания новой базы данных из Слияние получателей диалоговое окно поле, выполните следующие действия:
  1. Microsoft Word 2002

    На Сервис меню, нажмите кнопку Письма и рассылки, а затем нажмите кнопку Мастер слияния.

    Microsoft Office Word 2003

    На Сервис меню, нажмите кнопку Письма и рассылки, а затем нажмите кнопку Слияние.

    Microsoft Office Word 2007 и Word 2010

    На Рассылки Щелкните Начать слияние, а затем нажмите кнопку Пошаговый мастер слияния.

    Следуйте указаниям мастера слияния "шаг 3: Выбор Получатели». Это где Настройка списка адресов.
  2. Нажмите кнопку Ввести новый список.
  3. Нажмите кнопку Создать. В Новый список адресов Откроется диалоговое окно. В этом диалоговом окне введите адрес сведения для каждой записи. Если нет данных для определенного поля, Оставьте поле пустым. По умолчанию Word пропускает пустые поля слияния не влияние, если пустые записи в форме. Набор сведений в каждом формы составляют записи данных.
  4. После ввода сведений для записи, нажмите кнопку Новая запись для перехода к следующей записи. Чтобы удалить запись, нажмите кнопку Удалить запись. Для поиска конкретной записи, нажмите кнопку Найти запись. Чтобы отфильтровать или отсортировать записи, нажмите кнопку Фильтр и сортировка.

    Примечание Если вы хотите настроить список адресов, нажмите кнопку Настройка. В Настройка списка адресов диалоговое окно, можно добавить, удалить, переименовать и изменить порядок слияния поля.
  5. В Новый список адресов диалоговое окно, нажмите кнопку Закрыть.
  6. В Сохранение списка адресов изменить Имя файла Введите имя для присвоения источнику данных, и Нажмите кнопку Сохранить.
  7. В Получатели слияния диалоговое окно, вносить изменения, необходимо и нажмите кнопку ОК.
Создан новый адрес и готовы приступить к Следующий этап мастера слияния. Этот шаг является запись в буква.

Дополнительные сведения о способах создания письма щелкните следующий номер статьи базы знаний Майкрософт:
294683Использование слияния для создания писем в программе Microsoft Word 2002 и более поздних версиях Word
Если требуется более 255 полей данных в вашей список адресов, слова не могут организовывать данные из Слияние получателей диалоговое окно. Вместо этого можно настроить данные отдельно Слова абзацев документа. Необходимо завершить запись заголовка и каждой записи данных с помощью знака абзаца, который является разделитель записей данных. Имя каждого поля в запись заголовка и каждого поля в записи данных должны быть разделены вкладки знак или запятая, который является разделителем поля данных. Если какие-либо данные пустые поля, должен включать разделитель полей для определения пустых поле.

Если используется список адресов из базы данных или программу электронных таблиц, можно экспортировать данные в текстовый формат ASCII, разделенных запятыми или символами табуляции. Или можно присоединить базу данных с помощью ODBC, DDE или преобразователь. При экспорте данных в формате ASCII и Microsoft Word автоматически распознает поля и записи разделители, Word предлагается выбрать разделителей во время первого использования списка адресов. При можно настроить список адресов в этом формате в Word, следует использовать абзаца Пометить как разделитель записей данных и символ табуляции или запятыми данных Разделитель полей.

Помимо общих правил организации список адресов, действуют следующие правила для списков адресов, которые настроены как обычный текст:
  • Клавиши ВВОД в конце каждой записи данных с знак абзаца. Убедитесь в том, что существуют не лишние знаки абзацев между или после их записи. Word интерпретирует все пустые абзацы (пустые строки) как пустой записи.
  • Использовать же разделитель полей в записи заголовка и запись данных. Например нельзя использовать символы табуляции в заголовке запись и запятые в записи данных. Так как могут включать текст в поля данных запятые, предпочтительнее использовать символы табуляции.
  • Если запись данных содержит сведения для определенное поле данных, вставки двух знаков табуляции или две запятые для обозначения пустое поле. Не вставляйте второй разделитель полей, если поле данных последним в записи данных.
  • Заключите в кавычки поля данных, если поле данных содержит один из следующих символов:
    • Знак табуляции или запятыми, что при использовании символ для разделения полей
    • Разрыв строки или знака абзаца
    • Знак, заданный в качестве разделителя списка символ в международной части Панели управления Microsoft Windows
  • Если сведения в поле данных содержит кавычки (" "), дважды введите знаки (" "" "). Если данные из поля данных являются слияние, будут напечатаны только одну пару кавычек.

Решить, когда следует использовать отдельный заголовок источника

В большинстве случаев удобно укажите имя поля для каждого поля данных в первую строку или запись в списке адресов. Тем не менее вы можете Список имен полей в источнике отдельный заголовок для следующих причины для этого.
  • Можно использовать одинаковые имена строки и поля заголовка для слияния данные из различных источников без необходимости повторять или изменение строки заголовка Каждый список адресов или изменить имена полей слияния в основном документ.
  • Иногда нет списка адресов из другой программы включить запись заголовка или не совпадают имена полей в строке заголовков имена полей слияния в основной документ. Если не удается изменить или добавить заголовок записи в списке адресов (например, поскольку списка адресов доступен только для чтения) можно использовать отдельный исходный заголовок, содержащий поле, имена Укажите.

Добавление кнопки «Слияние Открытие источника заголовка»

Если используется отдельный заголовок источника, необходимо указать как источник заголовка и списка адресов, прежде чем можно объединить в новый документ в списке адресов.

Чтобы использовать источник заголовка в слияния в Word, можно необходимо добавить Открытие источника заголовка кнопки для вашего Слияние панель инструментов. Для этого выполните действия, соответствующие используемой версии Microsoft Word, на котором выполняется.
Word 2002 или Word 2003
  1. На Представление Выберите пункт Панели инструментов, а затем нажмите кнопку Слияние. В Слияние панель инструментов отображается.
  2. На Сервис меню, нажмите кнопку Настройка.
  3. На Команды флажок Все команды в Категории список.
  4. В Команды список, затем выберите и перетащите MailMergeOpenHeaderSource для вашего Слияние панель инструментов.
  5. Нажмите кнопку Закрыть Чтобы закрыть Настройка диалоговое окно.
Word 2007
Чтобы использовать источник заголовка в слияния в Word в Word 2007, необходимо добавить Открытие источника заголовка кнопки на панель быстрого доступа.
  1. В Word, нажмите кнопку Кнопка Microsoft Office.
  2. Нажмите кнопку Параметры Word.
  3. Нажмите кнопку Настройки.
  4. В Выбрать команды из диалоговое окно, нажмите кнопку Все команды.
  5. Нажмите кнопку Открытие источника заголовка, а затем нажмите кнопку Добавить.
  6. Нажмите кнопку ОК.
Word 2010


Использовать источник заголовка в слове слияния в Word 2007, добавьте кнопку Открыть источник заголовков на панель быстрого доступа.

  1. Выберите команду Параметры на вкладке файл .
  2. Выберите команду Настройка ленты.
  3. В списке выбрать команды иззамените Все командыЧасто используемые команды .
  4. Нажмите кнопку Открыть источник заголовкови нажмите кнопку Добавить.
    Примечание: может потребоваться добавить новую вкладку перед добавлением команды на ленте.
  5. Нажмите кнопку ОК.


Создание источника заголовка

При указании источника заголовка, следует помните следующие правила:
  • Число имен полей в источнике заголовка должно равняться число полей данных в списке адресов.
  • Имена полей в источнике заголовка должны быть перечислены в том же порядок соответствующих данных в списке адресов.
  • Использовать же разделитель полей (знак табуляции или запятая) для источника заголовка и списка адресов.
  • Если основной документ уже содержит поля слияния, те же поля слияния в источнике заголовка. Если этого не сделать, то необходимо Замена полей слияния в основной документ в соответствии с именами полей источник данных заголовка. После указания источника заголовка, его можно изменить так же, как Измените список адресов.

С помощью заголовка записи из другой список адресов

Если у вас есть список адресов, который содержит запись заголовка, вы можно использовать как источник заголовков. Например, если вы разбил на список адресов в нескольких документах можно указать имена полей в заголовке первый список адресов. При объединении из других списков адресов, которые не наличие записи заголовка, укажите первый список адресов в качестве источника заголовка. Затем Укажите, в свою очередь каждый из остальных списков адресов.

Word игнорирует данные записи из первого списка адресов и использует только заголовок запись.

Типы данных, которые можно использовать с слияния

Можно объединить практически любой тип информации из слияния источник данных, включая следующие:
  • Любой текст или числа
  • Графики, для которого установлен графический фильтр установлен


    Примечание Если графические объекты находятся в список адресов из программы Кроме Word необходимо преобразовать этот файл, используя формат файла преобразователь.
  • Объекты, созданные в программах, поддерживающих технологию связывания и внедрение объектов (OLE), такие как редактор формул
  • Полей Word, которые отображают результат, например, поле {=} (Формула)
Добавление данных текстовым или номера на адрес список, созданный в Microsoft Word, необходимо отобразить список адресов в документе с помощью окна Открыть команда Файл меню. Или открыть список адресов в исходной программы создан документ. Затем вставить данные в соответствующем столбце и Строка таблицы списка адресов.

Типы данных, нельзя использовать

Не удается объединить текст или рисунок в рамку в списке адресов. Тем не менее можно расположить поля слияния внутри фреймов. При объединять документы, текста и графики из списка адресов находится в рамке.

Свойства

Код статьи: 294688 - Последний отзыв: 7 января 2013 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Word 2010
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Ключевые слова: 
kbhowtomaster kbmerge kbmt KB294688 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке: 294688

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com