How to paste or insert Visio drawings into other Office programs

Article translations Article translations
Article ID: 296826 - View products that this article applies to.
This article was previously published under Q296826
Expand all | Collapse all

On This Page

INTRODUCTION

This article describes several methods that you can use to copy objects from Microsoft Visio drawings and paste them into other programs.

To copy objects from Visio to another program, use one of the following methods, depending on your situation.

Method 1: Use the Select by Type command or the Select Special command

In Microsoft Office Visio 2007, Microsoft Office Visio 2003, and in Microsoft Visio 2002, you can use the Select by Type command. In Microsoft Visio 2000, you can use Select Special command. To use the Select by Type command or the Select Special command, follow these steps:
  1. Start Visio, and then open your drawing.
  2. On the Edit menu in Visio 2007, Visio 2003 or in Visio 2002, click Select by Type. Alternatively, click Select Special in Visio 2000.

    In Visio 2010, on the Home tab, in the Editing group, click Select, and then click Select by Type.
  3. In the Select by Type dialog box or in the Select Special dialog box, perform one of the following steps:
    • Click Shape type. Then, click to select or click to clear one or more of the following check boxes:
      • Shapes
      • Groups
      • Guides
      • OLE objects
      • Metafiles
      • Bitmaps
      Additionally, the following shape type is available in Visio 2003:
      • Ink objects
    • Click Layer, and then click to select the check box next to the layer or layers that you want.
  4. Click OK.
  5. On the Edit menu, click Copy.

    In Visio 2010, on the Home tab, in the Clipboard group, click Copy.
  6. Switch to the destination file to which you want to paste the Visio object.

    For example, if you want to paste the Visio object to a Microsoft Word document, start Word, and then open the document to which you want to paste the Visio object.
  7. On the Edit menu, click Paste or Paste Special to insert the Visio object.

    In Visio 2010, on the Home tab, in the Clipboard group, click Paste or Paste Special to insert the Visio object.

Method 2: Use the Select All command

To use the Select All command, follow these steps:
  1. Start Visio, and then open your drawing.
  2. On the Edit menu, click Select All.

    In Visio 2010, on the Home tab, in the Editing group, click Select, and then click Select All.
  3. Switch to the destination file to which you want to paste the Visio object.

    For example, if you want to paste the Visio object to a Word document, start Word, and then open the document to which you want to paste the Visio object.
  4. On the Edit menu, click Paste or Paste Special to insert the Visio object.

    In Visio 2010, on the Home tab, in the Clipboard group, click Paste or Paste Special to insert the Visio object.

Method 3: Use the Copy Drawing command

To use the Copy Drawing command, follow these steps:
  1. Start Visio, and then open your drawing.
  2. Make sure that there is nothing selected in Visio.
  3. On the Edit menu, click Copy Drawing.

    In Visio 2010, on the Home tab, in the Clipboard group, click Copy.

    This command copies the page of the drawing that you are viewing.
  4. Switch to the destination file to which you want to paste the Visio object.
    For example, if you want to paste the Visio object to a Word document, start Word, and then open the document to which you want to paste the Visio object.
  5. On the Edit menu, click Paste or Paste Special to insert the Visio object.

    In Visio 2010, on the Home tab, in the Clipboard group, click Paste or Paste Special to insert the Visio object.

Method 4: Save the Visio drawing as a graphic file

To save a Visio drawing as a graphic file, follow these steps:
  1. Start Visio, and then open your drawing.
  2. Select the objects that you want to copy.

    Note If you want to copy the whole drawing page, make sure that no objects are selected in your Visio drawing. If you select objects in your drawing, only the objects that you select appear in the resulting graphic file.
  3. On the File menu, click Save As.
  4. In the Save as type list, click the graphic file type that you want, and then click Save.

    The following graphic file types are common among Visio 2007, Visio 2003, Visio 2002, and Visio 2000. These common graphic file types are listed in the Save as type box:
    • Enhanced Metafile (*.emf)
    • Graphics Interchange Format (*.gif)
    • JPEG File Interchange Format (*.jpg)
    • Portable Network Graphics (*.png)
    • Tag Image File Format (*.tif)
    • Compressed Enhanced Metafile (*.emz)
    • Windows Bitmap (*.bmp; *.dib)
    • Windows Metafile (*.wmf)
    In Visio 2010, Visio 2007, and Visio 2003, the following graphic file types are listed in addition to the common graphic file types:
    • Scalable Vector Graphics - Compressed (*.svgz)
    • Scalable Vector Graphics (*.svg)
    In Visio 2002 and in Visio 2000, the following graphic file types are listed in addition to the common graphic file types:
    • Macintosh PICT Format (*.pct)
    • Zsoft PC Paintbrush Bitmap (*.pcx)
    • Adobe Illustrator File (*.ai)
    • Computer Graphics Metafile (*.cgm)
    • Encapsulated PostScript File (*.eps)
    • PostScript File (*.ps)
    • IGES Drawing File Format (*.igs)
    Note When you export a shape or drawing by using the Save As dialog box, an Output Options dialog box may appear so that you can specify the settings that you want for the exported file. The options that appear in the Output Options dialog box depend on the graphic file format that you use.
  5. Switch to the destination file to which you want to paste the Visio object.

    For example, if you want to paste the Visio object to a Word document, start Word, and then open the document to which you want to paste the Visio object.
  6. On the Insert menu, point to Picture, and then click From File.

    In Visio 2010, on the Insert tab, in the Illustrations group, click Picture.
  7. Select the graphic file that you saved from Visio, and then click Insert.

    In Visio 2010, click Open.

    Note This method preserves the formatting of the shapes, the text, and the fill. However, the layer properties are not retained. For example, if a shape is located on a hidden layer, that shape is not visible when you insert the graphic file.

Method 5: Use the Insert Visio Drawing button in Visio 2000

This method applies only to Visio 2000. To install and use the Insert Visio Drawing button, follow these steps:
  1. To install the Insert Visio Drawing button on the toolbar in Word, Microsoft Excel, and Microsoft PowerPoint, run the Insert Visio Buttons program. Typically, this program is located in the following folder:
    C:\Program Files\Microsoft Visio\System\Custom
  2. To use the button, click Insert Visio Drawing, and then click Browse Templates in the Choose Drawing Type dialog box.
  3. In the Choose a Drawing Template dialog box, click Drawing (*.vsd) under Files of type. Click the drawing that you want to import, and then click Open.

    Note If layers are locked or hidden, you must first unhide and unlock the layers to include all the elements of your drawing.

REFERENCES

For more information about the formats in Visio 2007 that you can use to export Visio shapes and drawings, see Visio 2007 Help. To do this, click Microsoft Office Visio Help on the Help menu, type export shapes in the Search for box, and then press ENTER to view the topics.

For more information about the formats that you can use to export Visio shapes and drawings in Visio 2003, see Visio 2003 Help. To do this, click Microsoft Office Visio Help on the Help menu, type export shapes in the Search for box, and then press ENTER to view the topics.

For more information about the formats that you can use to export Visio shapes and drawings in Visio 2002, see Visio 2002 Help. To do this, click Microsoft Visio Help on the Help menu, type export shapes in the Ask a question box or in the Answer Wizard, and then press ENTER to view the topics.


Properties

Article ID: 296826 - Last Review: September 12, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio Professional 2010
  • Microsoft Visio Premium 2010
  • Microsoft Visio Standard 2010
Keywords: 
kbhowto KB296826

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com