How to reduce the size of a Visio drawing file in Visio

Article translations Article translations
Article ID: 305025 - View products that this article applies to.
This article was previously published under Q305025
For a Microsoft Visio 2000 version of this article, see 255020.
Expand all | Collapse all

On This Page

SUMMARY

This article contains information about the methods that you can use to reduce the size of Microsoft Visio drawing files in Microsoft Office Visio 2007, Microsoft Office Visio 2003 and in Microsoft Visio 2002.

INTRODUCTION

If you create large drawings (.vsd files) in Visio, you may want to reduce the size of the files. This article describes the following methods that you can use to reduce the size of a .vsd file:
  • Remove unused shapes in the local stencil.
  • Configure Visio to save the drawing with out a preview picture.
  • Reduce the number of grouped shapes.
  • Convert duplicate shapes to a single master shape.
  • Do not save your diagram as a XML for Visio drawing
Important Before you try any one of the methods that are discussed in this article, we recommend that you create a backup copy of your Visio drawing.

Remove unused shapes from the local stencil

The local stencil stores master shapes, including shapes that you deleted from the drawing page. An unused master shape can use unnecessary disk space. You can reduce the size of your drawing by removing these master shapes from the local stencil. To do this, use one of the following methods.

Method 1: Download and run the CleanIt Utility

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download cleanit2.exe now
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on secure servers that prevent any unauthorized changes to the file.

Note Microsoft Product Support Services (PSS) does not provide technical support for this tool.

Method 2: Delete unused master shapes

  1. Open the Visio drawing, point to Shapes on the File menu, and then click Show Document Stencil.
  2. Delete the master shapes that the local stencil is not using.

    Visio warns you if any master shapes are being used by your diagram. If you receive this warning, click Cancel.
  3. Click Close to close the stencil.
  4. Save your drawing.
The drawing file size is reduced.

Split a multiple-page drawing into separate drawings

If you have to reduce the file size of a multiple-page drawing to transfer it electronically, or if you have to save the drawing to a floppy disk, consider saving each page of your Visio drawing as a separate drawing. Use the Save As command to split the multiple-page drawing into several files. To do this, follow these steps:
  1. Open the Visio drawing.
  2. On the File menu, click Save As, type a new file name, and then click OK.

    For example, type filename_pageX.vsd, where filename is the name of your document, and pageX is the page number.
  3. Repeat step 2 for each page of your drawing.

    For example, save page 1 as filename_page1.vsd, and save page 2 as filename_page2.vsd.
  4. For each new Visio drawing file, delete the other pages that do not correspond with the file name. Right-click the Page tab for the page that you want to delete, and then click Delete Page.

    For example, if your drawing has four pages, and you open the filename_page2.vsd file, delete pages 1, 3, and 4.
  5. On the File menu, click Save, and then repeat these steps for each drawing.
You now have separate Visio files for each page of your drawing.

Configure Visio to save the drawing without a preview picture

You can reduce the file size of your drawing if you configure Visio to save the drawing without a preview picture. To do this, follow these steps:
  1. On the File menu, click Properties.
  2. In the Properties dialog box, click the Summary tab.
  3. Click to clear the Save preview picture check box, and then click OK.

Reduce the number of grouped shapes

If your Visio diagram includes many grouped shapes, your diagram can become very large and complex. Reducing the number of levels of grouping can help reduce the size and the complexity of your files. To reduce the levels of grouping, follow these steps:
  • Use commands that are displayed on the Operations submenu, such as Combine command.
  • Convert the grouped shape to a Microsoft Windows Metafile (WMF).
To convert a grouped shape to a Windows Metafile (WMF):
  1. On the Edit menu, click Copy.
  2. On the Edit menu, click Paste Special. The Paste Special dialog box appears.
  3. Click Picture, and then click OK.

Convert duplicate shapes to a single master shape

If you created shapes in your Visio drawing, consider converting duplicate shapes to masters. When you create a master shape, Visio stores it in the drawing's local stencil. When you drag a shape to a stencil, a master shape icon that is based on the shape appears in the stencil window.

For example, instead of your drawing containing 20 copies of a shape, your drawing can contain a single copy of the shape. That is, your drawing can contain a master shape and the instances of the master shape as references. The references use less disk space than duplicate copies of the shape.

To convert a shape to a master, follow these steps:
  1. In the Drawing window, display the shape that you want to convert to a master, or draw a shape that you want to convert.
  2. On the File menu, click Open, and then select the stencil file (.vss file) where you want to store the new master.
  3. Click Original or click Copy, and then click Open.
  4. Click the drawing page to make it active, and then drag the shape from the drawing page and drop it on the stencil. You can create a copy of the shape by holding down the CTRL key while you drag.

    The shape icon appears with a label "Master.X," where X is a number that represents the number of shapes on the stencil.
  5. Click the stencil to make it active. On the File menu, click Save to save the changes to the stencil.

Do not save your drawing as an XML drawing (.vdx file)

Visio lets you save your drawing in XML format. When you save a drawing as an .vdx file, the size of the file increases 1000 percent. For example, a drawing that is 500 kilobytes (KB) increases to almost 5 megabytes (MB) when it is saved as an XML drawing. This increase is because .vdx files are strictly text files.

For more information about XML for Visio, visit the following Microsoft Web site:
http://office.microsoft.com/en-us/visio/HP850526991033.aspx

REFERENCES

For more information about how to combine shapes or about how to create shapes, click Microsoft Office Visio Help on the Help menu, type shapes in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.
For more information about XML for Visio, click Microsoft Office Visio Help on the Help menu, type XML in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.

Properties

Article ID: 305025 - Last Review: September 12, 2007 - Revision: 2.3
APPLIES TO
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Keywords: 
kbhowtomaster kbconfig kbsavefile kbopenfile kbhowto KB305025

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com