Como reduzir o tamanho de um arquivo de desenho do Visio no Visio

Traduções deste artigo Traduções deste artigo
ID do artigo: 305025 - Exibir os produtos aos quais esse artigo se aplica.
Para uma versão deste artigo do Microsoft Visio 2000, consulte 255020.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo contém informações sobre os métodos que você pode usar para reduzir o tamanho do desenho arquivos no Office Visio 2007, Microsoft Office Visio 2003 e no Microsoft Visio 2002 do Microsoft Visio.

INTRODUÇÃO

Se você criar desenhos grandes (arquivos .vsd) no Visio, você pode querer reduzir o tamanho dos arquivos. Este artigo descreve os seguintes métodos que você pode usar para reduzir o tamanho de um arquivo .vsd:
  • Remova formas não utilizadas no estêncil local.
  • Configure o Visio para salvar o desenho com check-out uma imagem de visualização.
  • Reduza o número de formas agrupadas.
  • Converta formas duplicadas em uma forma do mestre única.
  • Não salvar seu diagrama como um XML para desenho do Visio
importante Antes de tentar qualquer um dos métodos descritos neste artigo, recomendamos que você crie uma cópia de backup de seu desenho do Visio.

Remover as formas não utilizadas do estêncil local

O estêncil local armazena formas do mestre, incluindo formas que você excluiu da página de desenho. Uma forma mestre não utilizada pode usar espaço em disco desnecessários. Você pode reduzir o tamanho do desenho, removendo essas formas do mestre do estêncil local. Para fazer isso, use um dos seguintes métodos.

Método 1: Baixar e executar o utilitário CleanIt

O seguinte arquivo está disponível para download no Centro de download da Microsoft:
Recolher esta imagemExpandir esta imagem
Download
Download cleanit2.exe now
Para obter informações adicionais sobre como baixar arquivos de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
119591Como obter arquivos de suporte da Microsoft a partir de serviços online
Microsoft examinou esse arquivo em busca de vírus. Microsoft utilizou o mais recente software de detecção de vírus que estava disponível na data em que o arquivo foi publicado. O arquivo é armazenado em servidores seguros que evitam qualquer alteração não autorizada para o arquivo.

Observação Serviços de suporte de produto da Microsoft (PSS) não fornece suporte técnico para esta ferramenta.

Método 2: Excluir formas do mestre não utilizadas

  1. Abra o desenho do Visio, aponte para formas no menu arquivo e, em seguida, clique em Mostrar Estêncil de documento .
  2. Exclua as formas do mestre que o estêncil local não está usando.

    O Visio avisará se quaisquer formas do mestre estão sendo usadas por seu diagrama. Se você receber esse aviso, clique em Cancelar .
  3. Clique em Fechar para fechar o estêncil.
  4. Salve seu desenho.
O tamanho de arquivo de desenho é reduzido.

Dividir um desenho em desenhos separados de várias páginas

Caso você precise reduzir o tamanho de uma várias-página de desenho para transferi-lo eletronicamente do arquivo, ou se você tem que salvar o desenho em um disquete, considere salvar cada página de desenho como um desenho separado do Visio. Use o comando Salvar como para dividir a desenho em vários arquivos de várias páginas. Para fazer isso, execute as seguintes etapas:
  1. Abra o desenho do Visio.
  2. No menu arquivo , clique em Salvar como , digite um novo nome de arquivo e em seguida, clique em OK .

    Por exemplo, tipo de filename _ pageX .vsd , onde filename é o nome do documento e pageX é o número da página.
  3. Repita a etapa 2 para cada página do desenho.

    Por exemplo, salvar a página 1 como filename _page1.vsd e salvar a página 2 como filename _page2.vsd .
  4. Para cada novo arquivo de desenho do Visio, exclua as outras páginas que não correspondem com o nome de arquivo. Clique com o botão direito do mouse a guia de página para a página que você deseja excluir e clique em Excluir página .

    Por exemplo, se seu desenho possui quatro páginas e você abrir o arquivo _page2.vsd de filename, exclua páginas 1, 3 e 4.
  5. No menu arquivo , clique em Salvar e, em seguida, repita essas etapas para cada desenho.
Agora você tem arquivos Visio separados para cada página do desenho.

Configurar o Visio para salvar o desenho sem uma imagem de visualização

Você pode reduzir o tamanho de arquivo do desenho se você configurar o Visio para salvar o desenho sem uma imagem de visualização. Para fazer isso, execute as seguintes etapas:
  1. No menu arquivo , clique em Propriedades .
  2. Na caixa de diálogo Propriedades , clique na guia Resumo .
  3. Clique para desmarcar a caixa de seleção Salvar visualização da imagem e, em seguida, clique em OK .

Reduzir o número de formas agrupadas

Se o diagrama do Visio inclui muitas formas agrupadas, seu diagrama pode se tornar muito grandes e complexos. Reduzindo o número de níveis de agrupamento pode ajudar a reduzir o tamanho e a complexidade de seus arquivos. Para reduzir os níveis de agrupamento, execute essas etapas:
  • Use os comandos que são exibidos no submenu operações , como combinar os comandos.
  • Converta forma agrupada a um metarquivo do Microsoft Windows (WMF).
Para converter uma forma agrupada a um metarquivo do Windows (WMF):
  1. No menu Editar , clique em Copiar .
  2. No menu Editar , clique em Colar especial . A caixa de diálogo Colar especial será exibida.
  3. Clique em imagem e, em seguida, clique em OK .

Converter formas duplicadas em uma forma do mestre única

Se você criou formas no desenho do Visio, considere converter formas duplicadas mestres. Quando você cria uma forma do mestre, o Visio o armazena no estêncil local do desenho. Quando você arrasta uma forma em um estêncil, um ícone de forma do mestre que baseia-se a forma aparece na janela de estêncil.

Por exemplo, em vez do desenho que contém 20 cópias de uma forma, seu desenho pode conter uma única cópia da forma. Ou seja, o desenho pode conter uma forma do mestre e as instâncias da forma do mestre como referências. As referências usam menos espaço em disco que cópias duplicadas da forma.

Para converter uma forma para um mestre, execute estas etapas:
  1. Na janela de desenho, exibir a forma que você deseja converter em um mestre ou desenhar uma forma que você deseja converter.
  2. No menu arquivo , clique em Abrir e, em seguida, selecione o arquivo de estêncil (arquivo .vss) onde você deseja armazenar o novo mestre.
  3. Clique em original ou clique em Copiar e, em seguida, clique em Abrir .
  4. Clique na página torná-la ativa, em seguida, arraste a forma da página de desenho e solte-o no estêncil de desenho. Você pode criar uma cópia da forma mantendo pressionada a tecla CTRL enquanto arrasta.

    O ícone de forma aparece com um rótulo "Mestre. X," onde X é um número que representa o número de formas no estêncil.
  5. Clique no estêncil para ativá-la. No menu arquivo , clique em Salvar para salvar as alterações para o estêncil.

Não salvar seu desenho como um desenho XML (arquivo .vdx)

Visio permite que você salvar seu desenho no formato XML. Quando você salva um desenho como um arquivo .vdx, o tamanho do arquivo aumenta 1000 %. Por exemplo, um desenho que é 500 quilobytes (KB) aumenta para quase 5 megabytes (MB) quando ele for salvo como um desenho do XML. Esse aumento é porque os arquivos de .vdx estritamente são arquivos de texto.

Para obter mais informações sobre XML para Visio, visite o seguinte site:
http://office.microsoft.com/en-us/visio/HP850526991033.aspx

Referências

Para obter mais informações sobre como combinar formas ou sobre como criar formas, clique em Ajuda do Microsoft Office Visio , no menu Ajuda , digite as formas no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.
Para obter mais informações sobre XML para Visio, clique em Ajuda do Microsoft Office Visio , no menu Ajuda , digite XML no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir os tópicos retornados.

Propriedades

ID do artigo: 305025 - Última revisão: quarta-feira, 12 de setembro de 2007 - Revisão: 2.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Palavras-chave: 
kbmt kbhowtomaster kbconfig kbsavefile kbopenfile kbhowto KB305025 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 305025

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com