How to create custom toolbars and tool buttons in Visio

Article translations Article translations
Article ID: 305069 - View products that this article applies to.
This article was previously published under Q305069
Expand all | Collapse all

On This Page

SUMMARY

This article describes how you can customize and create toolbars and toolbar buttons. You can customize any toolbar by adding, deleting, moving, or grouping toolbar buttons to suit your needs.

Microsoft Office Visio includes several built-in toolbars, including the two default toolbars that are visible when you start Visio: the Standard toolbar and the Formatting toolbar. The Standard toolbar includes command buttons that let you quickly access many of the frequently used commands, such as Save, Open, Copy, Paste, and so on. The Formatting toolbar provides quick access to formatting commands, including Bold, Italic, Underline, Line Color, Fill Color, and so on.

To see a list of available toolbars, point to Toolbars on the View menu. The available toolbars appear on the Toolbars submenu. The toolbars that are currently visible in the Visio window are selected (check marks appear next to them). To view and use a toolbar, you must select it on the Toolbars submenu. To select it (make it visible on the Visio screen), click the toolbar name.

NOTE: Creating and customizing menus in Visio is similar to the way you create and customize your toolbars. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
305060 How to customize, create, and restore menus in Visio 2002 or in Visio 2003

MORE INFORMATION

How to Add a Button to an Existing Toolbar

To add a button to an existing toolbar, use one of the following methods.

Method 1: Use the Customize Command on the Toolbars Submenu

  1. On the View menu, point to Toolbars, and then click Customize.

    NOTE: You can also open the Customize dialog box by clicking Customize on the Tools menu.
  2. In the Customize dialog box, click the Commands tab. Under Categories, select the category from which you want to add a button.

    The Categories list displays categories of commands, organized by menu name or by type. The Built-in Menus category provides options for changing menus.
  3. Click a category to change the list of commands that appear in the Commands box, on the right side of the Customize dialog box.
  4. To add a button to a toolbar that is displayed, drag the button from the Commands box to the toolbar.

    For example, under Categories, click File. In the Commands box, click Browse Sample Drawings, and drag it to the Standard toolbar. Release the mouse button when you see a vertical bar indicating the position of the button.

Method 2: Use the Toolbar Options Button on the Toolbar

  1. On the end of the toolbar, click Toolbar Options, and then click Add or Remove Buttons. A submenu appears.

    NOTE: The Toolbar Options button appears on most (not all) toolbars only when the toolbar is docked. To dock a toolbar, either double-click the title bar of the floating toolbar, or drag it to a docked position.
  2. To add a button to the toolbar, select the check box next to the button that you want to add. To remove a button from the toolbar, click to clear the check box next to the button on the submenu.

How to Change the Image of an Existing Button

  1. Display the toolbar where the button you want to change appears.
  2. On the Tools menu, click Customize.
  3. When the Customize dialog box appears, right-click the button on the toolbar, and point to Change Button Image on the menu that appears. A selection of images appears. Click the button image that you want to use as your custom button image.

    NOTE: If you change the image and then decide that it is not what you want, you cannot revert to the original image. However, you can drag the button with the wrong image off the toolbar and add another image from the Customize dialog box (click the Commands tab).
If you want to modify a button image, follow these steps:
  1. On the Tools menu, click Customize.
  2. When the Customize dialog box appears, right-click the button you want to modify, and then click Edit Button Image.
  3. The Edit Button dialog box appears. Make any changes that you want, and then click OK.
You cannot change the image of a button that displays a list or menu when you click it.

How to Modify Toolbar Buttons

  1. On the Tools menu, click Customize.
  2. Click the Toolbars tab.
  3. Use the appropriate procedure from the following table.
      To do this           Use this procedure
      ------------------------------------------------------------------------
    
      Move a button        Drag the button you want to the new location on the
                           same toolbar or to another displayed toolbar.
    
      Copy a button        While holding down CTRL, drag the button to the new
                           location on the same toolbar or to another displayed
                           toolbar.
    
      Remove a button      Click the button you want to remove, and drag it off
                           the toolbar. 
    
      Restore a button     If you accidentally remove a button that you need,
                           you can restore it by following the steps in the
                           "How to Add a Button to an Existing Toolbar"
                           section of this article.
    					

How to Create a New Toolbar

  1. On the View menu, point to Toolbars, and then click Customize.
  2. Click the Toolbars tab, and then click New.
  3. In the Toolbar Name box, type a name for your new custom toolbar.
  4. In the Make toolbar available to box, click the template or open document where you want to store the toolbar.
  5. Click OK. The Customize dialog box appears.
  6. Click the Commands tab. Click the category from which you want to select your button. Under Commands, drag the button you want to the new toolbar.
  7. Click Close.

How to Delete a Custom Toolbar

  1. On the View menu, point to Toolbars, and then click Customize.
  2. Click the Toolbars tab.
  3. Under Toolbars, click the custom toolbar that you want to delete, and then click Delete.

    NOTE: You cannot delete a built-in toolbar. When you select a built-in toolbar in the Toolbars list, the Delete button is unavailable, and the Reset button becomes available. Clicking the Reset button returns the built-in toolbar to its original default appearance.

How to Move a Toolbar

To move a toolbar from its docked position at the top of the Visio window, point to the two vertical bars on the left end of the toolbar. When the four-headed arrow appears, drag the toolbar to a new location.

To move a floating toolbar, click the title bar of the toolbar window, and then drag the toolbar to the new location.

How Toolbar Changes are Stored

When you create a custom toolbar or modify an existing toolbar, the changes are stored in the Microsoft Visio Custom Toolbars file (Custom.vsu). You can also attach a custom toolbar to a drawing. To do this, follow these steps:
  1. Open the Visio drawing in which you want to include a custom toolbar.
  2. On the Tools menu, click Customize, and then click the Toolbars tab.
  3. Click Attach to display the Attach Toolbars dialog box.

    NOTE: On the left is a list of the custom toolbars that are stored in the Custom.vsu file; on the right is a list of the custom toolbars that are stored in the drawing.
  4. In the Custom Toolbars list, click the toolbar that you want to store in the drawing file.
  5. Click Copy. The toolbar will appear in the list on the right and be stored in the drawing file.
  6. Click OK.
NOTE: You can delete custom toolbars stored in a drawing file from the Attach Toolbars dialog box. However, you can only delete custom toolbars from the Custom.vsu file. To delete a custom toolbar from the Custom.vsu file, click Customize on the Tools menu, click the Toolbars tab, click the custom toolbar name that you want to delete, and then click Delete.

You can delete custom toolbars stored in a drawing file from the Attach Toolbars dialog box. However, you can only delete custom toolbars from the Custom.vsu file by clicking the Delete button in the Tools Customize Toolbars dialog box.

Properties

Article ID: 305069 - Last Review: November 14, 2006 - Revision: 4.1
APPLIES TO
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Visio 2002 Professional Edition
Keywords: 
kbtoolbar kbhowto kbinfo KB305069

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com